Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: No gpu support after update nvidia

  1. #1
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default No gpu support after update nvidia

    openSUSE 12.3 x86_64
    I have installed 1-click install for openSUSE and had always gpu support for my applications like blender.
    After the latest package update to nvidiaG03 331.67-26-1x86_64 there is no gpu support anymore ?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: No gpu support after update nvidia

    Code:
    rpm -qa | grep nvidia
    Code:
    rpm -qa | grep kernel
    Code:
    uname -a
    Please supply the above
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: No gpu support after update nvidia

    Code:
    anton@linux-nfs:~> rpm -qa | grep nvidia
    nvidia-computeG03-331.67-26.1.x86_64
    nvidia-glG03-331.67-26.1.x86_64
    x11-video-nvidiaG03-331.67-26.1.x86_64
    nvidia-gfxG03-kmp-desktop-331.67_k3.7.10_1.1-26.1.x86_64
    Code:
    anton@linux-nfs:~> rpm -qa | grep kernel
    kernel-desktop-3.7.10-1.28.1.x86_64
    kernel-firmware-20130714git-1.9.1.noarch
    kernel-desktop-devel-3.7.10-1.28.1.x86_64
    kernel-devel-3.7.10-1.24.1.noarch
    nfs-kernel-server-1.2.7-2.18.1.x86_64
    kernel-desktop-devel-3.7.10-1.24.1.x86_64
    kernel-desktop-3.7.10-1.24.1.x86_64
    kernel-devel-3.7.10-1.28.1.noarch
    anton@linux-nfs:~>
    Code:
    anton@linux-nfs:~> uname -a
    Linux linux-nfs.site 3.7.10-1.28-desktop #1 SMP PREEMPT Mon Feb 3 14:11:15 UTC 2014 (c9a2c6c) x86_64 x86_64 x86_64 GNU/Linux

  4. #4

    Default Re: No gpu support after update nvidia

    Your packages look fine.

    Could you please post the file /var/log/Xorg.0.log? (Upload it to http://susepaste.org or similar and post a link)

    What graphics card do you actually have?

    Please install the package "Mesa-demo-x" if not installed and post the output of:
    Code:
    glxinfo | grep render

  5. #5
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: No gpu support after update nvidia

    http://susepaste.org/90405004

    Graphic card is Zotac Geforce GTX 580


    Code:
    anton@linux-nfs:~> glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: GeForce GTX 580/PCIe/SSE2
        GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    anton@linux-nfs:~>

  6. #6

    Default Re: No gpu support after update nvidia

    Quote Originally Posted by anton View Post
    Unfortunately this contains only the first few lines.
    But I guess we don't need the full one anyway.

    Code:
    anton@linux-nfs:~> glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: GeForce GTX 580/PCIe/SSE2
        GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render, 
        GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
        GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    anton@linux-nfs:~>
    So the nvidia driver is working, you do have full GPU support.

    Could you maybe explain your actual problem(s) in more detail please?

  7. #7
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: No gpu support after update nvidia

    Full Xorg.0.log : http://susepaste.org/70542638

    I have no GPU support anymore within blender 2.70a always have, nothing has changed only nvidia package is updated as you can read above.
    Since then I can only choose CPU support in blender.

  8. #8

    Default Re: No gpu support after update nvidia

    Quote Originally Posted by anton View Post
    Full Xorg.0.log : http://susepaste.org/70542638

    I have no GPU support anymore within blender 2.70a always have, nothing has changed only nvidia package is updated as you can read above.
    Since then I can only choose CPU support in blender.
    Hm, and where did you install blender from? Packman maybe?

    Mine doesn't even have that option (2.67 from the standard openSUSE repo).

    Anyway, your driver is working fine as already mentioned. Maybe there's an incompatibility between blender and the 331.67 driver version?
    You could try to switch back to the G02 driver.

    Otherwise I have no idea, sorry.

  9. #9
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    671

    Default Re: No gpu support after update nvidia

    Blender is no packman version its originally you can download unpack and start blender just that easy.
    There has nothing changed to my blender version it was working fine.
    With YaST i updated installed packages as i always do.
    The nvidia driver is that way updated and after restarting my computer I had no gpu support anymore within blender.
    I always used version nvidia G03 was never a problem.

    How can I test gpu working.

  10. #10

    Default Re: No gpu support after update nvidia

    Quote Originally Posted by anton View Post
    Blender is no packman version its originally you can download unpack and start blender just that easy.
    What does originally mean?
    Blender is open source, so you can download the source and compile it.
    That's what openSUSE does, that's what Packman does. And they provide binary RPM packages then.
    That doesn't mean it's not original.

    There has nothing changed to my blender version it was working fine.
    With YaST i updated installed packages as i always do.
    The nvidia driver is that way updated and after restarting my computer I had no gpu support anymore within blender.
    Yes, you already stated that.

    So the only change was the nvidia driver update.
    And that's why I suspect an incompatibility between your blender version and the new nvidia driver version.

    Btw, I now read on the blender wiki, that it needs to compile the render kernel when it is started the first time. So maybe it's just that kernel that would need to be re-compiled?
    I'm not sure where blender would store the compiled kernel, but I suppose it would be in the home directory.
    So maybe try whether it works with a new user?

    PS: I installed 2.70a (from Packman) now, and it does have that option. I also can only select CPU, but in my case it's because my gfx card doesn't support rendering I suppose. (it's an old Radeon 9600)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •