Results 1 to 6 of 6

Thread: JEOS doesnt open Qt Apps

  1. #1

    Question JEOS doesnt open Qt Apps

    Hi,

    I created a JEOS image to work on embedded board (Intel Atom N450).I added softwares about qt devel, razor also xterm ,xrandr but they all doesnt work :

    xterm: "Xt error :Cant open display: %s"
    qt apps : "calculator: cannot open X server "

    do I need add any package for openSuse jeos to open Qt apps?

    pls help me to solve this problem.

  2. #2

    Default Re: JEOS doesnt open Qt Apps

    If I write "xinit ./calculator -qws" it works but when I try "./calculator -qws" it doesnt work cannot connect X server.

    Pls help to solve this.

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,932

    Default Re: JEOS doesnt open Qt Apps

    Which desktop. note you must be running X to run a graphic app.

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,069

    Default Re: JEOS doesnt open Qt Apps

    Install xhost and then run xhost +localhost and try again.
    .: miuku #suse @ irc.freenode.net

  5. #5

    Question Re: JEOS doesnt open Qt Apps

    I am using Ubuntu 14.04 as a Desktop, I just want to work Qt apps on frame buffer I dont want to use X.I will try xhost +localhost.

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,069

    Default Re: JEOS doesnt open Qt Apps

    Ah so you are remotely connecting via ssh to the box?

    If so, you need to allow the SUSE box to connect to your Ubuntu Xorg - you need to set the display variable to point to your Ubuntu desktop.
    .: miuku #suse @ irc.freenode.net

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •