Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Problem installing ffmpeg on OpenSUSE 13.1

  1. #1

    Default Problem installing ffmpeg on OpenSUSE 13.1

    Hello,

    I am a new comer to this forum and to opensuse (but not new to Linux ) . I am having some problems in installing ffmpeg on opensuse 13.1. Following is the output I get while trying to install ffmpeg.

    Code:
    ahsan@linux-51zl:~> sudo zypper install ffmpeg
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: ffmpeg-2.2-1.4.x86_64 requires libswscale2 = 2.2, but this requirement cannot be provided
      uninstallable providers: libswscale2-2.2-1.4.i586[ftp.gwdg.de-suse]
                       libswscale2-2.2-1.4.x86_64[ftp.gwdg.de-suse]
     Solution 1: install libswscale2-2.2-1.4.x86_64 (with vendor change)
      openSUSE  -->  http://packman.links2linux.de
     Solution 2: do not install ffmpeg-2.2-1.4.x86_64
     Solution 3: do not install ffmpeg-2.2-1.4.x86_64
     Solution 4: break ffmpeg-2.2-1.4.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c] (c):
    Could someone help what exactly is the problem here?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    On 2014-05-12 01:16, mahsank wrote:

    >
    > Could someone help what exactly is the problem here?


    No problem at all, just choose libswscale2 from packman, solution 1.

    libswscale has two providers, or two repos to choose from. You can get
    2.0 from opensuse, or 2.2 from packman. ffmpeg wants 2.2, and you should
    be using packman for multimedia, anyway.

    There is a multimedia guide in the howto area, and a sticky on the
    multimedia area. read them both. The issue is that multimedia stuff with
    potential legal problems can not be provided directly on the corporate
    servers used by openSUSE, so they are provided by alternative groups.
    Packman is the main one.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    I don't have a good answer.

    I have version 2.1.1-3.3 installed here. However, the version in packman is different.

    It looks as if ffmpeg has been updated in packman, while some of its dependencies are not yet updated to match.

    Looking through the dependency list for libswscale2, it looks as if it needs an update to glibc.

    There's probably a pending update that has not yet been released.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    On 2014-05-12 03:26, nrickert wrote:
    >
    > I don't have a good answer.
    >
    > I have version 2.1.1-3.3 installed here. However, the version in
    > packman is different.
    >
    > It looks as if ffmpeg has been updated in packman, while some of its
    > dependencies are not yet updated to match.
    >
    > Looking through the dependency list for libswscale2, it looks as if it
    > needs an update to glibc.


    I have libswscale2-2.2-1.4 installed. All my packman things are updated,
    and I got no conflict at all, no missing parts.

    My glibc is 2.18-411.1 from oss-updates.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    Quote Originally Posted by robin_listas View Post
    I have libswscale2-2.2-1.4 installed. All my packman things are updated,
    and I got no conflict at all, no missing parts.
    I have 2.1.1-3.3 installed. And when I check updates with "zypper lu", it is not listed as an update. So something is blocking 2.2-1.4.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    On 2014-05-12 04:56, nrickert wrote:
    >
    > robin_listas;2642610 Wrote:
    >> I have libswscale2-2.2-1.4 installed. All my packman things are updated,
    >> and I got no conflict at all, no missing parts.

    >
    > I have 2.1.1-3.3 installed. And when I check updates with "zypper lu",
    > it is not listed as an update. So something is blocking 2.2-1.4.


    I got libswscale2 2.1.3-1.2 on Feb 20, and 2.2-1.3 on April 24. So, yes,
    you have something stuck.

    I would fire up yast (QT flavour), repository view, mark "@system", then
    secondary filter to "unmantained packages", and lets see what you find...

    And then select the packman repo, search for the libswscale2 package,
    and see in the version tab what you can find. Click to update it to the
    appropriate version, and see what it complains about, if anything.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    Quote Originally Posted by robin_listas View Post
    Click to update it to the
    appropriate version, and see what it complains about, if anything.
    It complains about a conflict with libavfilter3-2.1.1-3.3.x86_64
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    Quote Originally Posted by nrickert View Post
    It complains about a conflict with libavfilter3-2.1.1-3.3.x86_64
    Uninstall libavfilter3. It's the one from the older ffmpeg 2.1.1 (as the version number shows) and is not even available in the Packman repo any more.

    This blocks the installation of libavfilter4 which is required by ffmpeg 2.2.

    The OP's problem is not related to yours though.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    On 2014-05-12 10:46, wolfi323 wrote:
    >
    > nrickert;2642620 Wrote:
    >> It complains about a conflict with libavfilter3-2.1.1-3.3.x86_64

    > Uninstall libavfilter3. It's the one from the older ffmpeg 2.1.1 (as the
    > version number shows) and is not even available in the Packman repo any
    > more.


    It should then have displayed in red in the "unmantained packages"
    section I mentioned.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Problem installing ffmpeg on OpenSUSE 13.1

    Quote Originally Posted by robin_listas View Post
    It should then have displayed in red in the "unmantained packages"
    section I mentioned.
    Yes, it was. Is it good practice to remove packages that become unmaintained?
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •