Results 1 to 2 of 2

Thread: Problem with audio player

  1. #1

    Unhappy Problem with audio player

    I installed opensuse ldxm on my old laptop last week and tried to install one audio player called iceplayer today.

    Installation seemed good as no error occured during the process. However, by opening the player i found out such warning as followed.
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    (iceplayer:1675): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_bin_add_many: assertion 'GST_IS_ELEMENT (element_1)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_element_link_many: assertion 'GST_IS_ELEMENT (element_1)' failed
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    and a connection to gstreamer element failed also:
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    (iceplayer:1675): GStreamer-CRITICAL **: gst_element_get_static_pad: assertion 'GST_IS_ELEMENT (element)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_ghost_pad_new: assertion 'GST_IS_PAD (target)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_element_add_pad: assertion 'GST_IS_PAD (pad)' failed
    ** Message: don't know how to handle application/x-id3
    ----------------------------------------------------------------------------------------------------------------------------------------------------

    It looks like a problem with gstreamer and i am wondering what i should do next to fix this problem.


    All rpms installed relevant to gstreamer are listed.
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    gstreamer-0_10-0.10.36-10.1.3.i586
    gstreamer-libnice-0.1.4-2.1.4.i586
    gstreamer-0_10-devel-0.10.36-14.27.i586
    gstreamer-0_10-libnice-0.1.4-2.1.4.i586
    gstreamer-1.0.10-2.1.4.i586
    gstreamer-0_10-fluendo-mp3-18-2.2.1.i586
    gstreamer-0_10-utils-0.10.36-14.27.i586
    libgstreamer-0_10-0-0.10.36-10.1.3.i586
    PackageKit-gstreamer-plugin-0.8.11-2.3.1.i586
    libgstreamer-1_0-0-1.0.10-2.1.4.i586
    python-gstreamer-0_10-0.10.22-8.1.3.i586
    gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-12.5.i586
    gstreamer-0_10-plugins-bad-lang-0.10.23-24.46.noarch
    gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.4.i586
    gstreamer-plugins-good-1.0.10-2.1.4.i586
    gstreamer-0_10-plugins-base-0.10.36-9.1.4.i586
    gstreamer-plugins-base-1.0.10-2.4.1.i586
    gstreamer-plugin-gstclutter-2.0.8-3.1.i586
    gstreamer-plugins-farstream-0.2.3-2.1.3.i586
    gstreamer-0_10-plugin-gnomevfs-0.10.36-9.1.4.i586
    phonon-backend-gstreamer-0_10-4.7.1-2.12.1.i586
    gstreamer-0_10-plugins-bad-0.10.23-24.46.i586
    gstreamer-plugins-bad-1.0.10-2.5.4.i586
    gstreamer-0_10-plugins-ugly-0.10.19-12.5.i586
    ----------------------------------------------------------------------------------------------------------------------------------------------------

    Thanks in advance.

  2. #2

    Default Re: Problem with audio player

    problem solved. Installed another rpm to offer codes for id3-tag-demuxer.

    gstreamer-0_10-plugins-good-0.10.31-17.10.i586


    Quote Originally Posted by neilmellor View Post
    I installed opensuse ldxm on my old laptop last week and tried to install one audio player called iceplayer today.

    Installation seemed good as no error occured during the process. However, by opening the player i found out such warning as followed.
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    (iceplayer:1675): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_bin_add_many: assertion 'GST_IS_ELEMENT (element_1)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_element_link_many: assertion 'GST_IS_ELEMENT (element_1)' failed
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    and a connection to gstreamer element failed also:
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    (iceplayer:1675): GStreamer-CRITICAL **: gst_element_get_static_pad: assertion 'GST_IS_ELEMENT (element)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_ghost_pad_new: assertion 'GST_IS_PAD (target)' failed
    (iceplayer:1675): GStreamer-CRITICAL **: gst_element_add_pad: assertion 'GST_IS_PAD (pad)' failed
    ** Message: don't know how to handle application/x-id3
    ----------------------------------------------------------------------------------------------------------------------------------------------------

    It looks like a problem with gstreamer and i am wondering what i should do next to fix this problem.


    All rpms installed relevant to gstreamer are listed.
    ----------------------------------------------------------------------------------------------------------------------------------------------------
    gstreamer-0_10-0.10.36-10.1.3.i586
    gstreamer-libnice-0.1.4-2.1.4.i586
    gstreamer-0_10-devel-0.10.36-14.27.i586
    gstreamer-0_10-libnice-0.1.4-2.1.4.i586
    gstreamer-1.0.10-2.1.4.i586
    gstreamer-0_10-fluendo-mp3-18-2.2.1.i586
    gstreamer-0_10-utils-0.10.36-14.27.i586
    libgstreamer-0_10-0-0.10.36-10.1.3.i586
    PackageKit-gstreamer-plugin-0.8.11-2.3.1.i586
    libgstreamer-1_0-0-1.0.10-2.1.4.i586
    python-gstreamer-0_10-0.10.22-8.1.3.i586
    gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-12.5.i586
    gstreamer-0_10-plugins-bad-lang-0.10.23-24.46.noarch
    gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.4.i586
    gstreamer-plugins-good-1.0.10-2.1.4.i586
    gstreamer-0_10-plugins-base-0.10.36-9.1.4.i586
    gstreamer-plugins-base-1.0.10-2.4.1.i586
    gstreamer-plugin-gstclutter-2.0.8-3.1.i586
    gstreamer-plugins-farstream-0.2.3-2.1.3.i586
    gstreamer-0_10-plugin-gnomevfs-0.10.36-9.1.4.i586
    phonon-backend-gstreamer-0_10-4.7.1-2.12.1.i586
    gstreamer-0_10-plugins-bad-0.10.23-24.46.i586
    gstreamer-plugins-bad-1.0.10-2.5.4.i586
    gstreamer-0_10-plugins-ugly-0.10.19-12.5.i586
    ----------------------------------------------------------------------------------------------------------------------------------------------------

    Thanks in advance.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •