Results 1 to 6 of 6

Thread: Knacken zwischen zwei Titeln während der Musikausgabe

  1. #1

    Question Knacken zwischen zwei Titeln während der Musikausgabe

    Hallo Forum,

    ich bin auf dem Gebiet Linux noch recht neu. Trotzdem habe ich es gewagt, auf einem älteren Notebook Acer Aspire 1500 Open Suse 13.1 zu installieren. Dieses Notebook will ich einzig und allein zur Wiedergabe von Musik benutzen. Dies soll mit Amarok geschehen.


    Es funktioniert auch alles, jedoch habe ich einen unschönen Effekt. Zwischen zwei Musiktiteln ist ein deutliches Knackgeräusch aus den Lautsprechern zu hören. Der Soundchip ist wohl ein VIA 8235 mit AC97 Codec.


    Kann mir hier jemand helfen?


    Kompi

  2. #2

    Default Re: Knacken zwischen zwei Titeln während der Musikausgabe

    Quote Originally Posted by Kompi View Post
    Kann mir hier jemand helfen?
    Tja, ich würde mal probeweise PulseAudio abschalten.
    YaST->Hardware->Sound->Andere->PulseAudio Konfiguration.

    Außerdem kannst du auch probieren in den Einstellungen das Ausgabe-Backend zu wechseln.
    Standardmäßig wird gstreamer-0.10 benutzt, evtl. funktioniert VLC ja besser bei dir?
    Das Paket "phonon-backend-vlc" ist in den Standard Repos enthalten, du musst es aber erst händisch installieren.
    "vlc-codecs" sollte in dem Fall natürlich auch installiert sein. (erhältlich bei Packman z.B.)

  3. #3

    Default Re: Knacken zwischen zwei Titeln während der Musikausgabe

    Ich habe die Vorschläge ausprobiert, haben aber leider beide nicht gefruchtet.

    Auf diversen Internetseiten habe ich gelesen, dass solche Geräusche auch mit der Power Saving Einstellung der Audio Karte zusammenhängen könnte. Wo kann man dies denn im konkreten Fall einstellen?

    Kompi

  4. #4

    Default AW: Re: Knacken zwischen zwei Titeln während der Musikausgabe

    Quote Originally Posted by Kompi View Post
    Auf diversen Internetseiten habe ich gelesen, dass solche Geräusche auch mit der Power Saving Einstellung der Audio Karte zusammenhängen könnte. Wo kann man dies denn im konkreten Fall einstellen?
    Keine Ahnung. Ich musste diesbezüglich noch nie etwas tun.

    Evtl. in YaST->Hardware->Sound? (auf Bearbeiten klicken)
    Oder die Datei /etc/modprobe.d/50-sound.conf mit einem Texteditor editieren.
    Laut https://wiki.archlinux.org/index.php/Power_saving#Audio solltest du scheinbar an die Zeile mit "options" ein "power_safe=1" anhängen damit die Karte nach 1s in den "idle" Modus geht. "power_safe=0" würde das komplett abschalten.

    Du kannst das aber auch im laufenden Betrieb ändern, z.B.:
    Code:
    # echo 10 > /sys/module/snd_ac97_codec/parameters/power_save
    Sh. auch https://www.kernel.org/doc/Documenta.../powersave.txt

    Aber soweit ich das erkennen kann, sollte das eigentlich standardmäßig _aus_geschaltet sein, zumindest bei hda_intel und ac97.
    Welchen Treiber verwendest du denn?
    Kannst du vielleicht mal die Ausgabe von "/sbin/lspci -nnk | grep audio -A3" posten?

    PS: Scheinbar hab ich zumindest einen ähnlichen Chip wie du:
    Code:
    00:11.5 Multimedia audio controller [0401]: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller [1106:3059] (rev 60)
            Subsystem: ASUSTeK Computer Inc. A8V Deluxe motherboard (Realtek ALC850 codec) [1043:812a]
            Kernel driver in use: snd_via82xx
            Kernel modules: snd_via82xx
    Last edited by wolfi323; 12-May-2014 at 02:31.

  5. #5

    Default Re: Knacken zwischen zwei Titeln während der Musikausgabe

    Hier die Ausgabe des lspci - Befehls

    00:11.5 Multimedia audio controller [0401]: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller [1106:3059] (rev 50)
    Subsystem: Acer Incorporated [ALI] Device [1025:0046]
    Kernel driver in use: snd_via82xx
    Kernel modules: snd_via82xx

    Kompi

  6. #6

    Default Re: Knacken zwischen zwei Titeln während der Musikausgabe

    Quote Originally Posted by Kompi View Post
    Hier die Ausgabe des lspci - Befehls

    00:11.5 Multimedia audio controller [0401]: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller [1106:3059] (rev 50)
    Subsystem: Acer Incorporated [ALI] Device [1025:0046]
    Kernel driver in use: snd_via82xx
    Kernel modules: snd_via82xx
    Tja, ist ja wirklich fast gleich.
    Ich hab aber komischerweise kein Problem.

    Soweit ich das sehen kann, unterstützt der snd_via82xx allerdings überhaupt kein power_save, also wird das vorher vorgeschlagene nicht helfen.

    Diese Seite würde aber den Eindruck erwecken, dass die "dxs_support=1" (oder 4) Option helfen könnte:
    http://alsa.opensrc.org/Via_VT8235#noises_in_xmms

    Du kannst das wie schon gesagt entweder in YaST->Hardware->Sound->Bearbeiten oder direckt in /etc/modprobe.d/50-sound.conf angeben.

    Eventuell könntest du aber auch mal mit den Lautstärke-Reglern rumspielen. Ich habe schon seltsame Effekte erlebt (z.B. ein Brummen im Lautsprecher, wenn ich ein Fenster verschoben habe... ), wenn z.B. Master auf 100% war, und ich die Lautstärke nur mit den anderen Reglern (PCM z.B.) geregelt habe.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •