Results 1 to 6 of 6

Thread: Telnet: Connection Closed by Foreign Host

  1. #1

    Default Telnet: Connection Closed by Foreign Host

    Good day:

    I know just enough about Linux to get into trouble; appreciate your patience ... ;-)

    I've setup a SLES 11.3 server (Xen Hypervisor / SLES 11.3 DomU) as a gateway ahead of 3 network switches. I'm masquerading the switch management ip's.

    There are (2) 10G switches whose management interfaces are attached to a 1G Switch. The 1G switch employs in-band management. I've setup the port forwarding:

    0/0 8123 0/0 192.168.50.201 23
    0/0 8223 0/0 192.168.50.202 23
    0/0 8323 0/0 192.168.50.202 23
    0/0 8122 0/0 192.168.50.201 22
    0/0 8222 0/0 192.168.50.202 22
    0/0 8322 0/0 192.168.50.202 22

    Remotely I can Telnet or SSH w/ no issues into the 10G switches but attempts to get into the 1G results in no activity and the client window closes OR I'll get a login challenge but the console appears unresponsive and the client window eventually closes.

    From the Guest VM I get the login challenge; I can enter credentials; the connection opens; then immediately closes w/ the message "Connection Closed by Foreign Host".

    I can ping all the switches via the private network but the 1G shows response times approaching .5 secs ....

    From the vantage point of the private network I can Telnet/SSH perfectly fine.

    Being a total dunce .. I appreciate any suggestions as to how to debug this ..

    THANKS !!!

    BTW - I understand this would be more appropriate at forums.Suse.com but I seem unable to post .. the button does not present itself

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Telnet: Connection Closed by Foreign Host

    On 2014-05-10 01:06, DBrenchley wrote:
    >
    > Good day:
    >
    > I know just enough about Linux to get into trouble; appreciate your
    > patience ... ;-)
    >
    > I've setup a SLES 11.3 server (Xen Hypervisor / SLES 11.3 DomU) as a




    > BTW - I understand this would be more appropriate at forums.Suse.com but
    > I seem unable to post .. the button does not present itself


    But openSUSE users can not help you, unless they also happen to be SUSE
    users. And then, they will be subscribed there already.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3

    Default Re: Telnet: Connection Closed by Foreign Host

    Thank You Carlos .. I'm sure the talent here is more than able to offer their opinion ..

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Telnet: Connection Closed by Foreign Host

    On Fri 09 May 2014 11:06:01 PM CDT, DBrenchley wrote:


    Good day:

    I know just enough about Linux to get into trouble; appreciate your
    patience ... ;-)

    I've setup a SLES 11.3 server (Xen Hypervisor / SLES 11.3 DomU) as a
    gateway ahead of 3 network switches. I'm masquerading the switch
    management ip's.

    There are (2) 10G switches whose management interfaces are attached to a
    1G Switch. The 1G switch employs in-band management. I've setup the port
    forwarding:

    0/0 8123 0/0 192.168.50.201 23
    0/0 8223 0/0 192.168.50.202 23
    0/0 8323 0/0 192.168.50.202 23
    0/0 8122 0/0 192.168.50.201 22
    0/0 8222 0/0 192.168.50.202 22
    0/0 8322 0/0 192.168.50.202 22

    Remotely I can Telnet or SSH w/ no issues into the 10G switches but
    attempts to get into the 1G results in no activity and the client window
    closes OR I'll get a login challenge but the console appears
    unresponsive and the client window eventually closes.

    From the Guest VM I get the login challenge; I can enter credentials;
    the connection opens; then immediately closes w/ the message "Connection
    Closed by Foreign Host".

    I can ping all the switches via the private network but the 1G shows
    response times approaching .5 secs ....

    From the vantage point of the private network I can Telnet/SSH perfectly
    fine.

    Being a total dunce .. I appreciate any suggestions as to how to debug
    this ..

    THANKS !!!

    BTW - I understand this would be more appropriate at forums.Suse.com but
    I seem unable to post .. the button does not present itself


    Hi
    Can you try posting in the SUSE forum again, else will have to see if
    the forums admin can sort your account out.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: Telnet: Connection Closed by Foreign Host

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Can you try posting in the SUSE forum again, else will have to see if
    the forums admin can sort your account out.
    No Joy Malcolm .. I can't even send them an email ..

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Telnet: Connection Closed by Foreign Host

    On 2014-05-10 15:46, DBrenchley wrote:
    >
    > malcolmlewis;2642242 Wrote:
    >> Hi
    >> Can you try posting in the SUSE forum again, else will have to see if
    >> the forums admin can sort your account out.

    >
    > No Joy Malcolm .. I can't even send them an email ..


    Try posting in this forum support area, or ask a moderator to move this
    thread there. Probably they can contact the other forum support people.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •