Results 1 to 10 of 10

Thread: outline numbering tool in LibreOffice missing 'separator' features

  1. #1
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default outline numbering tool in LibreOffice missing 'separator' features

    In LibreOffice 4.1.5.3 (current in the OpenSuse 13.1 repository) I find that features in the Outline numbering tool are greyed out. I've used them before and wonder if anyone knows what's happening. It is impossible to enter Before or After Separator in the numbering format. I want to add Article to Heading 1, Section to Heading 2, etc. Can't get on the LibreOffice web site (it seem to require a 'social network' membership which I don't have just to log in). Thanks.
    Leap/KDE and a film-based photographer

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: outline numbering tool in LibreOffice missing 'separator' features

    I cannot replicate the problem with the 32bit version of the same release.

  3. #3

    Default Re: outline numbering tool in LibreOffice missing 'separator' features

    Works fine here as well, in the standard LibreOffice 4.1.5.3 on a 64bit KDE system.

    What are your exact steps to reproduce the problem?

    Does it work for a new user, or if you remove/rename ~/.config/libreoffice/ ?

  4. #4
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default SOLVED Re: outline numbering tool in LibreOffice missing 'separator' features

    Sort-of solved. As this screen capture shows
    [IMG]/home/konsultor/Downloads/LinuxFeatures/LibreOffice-invisibleSeparators.jpeg[/IMG]

    the fields for the 'before' and 'after' separators are invisible. Didn't find them earlier, when I clicked in the area where I thought they should be. Turns out, they are there, just further to the right than I thought. So with some 'pin the tail on the donkey' work I was able to enter the separators and all is well with the world (or at least with my document).
    Leap/KDE and a film-based photographer

  5. #5

    Default Re: SOLVED Re: outline numbering tool in LibreOffice missing 'separator' features

    Quote Originally Posted by konsultor View Post
    Sort-of solved. As this screen capture shows
    [IMG]/home/konsultor/Downloads/LinuxFeatures/LibreOffice-invisibleSeparators.jpeg[/IMG]
    You should upload the picture to some sharing site like http://susepaste.org.
    Nobody here can access it on your local hard disk...

    the fields for the 'before' and 'after' separators are invisible. Didn't find them earlier, when I clicked in the area where I thought they should be. Turns out, they are there, just further to the right than I thought. So with some 'pin the tail on the donkey' work I was able to enter the separators and all is well with the world (or at least with my document).
    The buttons are visible here. Maybe some theming problem?

    Are you using the KDE or the GNOME integration?

  6. #6
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default Re: SOLVED Re: outline numbering tool in LibreOffice missing 'separator' features

    Quote Originally Posted by wolfi323 View Post
    You should upload the picture to some sharing site like http://susepaste.org.
    Nobody here can access it on your local hard disk...

    The buttons are visible here. Maybe some theming problem?

    Are you using the KDE or the GNOME integration?
    An here I thought the icon that said "Insert Image" meant the same as in a word processor and Craig's List.
    Tried the various themes available from Configure Desktop but the appearance was unchanged for the Outline Numbering dialog in LibreOffice. Perhaps when I have more time I'll restart KDE and LO, in case theme changes don't take effect immediately.
    Thanks for all the responses.
    Leap/KDE and a film-based photographer

  7. #7

    Default Re: SOLVED Re: outline numbering tool in LibreOffice missing 'separator' features

    Quote Originally Posted by konsultor View Post
    An here I thought the icon that said "Insert Image" meant the same as in a word processor and Craig's List.
    Well, it works similar. But you cannot upload a picture to the forum, so it has to be accessible over the Internet.

    Tried the various themes available from Configure Desktop but the appearance was unchanged for the Outline Numbering dialog in LibreOffice.
    And where exactly did you change the theme?
    With the KDE integration, LO uses the standard KDE theme, with the GNOME integration it uses the Gtk2 theme.
    If you have ibus installed, LO uses the GNOME integration even on KDE (if you have libreoffice-gnome installed, if not it uses its own thing).

    So, check whether you have ibus and/or libreoffice-gnome installed.
    I don't see the problem with the GNOME integration either, but maybe you're using neither KDE nor GNOME.
    But I cannot reproduce it in that case as well.

    Perhaps when I have more time I'll restart KDE and LO, in case theme changes don't take effect immediately.
    There should be no need to restart KDE.

  8. #8
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default Re: outline numbering tool in LibreOffice missing 'separator' features

    Checking for installed software, libreoffice-gnome is not installed, nor is ibus (though libibus is).
    My changes to theme are usually made from the Configure Desktop page, which is in the "start" menu, then Workspace Appearance. Have not yet played with Application Appearance, where I see there are many config options for GTK and other aspects.
    Rebooted the machine with no apparent effect. It is still

  9. #9

    Default Re: outline numbering tool in LibreOffice missing 'separator' features

    Quote Originally Posted by konsultor View Post
    Checking for installed software, libreoffice-gnome is not installed, nor is ibus (though libibus is).
    Ok, but do you have libreoffice-kde4 installed?

    My changes to theme are usually made from the Configure Desktop page, which is in the "start" menu, then Workspace Appearance.
    "Workspace Appearance" only sets options for the workspace obviously. It doesn't affect the look of applications.
    You should try to change the "Style" in "Application Appearance". What have you set there?

    Have not yet played with Application Appearance, where I see there are many config options for GTK and other aspects.
    You can ignore the GTK options, LO only uses them with the GNOME integration, i.e. libreoffice-gnome, which you don't even have installed.

    On your picture it would seem that the text fields would have grey as background, so maybe try to change the color scheme.
    Another thought: are you maybe using the "GTK+" style for KDE? AFAIK that one can cause such color problems. And it's mainly intended for running KDE applications inside GNOME, not to be used as KDE style.

    Bingo! That must be the reason. I can reproduce your exact problem with the "Gtk+ style" in "Application Appearance"->"Style".
    So change that to something else, KDE's native "Oxygen" f.e.
    It doesn't make sense to set "Gtk+ style" for KDE and then use gtk-oxygen in turn. Just use Oxygen directly, that's designed for KDE.
    Last edited by wolfi323; 11-May-2014 at 08:26.

  10. #10
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default REALLY SOLVED. Re: outline numbering tool in LibreOffice missing 'separator' features

    Thank you, Wolfi. It was the GTK+ theme that caused the problem. Changed to Oxygen and the fields are clearly visible.
    Leap/KDE and a film-based photographer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •