Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Devede and Gparted won't load

  1. #1

    Default Devede and Gparted won't load

    I have both installed but they won't load, uninstalled and reinstalled them a couple of times but same result, they just hang trying to launch and then quit the launch process, any ideas what is wrong?

  2. #2

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by wirefox View Post
    I have both installed but they won't load, uninstalled and reinstalled them a couple of times but same result, they just hang trying to launch and then quit the launch process, any ideas what is wrong?
    What openSUSE version? What Desktop Environment? Where did you install them from?

    Try to run them in a terminal window and post the output.

    And maybe your repo list might be interesting, too:
    Code:
    zypper lr -d

  3. #3

    Default Re: Devede and Gparted won't load

    Thx for reply, 13.1 KDE and installed them with Yast, not sure how to run them in terminal?

  4. #4

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by wirefox View Post
    Thx for reply, 13.1 KDE and installed them with Yast,
    But from which repo?
    Packman?

    not sure how to run them in terminal?
    Start a terminal (f.e. Konsole, which is in the "Favorites" section in K-Menu), and type in the name of the application, then press ENTER.
    Code:
    devede
    gparted
    Last edited by wolfi323; 09-May-2014 at 04:57.

  5. #5

    Default Re: Devede and Gparted won't load

    I think it is this repo http://download.opensuse.org/reposit...openSUSE_13.1/


    localhost:~ # devede
    DeVeDe 3.23.0 beta1
    Locale: POSIX
    Using package-installed files
    /root/
    Cores: 1 Virtual cores: 1
    Entro en fonts
    Creating spumux directory/root/.spumux
    /usr/share/devede/devedesans.ttf
    Hago
    /root/.spumux/devedesans.ttf
    hecho
    retorno
    Salgo de fonts
    /root/
    Temp Directory is: /var/tmp
    home load: /root/.devede
    Traceback (most recent call last):
    File "/usr/bin/devede", line 404, in <module>
    global_vars["encoder_video"]=global_vars["encoders"][l-1]
    IndexError: list index out of range

    When I enter gparted in root terminal it works but won't from launcher if that helps you any, thx

  6. #6

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by wirefox View Post
    When I enter gparted in root terminal it works but won't from launcher if that helps you any, thx
    You shall run them as user, not root.
    We want to find out why they don't work as user, don't we?

    Also, please show your repo list as already asked.

    This is a beta version of devede, so maybe that's the problem.
    Try to install version 0.22.0 from the Packman repo, this should work.

  7. #7

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by wolfi323 View Post
    You shall run them as user, not root.
    We want to find out why they don't work as user, don't we?

    Also, please show your repo list as already asked.

    This is a beta version of devede, so maybe that's the problem.
    Try to install version 0.22.0 from the Packman repo, this should work.
    I added Packman and Devede is working good now but Gparted isn't unless I go Root terminal, heres the message from user terminal which may shed some light on the problem:


    baily@localhost:~> gparted
    Absolute path to 'gparted' is '/usr/sbin/gparted', so running it may require superuser privileges (eg. root).

  8. #8

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by wirefox View Post
    Absolute path to 'gparted' is '/usr/sbin/gparted', so running it may require superuser privileges (eg. root).
    so running it may require superuser privileges << that is your answer / solution.

    You need to run it with a user that has superuser provileges, you can do this by setting up sudo.

    https://en.opensuse.org/SDB:Administer_with_sudo

  9. #9
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by wirefox View Post
    I added Packman and Devede is working good now but Gparted isn't unless I go Root terminal, heres the message from user terminal which may shed some light on the problem:


    baily@localhost:~> gparted
    Absolute path to 'gparted' is '/usr/sbin/gparted', so running it may require superuser privileges (eg. root).

    GParted is a disk partitioner.

    As such, it should run as root. When you launch it, watch your tray for an authentication dialogue, you will need to give root password to launch GParted.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  10. #10

    Default Re: Devede and Gparted won't load

    Quote Originally Posted by cra1g321 View Post
    so running it may require superuser privileges << that is your answer / solution.

    You need to run it with a user that has superuser provileges, you can do this by setting up sudo.

    https://en.opensuse.org/SDB:Administer_with_sudo
    As gparted is an application with a GUI, you cannot run it with sudo on a default openSUSE installation. (it won't find the current Xorg session in that case)

    Use kdesu (for KDE), gnomesu (for GNOME), or xdg-su (should work in any case) to run it:
    Code:
    kdesu /usr/sbin/gparted
    gnomesu /usr/sbin/parted
    xdg-su -c /usr/sbin/gparted
    Those are the tools designed for that job.

    But actually the gparted menu entry should launch gparted as root anyway (via pkexec).
    What happens if you type this into the terminal window?
    Code:
    pkexec /usr/sbin/gparted
    But you could use YaST as well to partition your hard disks.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •