Results 1 to 4 of 4

Thread: Internet works, LAN doesn't

  1. #1

    Default Internet works, LAN doesn't

    Hello everyone, first post here

    I've installed OpenSUSE 13.1 and have the internet connection working.
    However, I cannot see any other PC on the local network (or be seen from any of them).

    What can I do?

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Internet works, LAN doesn't

    Helloo and welcome here.

    Your LAN "works" else you would not be able to reach your router through which you go to the internet.

    What do you mean by "cannot see any other PC on the LAN". "Seeing" might be a popular way of expressing things, but in working with computer systems we need presice computer definitions. A good problem description has three things:
    . what did you do;
    . what did you expect to happen;
    . what happened instead.

    In your case it could be somethhing like:
    . I did ping another-system-on-my-lan;
    . I expected it to come with connection timing reports.
    . I got "host unreachable".
    Or different according to what your real test was.


    Please explain.

    PS. when you want to show us your use of ping or any other computer text, please copy/paste that between CODE tags in a post here. You get the CODE tags by clicking on the # button in the tool bar of the post editor. Like:
    Code:
    henk@boven:~> ping bloop
    ping: unknown host bloop
    henk@boven:~>
    Henk van Velden

  3. #3
    Join Date
    Sep 2012
    Location
    Canada
    Posts
    112

    Default Re: Internet works, LAN doesn't

    Hi adrian9841 and welcome to the openSUSE community forum!

    I've installed OpenSUSE 13.1 and have the internet connection working.
    However, I cannot see any other PC on the local network (or be seen from any of them).

    What can I do?
    This looks like a firewall issue. You can easily configure the firewall using the "firewall" module in YaST and, for example, set the network interface of your computer to "internal". With the "internal" profile, most of the network traffic will be allowed through the network interface.

    Next, if what you call "cannot see any other PC on the local network" is Microsoft network browsing, you should also start and enable the following nmbd deamon:

    Code:
    # systemctl start nmb.service
    ...
    # systemctl enable nmb.service
    You can also do the same thing using YaST "service manager" module.
    Kalten

  4. #4

    Default Re: Internet works, LAN doesn't

    Thank you for the reply.
    Ping works OK to the new machine.

    What I was missing was accessing the network share of other PCs (windows boxes).
    But I've toyed about with the Samba config and now it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •