Results 1 to 8 of 8

Thread: USB Festplatte ist "write protected"

  1. #1

    Question USB Festplatte ist "write protected"

    Suse 10.3: USB Festplatte wird beim Einstecken automatisch als /media/sdf1 gemountet, ist sichtbar und von der Platte kann gelesen werden. Beschreiben geht jedoch nicht. Der Versuch die Platte mit mount -o remount,rw /media/sdf1 beschreibbar zu machen bringt die Meldung "block device ist write protected, mounting read only"

    Die Platte ist mit NTFS formatiert und und ist unter Windows XP les- und beschreibbar.

    Was tun?

  2. #2

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by braethreinhold View Post
    Suse 10.3: USB Festplatte wird beim Einstecken automatisch als /media/sdf1 gemountet, ist sichtbar und von der Platte kann gelesen werden. Beschreiben geht jedoch nicht. Der Versuch die Platte mit mount -o remount,rw /media/sdf1 beschreibbar zu machen bringt die Meldung "block device ist write protected, mounting read only"

    Die Platte ist mit NTFS formatiert und und ist unter Windows XP les- und beschreibbar.

    Was tun?
    10.3 ist aber schon _sehr_ alt (fast 7 Jahre), oder ist das ein Tippfehler?
    Ich weiß jetzt nicht, ob damals schon das ntfs-3g Dateisystem dabei war. (das Standard ntfs Dateisystem im Kernel unterstützte jedenfalls normalerweise _keinen_ Schreibzugriff)

    Was gibt denn folgendes aus wenn die Platte gemountet ist?
    Code:
    mount | grep sdf1

  3. #3

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by wolfi323 View Post
    10.3 ist aber schon _sehr_ alt (fast 7 Jahre), oder ist das ein Tippfehler?
    Ich weiß jetzt nicht, ob damals schon das ntfs-3g Dateisystem dabei war. (das Standard ntfs Dateisystem im Kernel unterstützte jedenfalls normalerweise _keinen_ Schreibzugriff)

    Was gibt denn folgendes aus wenn die Platte gemountet ist?
    Code:
    mount | grep sdf1
    mount/grep liefert folgendes Ergebnis:

    linux-kizi:~ # mount -o remount,rw /dev/sdf1
    mount: block device /dev/sdf1 is write-protected, mounting read-only
    linux-kizi:~ #

    Auf dem Rechner befinden sich auch noch ntfs-3g Windows-Partitionen, auf die von Linux aus ohne Probleme RW Zugriffe stattfinden
    (fstab)

    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part3 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part4 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part7 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/fd0 /media/floppy auto noauto,user,sync 0 0

  4. #4

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by braethreinhold View Post
    mount/grep liefert folgendes Ergebnis:

    linux-kizi:~ # mount -o remount,rw /dev/sdf1
    mount: block device /dev/sdf1 is write-protected, mounting read-only
    linux-kizi:~ #

    Auf dem Rechner befinden sich auch noch ntfs-3g Windows-Partitionen, auf die von Linux aus ohne Probleme RW Zugriffe stattfinden
    (fstab)

    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part3 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part4 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD200HJS16KJDWPB38637-part7 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/fd0 /media/floppy auto noauto,user,sync 0 0
    versehentlich hatte ich den das Ergebnis des mount/grep Befehls fals kopiert

    Passwort:
    linux-kizi:~ # mount | grep sdf1
    /dev/sdf1 on /media/Volume type ntfs (rw,nosuid,nodev,uid=1000,utf8)


    lustigerweise leifert der folgende Befehl ein widersprüchliches Ergebnis:

    linux-kizi:~ # mount -o remount,rw /dev/sdf1
    mount: block device /dev/sdf1 is write-protected, mounting read-only
    linux-kizi:~ #

  5. #5

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by braethreinhold View Post
    mount/grep liefert folgendes Ergebnis:

    linux-kizi:~ # mount -o remount,rw /dev/sdf1
    mount: block device /dev/sdf1 is write-protected, mounting read-only
    linux-kizi:~ #
    Hm, das ist aber nicht ganz das nach dem ich gefragt habe...

    Scheinbar wird das device selber schon als "write-protected" eingebunden.
    Gibts irgendwelche Fehler im Kernel Log, wenn du die Platte ansteckst?
    Code:
    dmesg | tail
    Hast du schon einen anderen USB-Port probiert? (Hört sich vielleicht blöd an, kann aber manchmal bei solchen Problemen helfen. Manche Ports liefern z.B. zu wenig Strom was gerade bei Festplatten ohne externem Netzteil Probleme machen kann)

    Und, ist das jetzt wirklich openSUSE 10.3?

  6. #6

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by wolfi323 View Post
    Hm, das ist aber nicht ganz das nach dem ich gefragt habe...

    Scheinbar wird das device selber schon als "write-protected" eingebunden.
    Gibts irgendwelche Fehler im Kernel Log, wenn du die Platte ansteckst?
    Code:
    dmesg | tail
    Hast du schon einen anderen USB-Port probiert? (Hört sich vielleicht blöd an, kann aber manchmal bei solchen Problemen helfen. Manche Ports liefern z.B. zu wenig Strom was gerade bei Festplatten ohne externem Netzteil Probleme machen kann)

    Und, ist das jetzt wirklich openSUSE 10.3?
    Hallo, danke. dmesg liefert (nach Einstecken USB-Festplatte)

    linux-kizi:~ # dmesg | tail
    sd 5:0:0:0: [sdf] Mode Sense: 43 00 00 00
    sd 5:0:0:0: [sdf] Assuming drive cache: write through
    sdf: sdf1
    sd 5:0:0:0: [sdf] Attached SCSI disk
    sd 5:0:0:0: Attached scsi generic sg6 type 0
    usb-storage: device scan complete
    NTFS driver 2.1.28 [Flags: R/W MODULE].
    NTFS-fs warning (device sdf1): parse_options(): Option utf8 is no longer supported, using option nls=utf8. Please use option nls=utf8 in the future and make sure utf8 is compiled either as a module or into the kernel.
    NTFS volume version 3.1.
    SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=01:00:5e:00:00:fb:00:24:2b:bc:1d:a6:08:00 SRC=192.168.178.26 DST=224.0.0.251 LEN=94 TOS=0x00 PREC=0x00 TTL=255 ID=476 PROTO=UDP SPT=5353 DPT=5353 LEN=74
    linux-kizi:~ #

    Das ist wohl der Grund. Was muss ich konkret machen?

  7. #7

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by braethreinhold View Post
    Das ist wohl der Grund. Was muss ich konkret machen?
    Tja, das schaut mir wirklich nach dem Kernel ntfs Dateisystem aus.

    Warum kommt da eigentlich eine Meldung von NTFS? Mountest du die Festplatte irgendwie automatisch?

    Probier mal die Festplatte zu unmounten, und dann folgendermaßen zu mounten:
    Code:
    sudo umount /dev/sdf1
    sudo mount -t ntfs-3g /dev/sdf1 /media/Volume
    Hast du dann Schreibzugriff? (zumindest als root?)

  8. #8

    Default Re: USB Festplatte ist "write protected"

    Quote Originally Posted by wolfi323 View Post
    Tja, das schaut mir wirklich nach dem Kernel ntfs Dateisystem aus.

    Warum kommt da eigentlich eine Meldung von NTFS? Mountest du die Festplatte irgendwie automatisch?

    Probier mal die Festplatte zu unmounten, und dann folgendermaßen zu mounten:
    Code:
    sudo umount /dev/sdf1
    sudo mount -t ntfs-3g /dev/sdf1 /media/Volume
    Hast du dann Schreibzugriff? (zumindest als root?)
    Hallo, ganz vielen Dank. Mit dieser Befehlsfolge bekam ich Schreibzugriff mit chmod auch für die normalen User. Jetzt sind die Daten von Suse 10.3 gesichert und kann einen Versionssprung auf 13.1 machen.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •