Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Noisy fan

  1. #1

    Default Noisy fan

    thx for reading and answering this thread if you can.

    I have installed os 13.1 x86_64 on a acer athlon II alongside win7. So far it works, but when I run win7, the fan processor only makes a faint hum when idle, whereas it emits a tedious roar when on linux, even idle. Normally this feature is managed by the bios, no ?

    How do I fiddle with the fan speed ? any idea ?

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Noisy fan

    Hi there,

    I have oS 13.1 64-bit installed in an old Athlon 64 X2 5200+ desktop, only without Windows dualbooting.

    AFAIK there's no fan setting in Yast or system-settings (KDE4.11.5), this is, indeed, managed by the Phoenix BIOS.

    On the sensors front, only libsensors4 is installed, used by the systemload viewer widget.

    Note that in the BIOS, Smart Fan Control is disabled. Possibly the speed is controlled by the OS or it's a quiet CPU fan, 3000 RPM according to the BIOS.

    Perhaps toggling your BIOS setting will make a difference.

  3. #3

    Default Re: Noisy fan

    I already tested it without the smart fan option from the bios. It's even worse: i'm working close to an jet engine :-(

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: Noisy fan

    Quote Originally Posted by lader1 View Post
    I already tested it without the smart fan option from the bios. It's even worse: i'm working close to an jet engine :-(
    Hi
    So turn on the cool'n'quiet and check the cpupower, maybe it's set to performance rather than ondemand?
    Code:
    cpupower frequency-info
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Noisy fan

    Thx for answering

    cpupower frequency-info

    analyzing CPU 0:
    driver: acpi-cpufreq
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 4.0 us.
    hardware limits: 800 MHz - 2.70 GHz
    available frequency steps: 2.70 GHz, 2.10 GHz, 1.50 GHz, 800 MHz
    available cpufreq governors: ondemand, performance
    current policy: frequency should be within 800 MHz and 2.70 GHz.
    The governor "ondemand" may decide which speed to use
    within this range.
    current CPU frequency is 800 MHz (asserted by call to hardware).
    boost state support:
    Supported: no
    Active: no
    Boost States: 0
    Total States: 4
    Pstate-P0: 2700MHz
    Pstate-P1: 2100MHz
    Pstate-P2: 1500MHz
    Pstate-P3: 800MHz

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: Noisy fan

    Quote Originally Posted by lader1 View Post
    Thx for answering

    cpupower frequency-info

    analyzing CPU 0:
    driver: acpi-cpufreq
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 4.0 us.
    hardware limits: 800 MHz - 2.70 GHz
    available frequency steps: 2.70 GHz, 2.10 GHz, 1.50 GHz, 800 MHz
    available cpufreq governors: ondemand, performance
    current policy: frequency should be within 800 MHz and 2.70 GHz.
    The governor "ondemand" may decide which speed to use
    within this range.
    current CPU frequency is 800 MHz (asserted by call to hardware).
    boost state support:
    Supported: no
    Active: no
    Boost States: 0
    Total States: 4
    Pstate-P0: 2700MHz
    Pstate-P1: 2100MHz
    Pstate-P2: 1500MHz
    Pstate-P3: 800MHz
    Hi
    So that part is working, what about the sensors command?

    The other one is acpi options, fire up YaST -> Bootloader and add either one of the following, save and reboot;
    Code:
    acpi.power_nocheck=1
    
    acpi_osi=linux
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Noisy fan

    Tried them, but no way, it didn't work. That being said, I also found an interesting module: amd_freq_sensitivity
    but I wasn't able to load it: modprobe said no such device, wheras I'm using an athlon II.

    ah, I forgot:

    I also modprobed cpufreq_powersave, then cpupower frequency-set -g powersave, but nada again, the proc freq stick to 800 Mhz, but the fan still turning too fast.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: Noisy fan

    Quote Originally Posted by lader1 View Post
    Tried them, but no way, it didn't work. That being said, I also found an interesting module: amd_freq_sensitivity
    but I wasn't able to load it: modprobe said no such device, wheras I'm using an athlon II.

    ah, I forgot:

    I also modprobed cpufreq_powersave, then cpupower frequency-set -g powersave, but nada again, the proc freq stick to 800 Mhz, but the fan still turning too fast.
    Hi
    So you never see the frequency change under load?

    So have you run sensors-detect and then run sensors command to see the fan speed?

    I have an old system to an Athlon 64 X2 4400+ but fans run quiet etc....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Noisy fan

    And I also found out that the cool n'quiet feature is managed by the powernow-k8 module, but like above, modprobe said Error inserting powernow_k8 (/lib/modules/3.11.10-7-desktop/kernel/drivers/cpufreq/powernow-k8.ko): No such device

    what's the matter ? Do I need to upgrade the kernel ? Send a bug report to the module developer ?

  10. #10

    Default Re: Noisy fan

    hi again,

    No, I saw the cpu speed changing when using the ondemand module, but with powersave, it sticks to 800Mhz for both cpus. But the fan is still turning too fast for an almost idle cpu.

    Installed the sensors: I only get temperatures, no fan speed. e.g.

    Code:
    sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +34.0°C  (crit = +105.0°C)
    
    radeon-pci-0200
    Adapter: PCI adapter
    temp1:        +60.0°C  
    
    k10temp-pci-00c3
    Adapter: PCI adapter
    temp1:        +31.0°C  (high = +70.0°C)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •