Results 1 to 3 of 3

Thread: Lost sound

  1. #1
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Red face Lost sound

    I'm running opensuse 13.1 and I lost sound after a recent update (where the only component that seemed remotely related was fglrx).

    To be more specific, when I run

    :~> speaker-test -Dplug:front -c2 -l5 -twav

    I get sound. I also have sound when I go into Yast2 and test for sound.

    However, I don't get any sound in kde and no application plays any sound (including non-kde apps like vlc). I don't get sound in any other window manager (twm, fvwm2) and switching to root doesn't help either. (I have audio and video added to my groups.)

    The only thing I can think of is that somehow kde and other apps are trying to use an HDMI audio device (see below) whereas I'm just using the standard analog device. I see Caicos HDMI Audio in my kde mixer and perhaps that's the problem even though it worked before. That doesn't explain why vlc and audacity don't work unless it's related to pulseaudio somehow.

    alsa output below:

    !!ALSA Information Script v 0.4.61
    !!################################

    !!Script ran on: Tue May 6 12:21:34 UTC 2014


    !!Linux Distribution
    !!------------------

    Welcome to openSUSE 13.1 "Bottle" - Kernel \r (\l). openSUSE 13.1 (x86_64) # /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64" NAME=openSUSE PRETTY_NAME="openSUSE 13.1 (Bottle) (x86_64)" ID=opensuse CPE_NAME="cpe:/opensuse/opensuse:13.1" BUG_REPORT_URL="https://bugs.opensuse.org" HOME_URL="https://opensuse.org/" ID_LIKE="suse"


    !!DMI Information
    !!---------------

    Manufacturer: LENOVO
    Product Name: IdeaCentre K330
    Product Version: Lenovo Product
    Firmware Version: DKKT20AUS


    !!Kernel Information
    !!------------------

    Kernel release: 3.11.10-7-default
    Operating System: GNU/Linux
    Architecture: x86_64
    Processor: x86_64
    SMP Enabled: Yes


    !!ALSA Version
    !!------------

    Driver version: k3.11.10-7-default
    Library version:
    Utilities version: 1.0.27.2


    !!Loaded ALSA modules
    !!-------------------

    snd_hda_intel
    snd_hda_intel


    !!Sound Servers on this system
    !!----------------------------

    Pulseaudio:
    Installed - Yes (/usr/bin/pulseaudio)
    Running - Yes

    ESound Daemon:
    Installed - Yes (/usr/bin/esd)
    Running - No

    Jack:
    Installed - Yes (/usr/bin/jackd)
    Running - No


    !!Soundcards recognised by ALSA
    !!-----------------------------

    0 [PCH ]: HDA-Intel - HDA Intel PCH
    HDA Intel PCH at 0xfe720000 irq 46
    1 [Generic ]: HDA-Intel - HD-Audio Generic
    HD-Audio Generic at 0xfe640000 irq 47


    !!PCI Soundcards installed in the system
    !!--------------------------------------

    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]

  2. #2
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Default Re: Lost sound

    I fixed the problem by removing as many pulse packages as the system would allow me to remove without having to remove 950 odd packages as well.

    After removing the packages and rebooting, I noticed that kde's multimedia didn't invoke pulse. Instead it reverted to the (i) analog and (ii) HDMI outputs for the two soundcards. I set the analog output as the default.

    The following packages were removed.

    2014-05-06 21:12:46|remove |alsa-plugins-pulse|1.0.27-3.1.1|x86_64|root@agape-server|
    2014-05-06 21:12:46|remove |libxine2-pulse|1.2.5-90.2|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |paman|0.9.4-155.1.3|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |paprefs-lang|0.9.10-9.2.1|noarch||
    2014-05-06 21:12:47|remove |pavucontrol-lang|2.0-2.4.2|noarch||
    2014-05-06 21:12:47|remove |pavumeter|0.9.3-192.1.4|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |pulseaudio-module-bluetooth|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |pulseaudio-module-jack|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |pulseaudio-module-lirc|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |pulseaudio-module-x11|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:47|remove |pulseaudio-module-zeroconf|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:48|remove |paprefs|0.9.10-9.2.1|x86_64|root@agape-server|
    2014-05-06 21:12:48|remove |pavucontrol|2.0-2.4.2|x86_64|root@agape-server|
    2014-05-06 21:12:48|remove |libsbc1|1.0-4.1.2|x86_64||
    2014-05-06 21:12:48|remove |pulseaudio-utils|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:48|remove |pulseaudio-module-gconf|4.0.git.270.g9490a-8.1|x86_64||
    2014-05-06 21:12:48|remove |libglademm-2_4-1|2.6.7-22.1.3|x86_64||
    2014-05-06 21:12:48|remove |libgconfmm-2_6-1|2.28.3-7.2.2|x86_64||
    2014-05-06 21:12:49|remove |libgtkmm-3_0-1|3.10.0-1.1|x86_64||
    2014-05-06 21:12:49|remove |pulseaudio|4.0.git.270.g9490a-8.1|x86_64|root@agape-server|
    2014-05-06 21:12:50|remove |libglademm|2.6.7-22.1.3|x86_64||
    2014-05-06 21:12:50|remove |rtkit|0.11_git201205151338-5.2.1|x86_64||
    2014-05-06 21:12:50|remove |libwebrtc_audio_processing0|0.1-9.1.2|x86_64||

  3. #3
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Lost sound

    On 05/06/2014 09:46 PM, anandrajan wrote:
    >
    > I fixed the problem by removing as many pulse packages as the system
    > would allow me to
    >


    I just skimmed through the two posts but just 2 things I thought of:

    1) You can disable pulse audio from YaST so you dont have to remove the
    packages

    2) Since you have 2 sound devices, maybe pulse audio was playing sound
    to the one you were not using. (changing it is pretty easy from KMix and
    I am not sure if you tried this)

    --
    Bring the Penguins Back! https://features.opensuse.org/316767
    openSUSE 13.1
    KDE 4.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •