Results 1 to 3 of 3

Thread: I have no wifi, yet wpa_supplicant is running. Why?

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default I have no wifi, yet wpa_supplicant is running. Why?

    Hi,

    I see this in my process list:


    Code:
    
    > USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
    > ...
    >
    > root     25736  0.0  0.0  27624  1372 ?        Ss   May04   0:00 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log

    This is a desktop (13.1, xfce, 64bit), and it has never had a WiFi card.
    Bluetooth things, yes. I don't know what starts it or why.

    I use ifup with fixed address.


    Code:
    
    > Telcontar:~ # systemctl status wpa_supplicant.service
    > wpa_supplicant.service - WPA Supplicant daemon
    >    Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled)
    >    Active: active (running) since Sun 2014-05-04 22:15:29 CEST; 3h 11min ago
    >  Main PID: 25736 (wpa_supplicant)
    >    CGroup: /system.slice/wpa_supplicant.service
    >            └─25736 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log
    >
    > May 04 22:15:29 Telcontar systemd[1]: Starting WPA Supplicant daemon...
    > May 04 22:15:29 Telcontar systemd[1]: Started WPA Supplicant daemon.
    > Telcontar:~ #

    Should I just disable that service? Or is there a reason why it should
    be there?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,700
    Blog Entries
    1

    Default Re: I have no wifi, yet wpa_supplicant is running. Why?

    Quote Originally Posted by robin_listas View Post
    Should I just disable that service? Or is there a reason why it should
    be there?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)
    Yes, if you're not using wifi you can safely stop and disable that service.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: I have no wifi, yet wpa_supplicant is running. Why?

    On 2014-05-05 01:56, deano ferrari wrote:

    > Yes, if you're not using wifi you can safely stop and disable that
    > service.


    Thanks for the confirmation. Done :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •