Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Dead keys on LibreOffice

  1. #1

    Default Dead keys on LibreOffice

    I'm having an issue on LibreOffice 4.1.5.3 OpenSuse 13.1 x86_64.
    Whe i create a new document I can use dead keys in a normal way, for instance:

    Code:
       Áéíóúñü
    Then If i save the doceument, open it again and continue writing, deadkeys donn't work (second line, typing the same as first line)

    Code:
       Áéíóúñü
    
     aeiouñu

    I've read It might be something about locales but I cna't find what.

    In any other app, deadkeys work fine (for instance thunderbird, firefox, kwrite, konsole, etc.)

    any help?

    regards

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: Dead keys on LibreOffice

    You do not describe what you use to get "dead keys".

    I use Shift-RightCtl as compose key and then e.g. " e to get ë.
    That works everywhere IMHO, thus also in LibreOffice Writer. And when I save such a LO document and reopen it, it still works.
    Henk van Velden

  3. #3

    Default Re: Dead keys on LibreOffice

    Quote Originally Posted by hcvv View Post
    You do not describe what you use to get "dead keys".

    I use Shift-RightCtl as compose key and then e.g. " e to get ë.
    That works everywhere IMHO, thus also in LibreOffice Writer. And when I save such a LO document and reopen it, it still works.

    I'm using ' (acute) and then a to write á or " (diaeresis) and then u to write ü.
    Ii has been working well for me ever since but LO stopped working (It crashed on opening) then I reinstalled it and now It works but with this strange behaviour.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: Dead keys on LibreOffice

    You then have different keyboard settings from what I have (English/US if I am correct, in mine there are no "dead keys" by definition, they only become "dead on the "Compose" combination). Sorry, but I can not recreate your problem.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Dead keys on LibreOffice

    As you are using some KDE programs, I assume you are using the KDE desktop which, under System Settings>Input methods>Keyboard>Layouts, enables you to select different keyboard layouts, some of which use dead keys and others of which do not.

    The LibreOffice help, under 'Compose key,' says:

    Linux / NetBSD: Using the dead-keys. In an xterm windowfirst press the (´) or (`) key. The character should not appear onthe screen. Now press a letter, such as "e". The e is givenan accent, é or è. If not, then check in the XF86Config file if a"nodeadkeys" XkbdVariant has been loaded there and replaceit. You may also have set the environment variable SAL_NO_DEADKEYS,which deactivates the dead-keys.

    All Unix systems: (Alt Graph) as additional compose key.The (Alt Graph) key can work in LibreOffice like the Compose key, ifyou set the environment variable SAL_ALTGR_COMPOSE. The (Alt Graph)key must trigger a mode_switch, so, for example, xmodmap -e "keysymAlt_R = Mode_switch" must be set. First press (Alt Graph), thenthe first modifier, then the second modifier. The characters arecombined as described on a Solaris system in the file/usr/openwin/include/X11/Suncompose.h.

  6. #6

    Default Re: Dead keys on LibreOffice

    Quote Originally Posted by hcvv View Post
    You then have different keyboard settings from what I have (English/US if I am correct, in mine there are no "dead keys" by definition, they only become "dead on the "Compose" combination). Sorry, but I can not recreate your problem.
    Yes, I'm using spanish layout.
    I think I've found the problem (or the solution). Tools-Settings-Save/load-HTML-Character set is set to ISO8859-15. I thought this setting was only for HTML saving but it seems it isn't. If I change it to UTF-8 and I save the doc and I open it again I can type áéíóúü again.

    regards

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Dead keys on LibreOffice

    On 2014-05-05 00:46, fperal wrote:

    > Yes, I'm using spanish layout.


    Like me.

    > I think I've found the problem (or the solution).
    > Tools-Settings-Save/load-HTML-Character set is set to ISO8859-15. I
    > thought this setting was only for HTML saving but it seems it isn't. If
    > I change it to UTF-8 and I save the doc and I open it again I can type
    > áéíóúü again.


    openSUSE has been using UTF-8 for several years. It is possible that if
    you choose ISO8859-15 things fail.

    But then, html settings should not affect other type of documents...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: Dead keys on LibreOffice

    Quote Originally Posted by fperal View Post
    Yes, I'm using spanish layout.
    I think I've found the problem (or the solution). Tools-Settings-Save/load-HTML-Character set is set to ISO8859-15. I thought this setting was only for HTML saving but it seems it isn't. If I change it to UTF-8 and I save the doc and I open it again I can type áéíóúü again.

    regards
    Like Carlos, I do not completely understand the connection, but when it works, that is fine. In any case, I would never encourage using anything other then UTF-8 encoded Unicode.
    Henk van Velden

  9. #9

    Default Re: Dead keys on LibreOffice

    Quote Originally Posted by hcvv View Post
    Like Carlos, I do not completely understand the connection, but when it works, that is fine. In any case, I would never encourage using anything other then UTF-8 encoded Unicode.
    Neither did I and I've just found It has nothing to do with the HTML settings, It was just coincidence.
    Now I have UTF-8 set in HTML settings and still having the same problem, but I've found that If a close the document and open It again, dead keys work..... for a while, then stop working, then I close the doc and open it again and dead keys working again

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,158

    Default Re: Dead keys on LibreOffice

    That is strange indeed. I am afraid the only thing I can advise is trying to understand what happened shortly before it changes. Maybe after some time you get some feeling of a pattern.

    Hm. not the nicest kinds of problem
    Henk van Velden

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •