Results 1 to 2 of 2

Thread: Unable to install openSUSE 13.1 (or any) to Lenovo G500 Laptop

  1. #1

    Default Unable to install openSUSE 13.1 (or any) to Lenovo G500 Laptop

    Recently I have bought a Lenovo G500 laptop and it shipped with UEFI instead of BIOS for having compatibility with Windows 8. It the laptop came without OS and I need to install some OS to use it. As I don't like windows that much I have tried to installed Linux in the same. But every attempt went to vain and I am not able to install linux. Oh by the way I have tried openSUSE 13.1, 12.4, Ubuntu, Fedora and also Redhat. But no luck. For all the OS it is booting from CD or USB, but when I am selecting installation, nothing is coming to screen, it goes black. I am not able to understand what goes wrong. I have tried to disable the UEFI and select legacy BIOS mode. But for all the case same result. Oh one more thing, in Lenovo's website they are providing driver for SUSE, so that mean linux can be installed in the laptop and it is supported. But don't know how. For the same already contacted the Lenovo support, but they told only for windows they can support not for Linux and it is not supported to install Linux in the laptop (as they never heard about Linux itself ).
    So can any one help me out to solve the issue. Any help will be appreciable.
    Thank you in advance.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,664
    Blog Entries
    3

    Default Re: Unable to install openSUSE 13.1 (or any) to Lenovo G500 Laptop

    Quote Originally Posted by tridibesh View Post
    Recently I have bought a Lenovo G500 laptop and it shipped with UEFI instead of BIOS for having compatibility with Windows 8. It the laptop came without OS and I need to install some OS to use it.
    You may need to disable secure-boot in the BIOS settings.

    For all the OS it is booting from CD or USB, but when I am selecting installation, nothing is coming to screen, it goes black.[/QUOTE]

    This may be a video problem. It is common with nVidia cards.

    Assuming that you are using UEFI booting, when you see the boot menu screen, hit 'e'. That will allow you to edit the command line. Then in the grub edit window, scroll to the "linux" line (or it might be a "linuxefi" line), and add "nomodeset" (without the quotes) to the end of that line. If that works, then you should be able to go ahead and install. You will later want to fix the graphic drivers to get better graphics.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •