Results 1 to 7 of 7

Thread: SAMBA Opensuse 13.1 Im lost!

  1. #1

    Default SAMBA Opensuse 13.1 Im lost!

    Good morning..or evening depending on your geographic location at the time.

    Name is Danny and I'm new to open suse....linux in general I know enough to be dangerous eh eh eh

    After being frustrated with ubuntu based distros I went on the hunt for something new.

    I did a lot of reading on distro watch and played with a few other options...then I found Opensuse needless to say I'm finally home.

    The install was great I couldn't believe how comprehensive it was. That being said im sure my issue is user error and lack of understanding.

    So on to the issue I have right now sharing files.

    Lets deal with the file sharing. The Setup is as follows:

    4x systems pure opensuse 13.1 (2x64bit 2x32bit)
    Hardwired
    Static IP's

    Now I decided to use samba...cause I'm not knowledgeable about other methods. Also I will have 4 VM guests running various windows OS (I'm in school for Microsoft certs then i get to move on to Linux/Unix classes he he) and I want them to access shares on the Linux boxes as well as the Linux boxes access the VM's

    The first thing I did was go to Yast2 > Network Services > Samba Server
    I let it do its initial thing and let yast open firewall.

    The configure comes up and I see the default listed shares now this is where I am either confused or making erroneous changes.
    The share I want to do is the home folder for my primary user.

    As such I click add set the name the description the path and made sure read only is not checked I click ok and bam its in my list of shares.

    I then click finish Yast2 does its finalizing and as expected returned to the main Yast2 window

    At this point I figure I'm good to go I turn around to my laptop which just got it's opensuse goodness.

    Launch dolphin click network and among the others I see samba shares which I click then I see my workgroup again I click it.

    And low and behold see both systems All giddy that it was that easy. I click the target system.....and the giddy is gone I get a time out issue when trying to connect to the target system.

    At this point I'm lost ..my linux-fu is not strong ...yet

    What am I doing wrong here? I searched around but didn't find anything related at least as far as I know it. lol

    Again any help on this is greatly appreciated.


    Sincerely Danny
    Proud new Opensuse user

  2. #2

    Default Re: SAMBA Opensuse 13.1 Im lost!

    Additionla info:

    The Windows VM's CAN access the shares
    The Linux hosts cannot get timed out
    Netbios names are set and workgroup is set to the desired name

  3. #3

    Default Re: SAMBA Opensuse 13.1 Im lost!(Solved)

    Well I'm not sure what I did.

    Either it was the name resolution order option i put in smb.conf.

    I also ran smbpasswd -a user on both systems why that would resolve a time out issue not sure.

    Regardless I'm sharing files linux<>linux windows<>linux windows<>windows.

    Still if somebody can explain WHY this might of worked I would love to here it strictly for the educational merit.

  4. #4

    Default Re: SAMBA Opensuse 13.1 Im lost!

    When it comes to samba i always consult http://www.swerdna.net.au/
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  5. #5

    Default Re: SAMBA Opensuse 13.1 Im lost!

    NICE! that looks like a great resource! I appreciate it!

  6. #6

    Default Re: SAMBA Opensuse 13.1 Im lost!

    Quote Originally Posted by jetchisel View Post
    When it comes to samba i always consult http://www.swerdna.net.au/
    Unfortunately, Swerdna says there: "I no longer update the pages on this site. So the pages will gradually become obsolete.". Lenwolf

  7. #7

    Default Re: SAMBA Opensuse 13.1 Im lost!

    Slowly but surely
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •