Results 1 to 2 of 2

Thread: YAST partitioner doesn't seem to recognize LV mirrors

  1. #1

    Default YAST partitioner doesn't seem to recognize LV mirrors

    Hi,

    I have an OpenSUSE 12.3 installation at home using YAST partitioner to manage partitions and Logical Volumes. Recently I decided to deploy also LV mirroring on some logical volumes. Then I discovered that the YAST partitioner apparently did not support volume mirroring, so I decided to use an lvconvert command line tool. Everything went well, except that the partitioning manager does not recognize the mirrored volumes and reports available space incorrectly. My logical volume consists of four physical partitions:

    PV VG Fmt Attr PSize PFree
    /dev/sdb1 VG_Unmirrored lvm2 a-- 193,29g 56,75g
    /dev/sdb2 VG_Unmirrored lvm2 a-- 100,00g 0
    /dev/sdb3 VG_Unmirrored lvm2 a-- 172,46g 0
    /dev/sde2 VG_Unmirrored lvm2 a-- 600,00g 200,00g

    ...with a total size of slightly more than 1TB, and four logical volumes, of which two are mirrored:

    LV VG Attr LSize Pool Origin Data% Move Log Copy% Convert
    BACKUP_NEW VG_Unmirrored rwi-aor-- 150,00g 100,00
    SMALLVOLUME1 VG_Unmirrored -wi-ao--- 4,00g
    SMALLVOLUME2 VG_Unmirrored -wi-ao--- 5,00g
    VIRTUALBOX VG_Unmirrored rwi-aor-- 250,00g 100,00

    The total volume size is slightly more than 1T, of which 800G is occupied by mirrored logical volumes, leaving about 256G unallocated space. However the YAST partititioner does not count mirroring and reports as much as 656 GB of unallocated space, which is incorrect. Fortunately, when I tried to create a new logical volume, the partitioner suggested a maximum size of 256GB, which was correct. However, after the new LV was created, the partitioner still reports 400 GB of unallocated space (/sbin/pvs reported 0). So the problem is only with reporting, and at the first glance does not seem to impose a risk of an improper allocation.

    How can it be reported so that the partitioner is fixed with this respect? I understand that adding LV mirroring features may not be on priority list, but at least I would appreciate if a free space is reported correctly, despite mirroring.

    --
    Best regards,

    (js).

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,631
    Blog Entries
    3

    Default Re: YAST partitioner doesn't seem to recognize LV mirrors

    I suggest that you report this as a bug. That's how such problems get fixed.

    openSUSE:Submitting bug report
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •