Results 1 to 4 of 4

Thread: KMS doesn't work on Lenovo G710

  1. #1

    Default KMS doesn't work on Lenovo G710

    Hi all,

    I recently bought a Lenovo G710 which comes with two graphic chipsets: The CPU has a built-in Intel HD Graphics 4600 and then it has a Nvidia Geforce GT 720M, which is only being used if there's demand for it like 3D games etc. One can deactivate the Nvidia in the BIOS, but that doesn't have any effect on the problem I encountered.
    When I try to boot OpenSuse 13.1 with default options, the screen will soon turn black after it switched to graphical mode. Trying to switch to a text console also won't help once the screen is black since it won't respond.
    However, when disabling KMS, the graphical mode works and after having installed the system there's no problem (the right driver is being loaded then). I think it's especially a problem for people who want to work with the Live Image, because it will use some default driver which could result in performance and/or graphic problems.

    Did anyone encounter the same problem with this notebook or another notebook using the same graphic chipset?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: KMS doesn't work on Lenovo G710

    You need bumblebee to manage the 2 different chips sets. This is called Optimus

    Instructions here

    http://smithfarm-thebrain.blogspot.i...bumblebee.html

  3. #3

    Default Re: KMS doesn't work on Lenovo G710

    Quote Originally Posted by gogalthorp View Post
    You need bumblebee to manage the 2 different chips sets. This is called Optimus

    Instructions here

    http://smithfarm-thebrain.blogspot.i...bumblebee.html
    Thanks for that advice, I didn't know about this before.

    I hope the KMS developers know about this problem though, since I guess that bug could make many inexperienced users give up installing Linux on a notebook which uses this chipset.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: KMS doesn't work on Lenovo G710

    The problem is for the most part from NVIDIA. Their Linux driver does not fully support their funky mixed GPU scheme. I mean who thought mixing different GPU's was a good idea LOL. I call it Frankengraphics. I suppose it does sell chips to people that have Intel CPU's with built in GPU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •