Results 1 to 5 of 5

Thread: Firefox is ignoring the language preferences

  1. #1

    Default Firefox is ignoring the language preferences

    My openSUSE system's language and region are correctly set, Spanish. Firefox's preferences are also set to Spanish (Preferences, Content, Language). And today I just started my laptop and suddenly when opening Firefox I realized it no longer recognizes none of these settings, now it's stuck in English. openSUSE's front page (www.opensuse.org) now always defaults to English, Youtube defaults to English, and so on in the sites.

    Tried deleting all cookies, site preferences, cache, and stuff (except for browsing/downloads history and auto-form-fill/search history), reset my modem and upgraded to Firefox 29. Didn't work!
    Firefox as program is still installed in Spanish, but language settings are totally ignored!

    Can you help me?
    Thanks.

  2. #2

    Default Re: Firefox is ignoring the language preferences

    I tried moving my ~/.mozilla directory to another location in order for Firefox to not recognize it and create a new directory. Worked, seemingly it went back to normal! Then tried restoring my original directory, and again the problem. Something must have gone wrong with my stored settings...

    But I wouldn't like to delete my directory; though I don't care that much about auto-form-fills, I have a big deal of browsing history that I don't want to loose. And perhaps it's a big history, since my directory is 144.4 Mb, while a brand new mozilla directory is just 11.8 Mb. Otherwise I don't know why it's so heavy...

    I constantly erase cookies, cache, active sessions, offline website data, and site preferences; just as I did before upgrading to Firefox 29. Guess these elements are not that heavy...

    Well, this is all the background information I have by now. Any help?

    EDIT: no output at all when running Firefox from console.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Firefox is ignoring the language preferences

    On 2014-05-01 19:06, F style wrote:
    >
    > My openSUSE system's language and region are correctly set, Spanish.
    > Firefox's preferences are also set to Spanish (Preferences, Content,
    > Language). And today I just started my laptop and suddenly when opening
    > Firefox I realized it no longer recognizes none of these settings, now
    > it's stuck in English. openSUSE's front page (www.opensuse.org) now
    > always defaults to English, Youtube defaults to English, and so on in
    > the sites.


    I have FF 28.0. I made sure that the language preference was set to
    "ES", and opened www.opensuse.org: it appeared in Spanish. Youtube also
    appeared in Spanish. Then I pushed "en" as the preferred language,
    reloaded the same two pages and they appeared in English. All as expected.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  4. #4

    Default Re: Firefox is ignoring the language preferences

    Did you read my second post?
    If I use a brand new ~/.mozilla directory things go as you describe, but I don't want to loose my current directory. I was expecting someone could help in deciphering the problem without having to delete my current directory... Again, maybe a file went corrupted, or something...

  5. #5

    Default Re: Firefox is ignoring the language preferences

    After a long fight all along the day, it *seems* to be fixed...

    I was applying trial/error with all the files inside ~/.mozilla/firefox/(weird-set-of-letters).default-(long-number) directory, and found that seemingly the file at fault was one inside /extensions subdirectory, named {long-hexadecimal-number}.xpi.

    Over all I only have 3 extensions in Firefox: the 2 default ones (TrackerFox and openSUSE Firefox extensions, though the first one has always been disabled perhaps due to incompatibility), and AdBlock Plus, the only one I install and which settings I leave all default since installing. When deleting/moving the xpi file, shown language in Firefox went back to normal but AdBlock Plus disappeared. If I put the file back in place Firefox asked permission to install an extension (AdBlock Plus), but regardless if I accepted or not, language still remained back to normal. Weird...
    By the way, if accepting there was no additional disk space used; seemingly it used the same addon files inside ~/.mozilla.

    But I better chose to restore Firefox to factory defaults, which indeed deleted half of stuff inside ~/.mozilla... Started Firefox like this and language normal. Installed AdBlock Plus again, and after restarting Firefox again website language in default English! Then disabled AdBlock Plus, restarted Firefox, and again normal. Enabled AdBlock Plus again, and normal ever since.... I don't understand...

    So probably the solution since the beginning, before upgrading to Firefox 29 (see first post), could have been disabling AdBlock Plus, restart Firefox and enabling AdBlock Plus again. But I can't be totally sure now... Anyway, restoring to factory was worth it, but the whole experience leave me with a bad taste.

    Any ideas, theorems, or anything about this? How could an extension cause all of this? Yesterday everything was working well and normal. Then shut down and went to sleep. Today at the beginning I turned on system and the problem was magically present!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •