Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

  1. #1

    Default kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    on my Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, OS=opensuse 13.1 KDE=4.13.0
    knotes doesn't create new notes, rightclick on knotes icon in system tray, choose new note, nothing is created, in 12.3 it works but if you hide the just created note it disappear and cannot be showed again.
    ...and also knotes has some strange behaviours about duplication notes and conflict warnings that I has to better identify...
    ...and also, if in knotes settings > collections > selecting a folder in "select the folder where the note will be saved" it is not remembered by knotes after closing knotes settings and reopen it...
    suggestions??


  2. #2

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by pier_andreit View Post
    knotes doesn't create new notes, rightclick on knotes icon in system tray, choose new note, nothing is created, in 12.3 it works but if you hide the just created note it disappear and cannot be showed again.
    ???
    I'm not sure I understand this sentence correctly.

    So, knotes 4.13 works fine in your openSUSE 12.3 system, but it doesn't in 13.1?

    On 13.1 nothing happens when you choose "New note"?

    On 12.3 creating a new note works, but it isn't saved?

    Do you have problems when you create a new user?

    suggestions??
    File bug reports at http://bugs.kde.org/.
    Last edited by wolfi323; 30-Apr-2014 at 02:24.

  3. #3

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by wolfi323 View Post
    ???
    I'm not sure I understand this sentence correctly.
    you are overextimating my mess capability

    Quote Originally Posted by wolfi323 View Post
    So, knotes 4.13 works fine in your openSUSE 12.3 system, but it doesn't in 13.1?
    yes

    Quote Originally Posted by wolfi323 View Post
    On 13.1 nothing happens when you choose "New note"?
    yes

    Quote Originally Posted by wolfi323 View Post
    On 12.3 creating a new note works, but it isn't saved?
    yes

    Quote Originally Posted by wolfi323 View Post
    Do you have problems when you create a new user?
    I will try...


    Quote Originally Posted by wolfi323 View Post
    File bug reports at http://bugs.kde.org/.
    I will do...
    manythnx, :-) ciao :-)

  4. #4

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by wolfi323 View Post
    ???
    I'm not sure I understand this sentence correctly.
    you are overextimating my mess capability

    Quote Originally Posted by wolfi323 View Post
    So, knotes 4.13 works fine in your openSUSE 12.3 system, but it doesn't in 13.1?
    yes

    Quote Originally Posted by wolfi323 View Post
    On 13.1 nothing happens when you choose "New note"?
    yes

    Quote Originally Posted by wolfi323 View Post
    On 12.3 creating a new note works, but it isn't saved?
    yes

    Quote Originally Posted by wolfi323 View Post
    Do you have problems when you create a new user?
    I will try...


    Quote Originally Posted by wolfi323 View Post
    File bug reports at http://bugs.kde.org/.
    I will do...
    manythnx, :-) ciao :-)

  5. #5

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Thanks for clarifying!

    Quote Originally Posted by pier_andreit View Post

    knotes doesn't create new notes, rightclick on knotes icon in system tray, choose new note, nothing is created, in 12.3 it works but if you hide the just created note it disappear and cannot be showed again.
    Some ideas:
    Try to choose a different default collection to save to in KNotes' settings.

    Have a look in akonadiconsole (Browser tab), whether the newly created notes show up there. Maybe right-click on the collection and choose "Synchronize".

    Does the note get saved to the corresponding folder in the filesystem and just doesn't show up in KNotes, or is it not even saved?

    Try to run akonaditray (a small program for the system tray that lets you start/stop Akonadi f.e.), this will show certain errors as notifications. Do you get some when creating a new note?

    What database backend are you actually using?
    (to find out, run "kcmshell4 akonadi" or right-click on the akonaditray icon and select "Configure...", then click on the "Configure the Akonadi-Server" tab; or select Server->Configure Server... in akonadiconsole's menu)

  6. #6

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by wolfi323 View Post
    Do you have problems when you create a new user?
    this is my try:
    created a new user, launched knotes, rightclick on icon in the system tray, choosen new note, knotes asked me where save the note, I checked the only one "note" icon and checked use as default, click ok, knotes created 2 notes instead of one, and after a while this warning appeared:

    I clicked on left one, warning disappeared, but after a while another warning appeared

    note that in the first picture, before to accept "left one" in the warning, only one note is filled with "hhhhhhhhh", after having chosen the "left one" both are filled with "hhhhhhhhh",
    I chosen "left one" again, deleted one of the notes, hided, the note, and it disappear from knotes, I cannot resume it in any way.

  7. #7

    Default AW: Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by pier_andreit View Post
    this is my try:
    created a new user, launched knotes, rightclick on icon in the system tray, choosen new note, knotes asked me where save the note, I checked the only one "note" icon and checked use as default, click ok, knotes created 2 notes instead of one, and after a while this warning appeared:
    Hm, I only know this dialog and the duplication issue from kmail.
    The messages are not really duplicated, but two references to the same message (or note in this case) exist in the database it seems. That's why there is a conflict when one of them is changed.

    In kmail this seems to only happen when filtering (and therefore moving) messages (but not for all of them, it seems to be some timing issue/race condition).

    But I haven't seen this in knotes yet. Well, I haven't seen it in KMail for some time either, since it only happened with the POP3 accounts. And I switched all of my accounts to IMAP in the meantime (and use server-side filtering).

    I chosen "left one" again, deleted one of the notes, hided, the note, and it disappear from knotes, I cannot resume it in any way.
    I suppose that's because the note itself was _not_ duplicated. So by deleting _one_ of the notes, you deleted the _only_ one.

    If you experience that again, try to quit knotes and restart akonadi ("akonadictl restart" f.e.).
    Is the note still duplicated?

    Try to open _both_ notes. Can you then delete one without affecting the other?

    But I think you should really file a bug report about this, especially if it also occurs with a new user and therefore fresh akonadi database.

  8. #8

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by wolfi323 View Post
    Thanks for clarifying!

    Quote Originally Posted by wolfi323 View Post
    Some ideas:
    Try to choose a different default collection to save to in KNotes' settings.
    tried, it doesn't works
    Quote Originally Posted by wolfi323 View Post
    Have a look in akonadiconsole (Browser tab), whether the newly created notes show up there. Maybe right-click on the collection and choose "Synchronize".
    when I launch akonadiconsole a warning appear and also this in the konsole....may be useful...
    Code:
    pla@suseST-pla:~> akonadiconsole
    akonadiconsole(10615) KDirWatch::removeDir: doesn't know "/home/pla/.kde4/share/apps/messageviewer/themes/" 
    akonadiconsole(10615) KDirWatch::removeDir: doesn't know "/usr/share/kde4/apps/messageviewer/themes/" 
    QSqlQuery::exec: database not open
    QLayout: Attempting to add QLayout "" to JobTrackerWidget "", which already has a layout
    QLayout: Attempting to add QLayout "" to JobTrackerWidget "", which already has a layout
    QLayout: Attempting to add QLayout "" to NotificationMonitor "", which already has a layout
    akonadiconsole(10615) MonitorItem::MonitorItem: "Invalid object path: /subscriber/plasma-desktop_2004_EvnIEU"
    in 13.1 where nothing happen no notes appear in the browser tab nothing change in the numbers that shows the numbers of notes present in the collections even if I sicronyze everything...

    Quote Originally Posted by wolfi323 View Post
    Does the note get saved to the corresponding folder in the filesystem and just doesn't show up in KNotes, or is it not even saved?
    ..it seems it isn't saved at all...
    Quote Originally Posted by wolfi323 View Post
    Try to run akonaditray (a small program for the system tray that lets you start/stop Akonadi f.e.), this will show certain errors as notifications. Do you get some when creating a new note?
    no notifications appear...but
    if I test clicking on test button, this is the result, there are some red crosses...:

    the details here..
    http://paste.opensuse.org/77801453

    Quote Originally Posted by wolfi323 View Post
    What database backend are you actually using?
    (to find out, run "kcmshell4 akonadi" or right-click on the akonaditray icon and select "Configure...", then click on the "Configure the Akonadi-Server" tab; or select Server->Configure Server... in akonadiconsole's menu)
    maybe mysql????

  9. #9

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    Quote Originally Posted by pier_andreit View Post
    when I launch akonadiconsole a warning appear and also this in the konsole....may be useful...
    Code:
    pla@suseST-pla:~> akonadiconsole
    akonadiconsole(10615) KDirWatch::removeDir: doesn't know "/home/pla/.kde4/share/apps/messageviewer/themes/" 
    akonadiconsole(10615) KDirWatch::removeDir: doesn't know "/usr/share/kde4/apps/messageviewer/themes/" 
    QSqlQuery::exec: database not open
    QLayout: Attempting to add QLayout "" to JobTrackerWidget "", which already has a layout
    QLayout: Attempting to add QLayout "" to JobTrackerWidget "", which already has a layout
    QLayout: Attempting to add QLayout "" to NotificationMonitor "", which already has a layout
    akonadiconsole(10615) MonitorItem::MonitorItem: "Invalid object path: /subscriber/plasma-desktop_2004_EvnIEU"
    No. I get those messages as well. Nothing to do with akonadi or notes problems.

    With "warning" you mean the dialog that appears on start that "Akonadi Console is purely a development tool" and so on?
    This is normal as well. You can change internal things with akonadiconsole that might break your setup and cause data loss.

    in 13.1 where nothing happen no notes appear in the browser tab nothing change in the numbers that shows the numbers of notes present in the collections even if I sicronyze everything...
    But you do have a notes collection, right?
    Is at least one enabled in KNotes' settings?

    no notifications appear...but
    if I test clicking on test button, this is the result, there are some red crosses...:

    the details here..
    http://paste.opensuse.org/77801453
    So, there are database errors reported there:
    Code:
    InnoDB: The log sequence number in ibdata files does not match
    InnoDB: the log sequence number in the ib_logfiles!
    140430 12:15:39  InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    InnoDB: Last MySQL binlog file position 0 1256, file name ./mysql-bin.000005
    140430 12:15:44  InnoDB: Waiting for the background threads to start
    140430 12:15:45 Percona XtraDB (http://www.percona.com) 5.5.33-MariaDB-31.1 started; log sequence number 898858158
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
    140430 12:15:46 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure
    No idea if those could give problems, but that sure doesn't sound healthy.
    Try to rename the folders ~/.config/akonadi and ~/.local/share/akonadi when akonadi is stopped.

    But you have those problems with a new user as well, right?
    So they shouldn't be related to any database or settings issues.

    Then there's also:
    Code:
    Executable "akonadi_nepomuk_feeder" for agent "akonadi_nepomuk_feeder" could not be found!
    Executable "akonadi_folderarchive_agent" for agent "akonadi_folderarchive_agent" could not be found!
    But this is completely unrelated to your problems.
    The first one is caused by the fact that nepomuk has been replaced by baloo (and akonadi_nepomuk_feeder by akonadi_baloo_feeder).
    No idea about the second one.
    You could remove those two agents in akonadiconsole to get rid of those errors.

    maybe mysql????
    Yes, and that's the recommended one since quite some times.

    But for a while sqlite was the default on openSUSE IIRC, and this might have problems.
    That's why I asked.

    PS:
    Do you have the same problems in KJots?
    Last edited by wolfi323; 30-Apr-2014 at 08:07.

  10. #10

    Default Re: kde 4.13.0 in opensuse 13.1 knotes doesn't create a new note and in 12.3 yes

    And another thing:
    Most of your problems seem to be related to synchronizing (Akonadi only actually writes changes when it synchronizes a collection).
    What I suspect that might happen is, that one synchronization isn't finished yet when a new one is started.
    This could explain the conflict dialogs and that changes get lost.

    Try changing the synchronization settings for your notes collections in akonadiconsole, by right-clicking on them in the "Browser" tab and switching to "Retrieval" there.
    Especially try to increase the synchronization interval. (here it is "Never")
    Try also playing with the other settings there.
    As I don't have this problem, I cannot tell you what might help.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •