Results 1 to 4 of 4

Thread: Recent update (?) broken Okular "open at page".

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Recent update (?) broken Okular "open at page".

    Hi,

    Before I report a bug I'd appreciate if someone else could try this please?

    Some time within the last two weeks or so I've lost the ability to open a pdf, or indeed any document type, at a specific page using Okular.

    Previously, this for example:
    Code:
    paul@Orion-1:~/Temporary$ okular --page 5 test.pdf
    opened test.pdf at page 5

    Now okular is ignoring the page request and opens documents at either the first page or (for a document previously opened) the last opened page.

    I don't know if this is of relevance (to this problem) there is also an error message:
    Code:
    paul@Orion-1:~/Temporary$ okular --page 5 test.pdf
    okular(7579) KXMLGUI::ActionList::plug: Index  15  is not within range (0 -  12
    paul@Orion-1:~/Temporary$
    Although the same error is given when no options are passed on the command line:
    Code:
    paul@Orion-1:~/Temporary$ okular test.pdf
    okular(7594) KXMLGUI::ActionList::plug: Index  15  is not within range (0 -  12
    paul@Orion-1:~/Temporary$
    A quick "google" suggest that the "error" message is (I think) irrelevant.

    There was an update to Okular on 23-Apr-14, which fits within the time-frame of this appearing.

    Version Information:
    Code:
    Okular - Version 0.19.0
    Using KDE Development Platform 4.13.0
    
    from openSUSE KDE:Current
    4.13.0-3.1
    Wed 23 Apr 2014 19:43:28 BST
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,280

    Default Re: Recent update (?) broken Okular "open at page".

    I have standard openSUSE 13.1 and it has:
    Code:
    Qt: 4.8.5
    KDE Development Platform: 4.11.5
    Okular: 0.17.5
    It works as you expect.
    Henk van Velden

  3. #3

    Default Re: Recent update (?) broken Okular "open at page".

    Quote Originally Posted by tannington View Post
    Now okular is ignoring the page request and opens documents at either the first page or (for a document previously opened) the last opened page.
    I can confirm this (KDE 4.13.0 here as well).

    I don't know if this is of relevance (to this problem) there is also an error message:
    I don't think the message has any relevance.
    I didn't get any message with the PDFs I tried, but the "--page" parameter didn't work either.

    PS: If you want to report it, I would suggest to do so directly upstream at http://bugs.kde.org/. I may do so later, if you don't have/wnat to create an account there.

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: Recent update (?) broken Okular "open at page".

    Thanks guys.


    Quote Originally Posted by wolfi323 View Post
    PS: If you want to report it, I would suggest to do so directly upstream at http://bugs.kde.org/. I may do so later, if you don't have/wnat to create an account there.

    Done. https://bugs.kde.org/show_bug.cgi?id=334100
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •