Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Steam cant run: Unable to open a connection to X

  1. #1

    Default Steam cant run: Unable to open a connection to X

    Hi,

    Running Steam it popup:

    "Unable to open a connection to X. Check your DISPLAY environment variable and make sure that you have enabled X. If you are running remotely, make sure that you have a remote connection which will allow an X connection.

    For more information visit https://support.steampowered.com/kb_article.php?ref=4050-WOJB-0608."


    Searched through out google trying fix it and got a workaround but I have to do it every time(startup): xhost +; steam


    xhost is issuing: "access control enabled, only authorized clients can connect"

    And I cant get permission to my user from X

    Thanks in advance.

    Rig:
    openSUSE 13.1
    Nvidia proprietary driver (updated)
    Gigabyte GTX 770
    i5 3330 (h60 corsair)

  2. #2

    Default Re: Steam cant run: Unable to open a connection to X

    I can confirm this issue, after steam client update on 22 april, its not working anymore.

  3. #3
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Steam cant run: Unable to open a connection to X

    On 04/27/2014 01:36 PM, nevenblazic wrote:
    >
    > I can confirm this issue, after steam client update on 22 april, its not
    > working anymore.
    >
    >


    Hmm I have updated and it still works for me.

    On 04/27/2014 11:16 AM, GoCorinthians wrote:>
    > Hi,
    >
    > Running Steam it popup:
    >
    >

    _\"Unable_to_open_a_connection_to_X.__Check_your_DISPLAY_environment_variable_and_make_sure_that_you_have_enabled_X.__If_you_are_running_remotely,_make_sure_that_you_have_a_remote_connection_which_will_allow_an_X_connection._
    >
    >

    _For_more_information_visit_https://support.steampowered.com/kb_article.php?ref=4050-WOJB-0608.\"
    > _
    >


    Did you visit the link steam provides? It has some debugging information
    on it. https://support.steampowered.com/kb_...4050-WOJB-0608

    --
    Bring the Penguins Back! https://features.opensuse.org/316767
    openSUSE 13.1
    KDE 4.13.0

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Steam cant run: Unable to open a connection to X

    No problems here either; one machine running native Steam, one running through wine.
    I have not updated through any repository, but the clients have been 'automatically' updated in both cases.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5

    Default Re: Steam cant run: Unable to open a connection to X

    Just a wild guess:
    There was an update to xorg-x11-server recently, this will break the nvidia driver if you installed it "the hard way" (by downloading and running the .run file from the nvidia homepage).
    If that's how you installed it, you _have_ to re-install it after any update to Mesa-libGL1 and xorg-x11-server, as the nvidia driver replaces parts of those with its own versions.

    Maybe this causes your issue?
    Try re-installing the driver.
    To check whether the driver is working, install "Mesa-demo-x" and run:
    Code:
    glxinfo | grep render
    or have a look in /var/log/Xorg.0.log.

  6. #6

    Default Re: Steam cant run: Unable to open a connection to X

    hey,

    Installed openSUSE all over.

    - Zypper up then restart.
    - Nvidia install from one-click install found here: https://en.opensuse.org/SDB:NVIDIA_drivers
    - restart here;
    - Steam install from one-click install found here: https://en.opensuse.org/Steam
    - restart here too
    - Steam poped :"Unable to open" again.

    I do noticed that after installing Steam appeared two new kernel choices on grub: 3.11.10-7 & 3.11.6-4. I booted with each one of them and same error issued sadly
    Could be it?

    -----------------------------
    Host-001:~ # zypper in Mesa-demo-x
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...


    The following NEW package is going to be installed:
    Mesa-demo-x


    1 new package to install.
    Overall download size: 25.8 KiB. After the operation, additional 67.7 KiB will be used.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package Mesa-demo-x-8.1.0-4.1.2.x86_64 (1/1), 25.8 KiB ( 67.7 KiB unpacked)
    Retrieving: Mesa-demo-x-8.1.0-4.1.2.x86_64.rpm ........................................................................................................................................................................................[done]
    (1/1) Installing: Mesa-demo-x-8.1.0-4.1.2 .............................................................................................................................................................................................[done]
    Host-001:~ # glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: GeForce GTX 770/PCIe/SSE2
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, GL_NVX_nvenc_interop,
    GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering,
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, GL_NVX_nvenc_interop,
    GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering,

  7. #7

    Default Re: Steam cant run: Unable to open a connection to X

    Quote Originally Posted by alanbortu View Post
    On 04/27/2014 01:36 PM, nevenblazic wrote:
    >
    > I can confirm this issue, after steam client update on 22 april, its not
    > working anymore.
    >
    >


    Hmm I have updated and it still works for me.

    On 04/27/2014 11:16 AM, GoCorinthians wrote:>
    > Hi,
    >
    > Running Steam it popup:
    >
    >

    _\"Unable_to_open_a_connection_to_X.__Check_your_DISPLAY_environment_variable_and_make_sure_that_you_have_enabled_X.__If_you_are_running_remotely,_make_sure_that_you_have_a_remote_connection_which_will_allow_an_X_connection._
    >
    >

    _For_more_information_visit_https://support.steampowered.com/kb_article.php?ref=4050-WOJB-0608.\"
    > _
    >


    Did you visit the link steam provides? It has some debugging information
    on it. https://support.steampowered.com/kb_...4050-WOJB-0608

    --
    Bring the Penguins Back! https://features.opensuse.org/316767
    openSUSE 13.1
    KDE 4.13.0
    Yep. no fix here!

  8. #8

    Default Re: Steam cant run: Unable to open a connection to X

    I'm using Tumbleweed and Steam RPM package was upgraded to 1.0.0.50 and this error started to appear for me.

    This command:
    Code:
    xhost +; steam
    helped me to fix the problem.

    Thanks and sorry for the necro posting.

  9. #9

    Default Re: Steam cant run: Unable to open a connection to X

    Hey,

    try

    echo $DISPLAY
    # Outpu:
    :0.0

    DISPLAY=:0.0 xhost +;steam

    works for me

    OpenSuSE 13.2
    NVIDIA ION
    XFCE

  10. #10
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: Steam cant run: Unable to open a connection to X

    xhost + is A REALLY BAD IDEA, you should never use it but instead allow only certain hosts like localhost connect.
    .: miuku @ #opensuse @ irc.libera.chat

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •