Results 1 to 6 of 6

Thread: proper way to install Qt5 Development ?

  1. #1
    wally345 NNTP User

    Default proper way to install Qt5 Development ?

    Is there any instruction out there how to setup Qt5 with qt5-creator and all others
    needed to develop on Qt5 libs ?
    Seems there are some significant changes and i do not want to start a new project
    against Qt4-libs.
    Which repos to add and which packgae minimum is necessary ?
    How to setup the kits and Qtversion in creator after installing ?

    All to be done on OpenSuse 13.1

    thank you

  2. #2

    Default Re: proper way to install Qt5 Development ?

    Quote Originally Posted by wally345 View Post
    Is there any instruction out there how to setup Qt5 with qt5-creator and all others
    needed to develop on Qt5 libs ?
    I haven't used qt-creator for Qt5 projects yet, but I think for compiling Qt5 projects, just select Tools->Options->Qt-Versions, click on "Add" and select /usr/bin/qmake-qt5 in the file dialog. You may want to remove the Qt4 configuration though.

    Which libQt5 devel packages you need depends on what parts of Qt5 your application is going to use of course.
    A good start would be libqt5-qtbase-devel and libqt5-qttools (for Assistant, Designer, and so on, but I'm not sure that's needed when using qt-creator)
    I suppose.

    And JFYI, the Qt5 version of qt-creator is in the package libqt5-creator, whereas the Qt4 version is called qt-creator.
    But I think it doesn't really matter which one you use. Both should be able to build against either Qt4 or Qt5.

    Which repos to add and which packgae minimum is necessary ?
    You have to decide yourself which version you want/need.

    There's 5.1.1 included in openSUSE 13.1, there's 5.2.1 in the KDE:Qt52 repo, and there's also the latest 5.3 in KDE:Qt53 (5.3.1~pre) and KDE:Qt5 (5.3.0~beta, because it is needed by KDE5).

  3. #3
    wally345 NNTP User

    Default Re: proper way to install Qt5 Development ?

    thank you for now

  4. #4
    wally345 NNTP User

    Default Re: proper way to install Qt5 Development ?

    OK, did exactly what you said and it works as expected.

    Anyway, getting again this annoying error message but seems to work:

    Code:
    libGL error: failed to load driver: swrast
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.

  5. #5
    wally345 NNTP User

    Default Re: proper way to install Qt5 Development ?

    There are no qt5 examples - how to get them ?
    Seems there are only example packages for webkit
    or do i need to add another repo to get qt5 examples ?

  6. #6

    Default Re: proper way to install Qt5 Development ?

    Quote Originally Posted by wally345 View Post
    There are no qt5 examples - how to get them ?
    Seems there are only example packages for webkit
    or do i need to add another repo to get qt5 examples ?
    AFAICS the examples are in packages named "xxx-examples", f.e. the examples for libqt5-qtbase are in "libqt5-qtbase-examples".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •