Results 1 to 9 of 9

Thread: Application Launcher Menu Settings don't work

  1. #1

    Default Application Launcher Menu Settings don't work

    I have Rt-clicked on "Application Launcher" & chosen "Application Launcher Menu Settings", then checked
    "Restart",
    "Shut Down",
    "Log out" and
    "Leave".

    After "Apply" and "OK", Launcher shows only
    "Log out" and
    "Leave >" which leads to the sub-menu which shows, among others,
    "Log out",
    "Lock",
    "Switch user",
    "Sleep" and
    "Hibernate".

    There is no "Restart" or "Shut Down" in view in the launcher.

    The only way I can restart or shut down is from a konsole, or
    "Log out", log back in as root, and shut down as root...,

    Or push the button.

    How can I get the Application Launcher to accept its Menu Settings?
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  2. #2

    Default Re: Application Launcher Menu Settings don't work

    Quote Originally Posted by Maximillium View Post
    How can I get the Application Launcher to accept its Menu Settings?
    Works fine here.

    Does it work if you create a new user (YaST->Security and Users->User and Group Management) and login as that?

    Do you get those options when you right-click on the desktop (or click on the toolbox icon) and choose "Leave..."?

  3. #3

    Default Re: Application Launcher Menu Settings don't work

    Hi Wolfi;

    Finally getting back to this....
    Quote Originally Posted by wolfi323 View Post
    Works fine here.

    Does it work if you create a new user (YaST->Security and Users->User and Group Management) and login as that?
    Yes - it does work with a (temporary) different user. Application Launcher menu setting edits "take" and the Launcher works as it should.
    Quote Originally Posted by wolfi323 View Post
    Do you get those options when you right-click on the desktop (or click on the toolbox icon) and choose "Leave..."?
    Rt click on desktop and choosing "Leave" works instantly, knocks me out to the login dialog.

    So now it's how to get the Launcher to take the settings changes as the regular user (me!).
    Last edited by Maximillium; 07-May-2014 at 23:51. Reason: clicked the wrong button too soon
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  4. #4

    Default Re: Application Launcher Menu Settings don't work

    Quote Originally Posted by Maximillium View Post
    Yes - it does work with a (temporary) different user. Application Launcher menu setting edits "take" and the Launcher works as it should.
    OK, so it's "only" a user configuration issue.

    Rt click on desktop and choosing "Leave" works instantly, knocks me out to the login dialog.
    You can configure this in "Configure Desktop"->"Startup and Shutdown"->"Session Management".
    You can set the "Default Leave Option" to logout, shutdown, or reboot.
    And there are two other options:
    • "Confirm Logout": shows a dialog with a countdown where you can cancel
    • "Offer Shutdown Options": shows a dialog which offers you to choose whether you want to logout, shutdown or reboot when you select "Leave..."


    So now it's how to get the Launcher to take the settings changes as the regular user (me!).
    Does it work when you add a new Application Launcher to the panel or desktop?
    If yes, then just remove the old one.

    Otherwise you could try to remove/rename the plasma configuration ~/.kde4/share/config/plasma-desktop-appletsrc, preferrably when plasma is not running. (so either log into a different session than KDE, or quit plasma with "kquitapp plasma-desktop", you can start it with "plasma-desktop" again afterwards, in the Alt+F2 run dialog or a konsole f.e.)

  5. #5

    Default Re: Application Launcher Menu Settings don't work

    Quote Originally Posted by wolfi323 View Post
    "Offer Shutdown Options": shows a dialog which offers you to choose whether you want to logout, shutdown or reboot when you select "Leave..."
    I just noticed that it's exactly this option that causes the "problem" you mentioned.

    "Restart" and "Shut Down" is only shown in the launcher if that option is enabled, so enable it and those entries should be there.

  6. #6

    Default Re: Application Launcher Menu Settings don't work [SOLVED]

    Quote Originally Posted by wolfi323 View Post
    I just noticed that it's exactly this option that causes the "problem" you mentioned.

    "Restart" and "Shut Down" is only shown in the launcher if that option is enabled, so enable it and those entries should be there.
    That was it! Well, it was the major clue; the option was already enabled, but using the Rt-click on the Application Launcher & choosing "Application Launcher Menu Settings" which gives a dialog that lets you choose the way you want the Application Launcher to appear/work, simply had no effect on the Application Launcher.

    BUT,
    Code:
    Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services, Check "Application menus daemon" & restart ("Stop" & "Start" at bottom right of window & "Apply")
    - and the application menu responds to its settings!

    Onward to the next thing. This box has a lot of OS things in it that don't mesh, but we're whittling it down, piece by piece.

    Thank you, Wolfi; I don't know what we'd all do without you guys who are willing to spend time helping the rest of us!
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  7. #7

    Default Re: Application Launcher Menu Settings don't work [SOLVED]

    Quote Originally Posted by Maximillium View Post
    BUT,
    Code:
    Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services, Check "Application menus daemon" & restart ("Stop" & "Start" at bottom right of window & "Apply")
    - and the application menu responds to its settings!
    Now that's strange.
    I don't have that enabled here, and the application launcher does show those options.

    And AFAIK that service is only needed for displaying the applications' menubar (i.e. "File", "Edit", "Help", ...) outside of their windows, f.e. on the top of the screen. See "Configure Desktop"->"General Appearance and Behavior"->"Application Appearance"->"Style"->"Fine Tuning".
    This is not related to the application launcher at all!

    Are you sure that this wasn't just a coincidence?

  8. #8

    Default Re: Application Launcher Menu Settings don't work [SOLVED]

    Quote Originally Posted by wolfi323 View Post
    Now that's strange.
    I don't have that enabled here, and the application launcher does show those options.

    And AFAIK that service is only needed for displaying the applications' menubar (i.e. "File", "Edit", "Help", ...) outside of their windows, f.e. on the top of the screen. See "Configure Desktop"->"General Appearance and Behavior"->"Application Appearance"->"Style"->"Fine Tuning".
    This is not related to the application launcher at all!

    Are you sure that this wasn't just a coincidence?
    I dunno, Wolfi - but the problem for me wasn't what appeared in the "Application Launcher", it was that the "Application Launcher" didn't reflect changes I made in the "Application Launcher Menu Settings" dialog.

    After I enabled the "Application menus daemon" in [Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services], the "Application Launcher" did indeed "take" the settings that I gave it from "Application Launcher Menu Settings".

    I was able to check it by making several consecutive settings changes in the menu, with the "Application menus daemon" alternately enabled and not, and yes, it makes no sense to me either, based on the descriptive terminology. To say that the "Application Launcher" is configured by an "Application Launcher Menu Settings" dialog is understandable - but to see that that dialog is enabled by a setting buried in [Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services] is hardly intuitive. One would have to be a dedicated reader of esoteric minutia to have any clue.

    The KDE Manual, like so many others, is no help either since it only tells you "how it works" when it works, nothing about what to do when it doesn't.
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  9. #9

    Default Re: Application Launcher Menu Settings don't work [SOLVED]

    Quote Originally Posted by Maximillium View Post
    I dunno, Wolfi - but the problem for me wasn't what appeared in the "Application Launcher", it was that the "Application Launcher" didn't reflect changes I made in the "Application Launcher Menu Settings" dialog.

    After I enabled the "Application menus daemon" in [Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services], the "Application Launcher" did indeed "take" the settings that I gave it from "Application Launcher Menu Settings".
    As I said, this works fine here with the "Application menus daemon" _disabled_.

    but to see that that dialog is enabled by a setting buried in [Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services] is hardly intuitive.
    Well, again, this is absolutely _not_ related at all. The "Application menus daemon" in [Configure Desktop > System Administration > Startup and Shutdown > Service Manager > Startup Services] is in fact for exporting Application menus as the description says (and I already as well).
    And application menus have absolutely nothing to do with the Application Launcher (although it is called K-Menu).

    The KDE Manual, like so many others, is no help either since it only tells you "how it works" when it works, nothing about what to do when it doesn't.
    Normally it should work.
    You cannot write every possible way it could be not working and how to fix it into the manual.

    My suspicion would be that somehow your plasma configuration was corrupted, and it got fixed at some point in between.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •