Results 1 to 5 of 5

Thread: Cannot enable lightdm.service in systemd

  1. #1

    Default Cannot enable lightdm.service in systemd

    I did a basic installation of openSUSE 13.1 with the idea of installing cinnamon and lightdm.
    Installed everything, including xorg, intel drivers and lightdm but when I run 'systemctl enable lightdm.service' I get a 'failed to issue method call, file not found' error.
    I checked /etc/systemd/system and there's nothing related to lightdm there, so something's missing.

  2. #2

    Default Re: Cannot enable lightdm.service in systemd

    Quote Originally Posted by bogdanc2011 View Post
    I did a basic installation of openSUSE 13.1 with the idea of installing cinnamon and lightdm.
    Installed everything, including xorg, intel drivers and lightdm but when I run 'systemctl enable lightdm.service' I get a 'failed to issue method call, file not found' error.
    I checked /etc/systemd/system and there's nothing related to lightdm there, so something's missing.
    No.
    X ist started by /etc/init.d/xdm. You can enable it with "systemctl enable xdm.service", but it should be enabled by default anyway.
    But maybe you have to set the default target to "graphical" or "runlevel5". Use "systemctl get-default" to see the current setting and run "systemctl set-default runlevel5.target" to set it accordingly.
    Or use YaST->System->Services Manager.

    xdm.service runs the corresponding display manager according to the configuration in /etc/sysconfig/displaymanager ("DISPLAYMANAGER").
    Set this to "lightdm" and it should be used.

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: Cannot enable lightdm.service in systemd

    Quote Originally Posted by bogdanc2011 View Post
    I checked /etc/systemd/system and there's nothing related to lightdm there, so something's missing.
    I have never used Lightdm, but I suspect that your systmctl approach is wrong. To select e.g. kdm, gdm, xdm, the /etc/sysconfig//displaymanager file is edited.

    You can either use a text editor to set the appropriate value for "DISPLAYMANAGER", or use YaST >> System >> sysconfig editor > Display manager> DISPLAYMANAGER.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  4. #4

    Default Re: Cannot enable lightdm.service in systemd

    systemctl set-default runlevel5.target

    This gives me an error. get-default tells me the runlevel is 3.

    I also tried changing "xdm" to "lightdm" in sysconfig and it still gets me to runlevel 3.

  5. #5

    Default Re: Cannot enable lightdm.service in systemd

    Quote Originally Posted by bogdanc2011 View Post
    systemctl set-default runlevel5.target

    This gives me an error. get-default tells me the runlevel is 3.
    Then try:
    Code:
    systemctl set-default graphical.target
    Or use YaST->Services Manager as already said.

    I also tried changing "xdm" to "lightdm" in sysconfig and it still gets me to runlevel 3.
    Of course. This only tells xdm.service which DM to run, but it doesn't change the default target/runlevel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •