Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

  1. #1

    Default Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Hi,

    I finally got a fresh 13.1 install to boot on my latest-gen i7 laptop with HD 4600 graphics, but it only boots successfully with the nomodeset option in Grub. If I boot in failsafe mode, it will hang at "Reached target graphical interface." A fresh install boots to a blank screen, and failsafe mode also fails. Seems odd for such a mainstream graphics chip, though it is still fairly new.

    Any idea as to how I can go about diagnosing this, so that I don't have to boot with the nomodeset option? Is this a known bug?

  2. #2

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    First of all, please check that you have the latest xf86-video-intel from the Update repo installed. The version included in 13.1 could crash on some systems but this should be fixed already.

    Please do a normal boot (without nomodeset), then reboot with nomodeset and post /var/log/Xorg.0.log.old (via http://susepaste.org f.e.).

    Since this is an intel chip, you might have a problem with the new SNA acceleration.
    Try to switch to the older but stable UXA:
    https://en.opensuse.org/SDB:Switch_x...o-intel_to_UXA

    As to why Failsafe mode is not working:
    Please check, that you have a file /etc/X11/xorg.conf.install, that's needed for Failsafe/Recovery Mode.

  3. #3

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Thanks for the suggestions; unfortunately it's still not working. My openSUSE install is fully updated, including the latest xf86-video-intel (2.99.906-12.1 64-bit). Disabling SNA did not solve the problem. Here is /var/log/Xorg.0.log.old:

    Code:
    [    15.047] 
    This is a pre-release version of the X server from The X.Org Foundation.
    It is not supported in any way.
    Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
    Select the "xorg" product for bugs you find in this release.
    Before reporting bugs in pre-release versions please check the
    latest version in the X.Org Foundation git repository.
    See http://wiki.x.org/wiki/GitPage for git access instructions.
    [    15.047] 
    X.Org X Server 1.14.3.901 (1.14.4 RC 1)
    Release Date: 2013-10-26
    [    15.047] X Protocol Version 11, Revision 0
    [    15.047] Build Operating System: openSUSE SUSE LINUX
    [    15.047] Current Operating System: Linux linux-a05p 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64
    [    15.047] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.10-7-desktop root=UUID=7f2d56aa-e6ba-481d-9f67-bab36e8f73a8 resume=/dev/disk/by-id/ata-ST1000LM024_HN-M101MBB_S2Y9J9BD401873-part4 splash=silent quiet showopts
    [    15.047] Build Date: 19 December 2013  01:42:00PM
    [    15.047]  
    [    15.047] Current version of pixman: 0.30.2
    [    15.047]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    15.047] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    15.047] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 24 14:42:42 2014
    [    15.047] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    15.047] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    15.110] (==) No Layout section.  Using the first Screen section.
    [    15.110] (==) No screen section available. Using defaults.
    [    15.110] (**) |-->Screen "Default Screen Section" (0)
    [    15.110] (**) |   |-->Monitor "<default monitor>"
    [    15.110] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
    [    15.110] (==) Automatically adding devices
    [    15.110] (==) Automatically enabling devices
    [    15.110] (==) Automatically adding GPU devices
    [    15.624] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [    15.624]     Entry deleted from font path.
    [    15.624] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/ghostscript/,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
    [    15.624] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    [    15.624] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    15.624] (II) Loader magic: 0x803c20
    [    15.624] (II) Module ABI versions:
    [    15.625]     X.Org ANSI C Emulation: 0.4
    [    15.625]     X.Org Video Driver: 14.1
    [    15.625]     X.Org XInput driver : 19.1
    [    15.625]     X.Org Server Extension : 7.0
    [    15.625] (II) xfree86: Adding drm device (/dev/dri/card0)
    [    15.626] (--) PCI:*(0:0:2:0) 8086:0416:103c:1962 rev 6, Mem @ 0xb2000000/4194304, 0xa0000000/268435456, I/O @ 0x00005000/64
    [    15.626] Initializing built-in extension Generic Event Extension
    [    15.626] Initializing built-in extension SHAPE
    [    15.626] Initializing built-in extension MIT-SHM
    [    15.626] Initializing built-in extension XInputExtension
    [    15.626] Initializing built-in extension XTEST
    [    15.626] Initializing built-in extension BIG-REQUESTS
    [    15.626] Initializing built-in extension SYNC
    [    15.626] Initializing built-in extension XKEYBOARD
    [    15.626] Initializing built-in extension XC-MISC
    [    15.626] Initializing built-in extension SECURITY
    [    15.626] Initializing built-in extension XINERAMA
    [    15.626] Initializing built-in extension XFIXES
    [    15.626] Initializing built-in extension RENDER
    [    15.626] Initializing built-in extension RANDR
    [    15.626] Initializing built-in extension COMPOSITE
    [    15.626] Initializing built-in extension DAMAGE
    [    15.626] Initializing built-in extension MIT-SCREEN-SAVER
    [    15.626] Initializing built-in extension DOUBLE-BUFFER
    [    15.626] Initializing built-in extension RECORD
    [    15.626] Initializing built-in extension DPMS
    [    15.626] Initializing built-in extension X-Resource
    [    15.626] Initializing built-in extension XVideo
    [    15.626] Initializing built-in extension XVideo-MotionCompensation
    [    15.626] Initializing built-in extension XFree86-VidModeExtension
    [    15.626] Initializing built-in extension XFree86-DGA
    [    15.626] Initializing built-in extension XFree86-DRI
    [    15.626] Initializing built-in extension DRI2
    [    15.626] (II) "glx" will be loaded by default.
    [    15.626] (II) LoadModule: "dri2"
    [    15.626] (II) Module "dri2" already built-in
    [    15.626] (II) LoadModule: "glamoregl"
    [    15.643] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [    15.644] (II) Module glamoregl: vendor="X.Org Foundation"
    [    15.644]     compiled for 1.14.3.901, module version = 0.5.1
    [    15.644]     ABI class: X.Org ANSI C Emulation, version 0.4
    [    15.644] (II) LoadModule: "glx"
    [    15.644] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    15.644] (II) Module glx: vendor="X.Org Foundation"
    [    15.644]     compiled for 1.14.3.901, module version = 1.0.0
    [    15.644]     ABI class: X.Org Server Extension, version 7.0
    [    15.644] (==) AIGLX enabled
    [    15.645] Loading extension GLX
    [    15.645] (==) Matched intel as autoconfigured driver 0
    [    15.645] (==) Matched intel as autoconfigured driver 1
    [    15.645] (==) Matched modesetting as autoconfigured driver 2
    [    15.645] (==) Matched fbdev as autoconfigured driver 3
    [    15.645] (==) Matched vesa as autoconfigured driver 4
    [    15.645] (==) Assigned the driver to the xf86ConfigLayout
    [    15.645] (II) LoadModule: "intel"
    [    15.645] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [    15.645] (II) Module intel: vendor="X.Org Foundation"
    [    15.645]     compiled for 1.14.3.901, module version = 2.99.906
    [    15.645]     Module class: X.Org Video Driver
    [    15.645]     ABI class: X.Org Video Driver, version 14.1
    [    15.645] (II) LoadModule: "modesetting"
    [    15.645] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    [    15.684] (II) Module modesetting: vendor="X.Org Foundation"
    [    15.684]     compiled for 1.14.3.901, module version = 0.8.0
    [    15.684]     Module class: X.Org Video Driver
    [    15.684]     ABI class: X.Org Video Driver, version 14.1
    [    15.684] (II) LoadModule: "fbdev"
    [    15.685] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [    15.697] (II) Module fbdev: vendor="X.Org Foundation"
    [    15.697]     compiled for 1.14.3, module version = 0.4.3
    [    15.697]     Module class: X.Org Video Driver
    [    15.697]     ABI class: X.Org Video Driver, version 14.1
    [    15.697] (II) LoadModule: "vesa"
    [    15.697] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [    15.702] (II) Module vesa: vendor="X.Org Foundation"
    [    15.702]     compiled for 1.14.3, module version = 2.3.3
    [    15.702]     Module class: X.Org Video Driver
    [    15.702]     ABI class: X.Org Video Driver, version 14.1
    [    15.702] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
    [    15.702] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    15.702] (II) FBDEV: driver for framebuffer: fbdev
    [    15.703] (II) VESA: driver for VESA chipsets: vesa
    [    15.703] (++) using VT number 7
    
    [    15.703] (WW) Falling back to old probe method for modesetting
    [    15.703] (WW) Falling back to old probe method for fbdev
    [    15.703] (II) Loading sub module "fbdevhw"
    [    15.703] (II) LoadModule: "fbdevhw"
    [    15.704] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [    15.712] (II) Module fbdevhw: vendor="X.Org Foundation"
    [    15.712]     compiled for 1.14.3.901, module version = 0.0.2
    [    15.712]     ABI class: X.Org Video Driver, version 14.1
    [    15.712] (WW) Falling back to old probe method for vesa
    [    15.712] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
    [    15.712] (==) intel(0): Depth 24, (--) framebuffer bpp 32
    [    15.712] (==) intel(0): RGB weight 888
    [    15.712] (==) intel(0): Default visual is TrueColor
    [    15.712] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4600
    [    15.712] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2
    [    15.712] (**) intel(0): Framebuffer tiled
    [    15.712] (**) intel(0): Pixmaps tiled
    [    15.712] (**) intel(0): "Tear free" disabled
    [    15.712] (**) intel(0): Forcing per-crtc-pixmaps? no
    [    15.713] (II) intel(0): Output eDP1 has no monitor section
    [    15.713] (--) intel(0): found backlight control interface acpi_video0 (type 'firmware')
    [    15.713] (II) intel(0): Output VGA1 has no monitor section
    [    15.713] (II) intel(0): Output DP1 has no monitor section
    [    15.713] (II) intel(0): Output HDMI1 has no monitor section
    [    15.713] (II) intel(0): Output VIRTUAL1 has no monitor section
    [    15.713] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
    [    15.713] (==) intel(0): DPI set to (96, 96)
    [    15.713] (II) Loading sub module "dri2"
    [    15.713] (II) LoadModule: "dri2"
    [    15.713] (II) Module "dri2" already built-in
    [    15.713] (II) UnloadModule: "modesetting"
    [    15.713] (II) Unloading modesetting
    [    15.713] (II) UnloadModule: "fbdev"
    [    15.713] (II) Unloading fbdev
    [    15.713] (II) UnloadSubModule: "fbdevhw"
    [    15.713] (II) Unloading fbdevhw
    [    15.713] (II) UnloadModule: "vesa"
    [    15.713] (II) Unloading vesa
    [    15.713] (==) Depth 24 pixmap format is 32 bpp
    [    15.713] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
    [    15.713] (==) intel(0): Backing store disabled
    [    15.713] (==) intel(0): Silken mouse enabled
    [    15.713] (II) intel(0): HW Cursor enabled
    [    15.713] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    [    15.713] (==) intel(0): DPMS enabled
    [    15.713] (II) intel(0): [DRI2] Setup complete
    [    15.713] (II) intel(0): [DRI2]   DRI driver: i965
    [    15.713] (II) intel(0): direct rendering: DRI2 Enabled
    [    15.713] (==) intel(0): hotplug detection: "enabled"
    [    15.713] (--) RandR disabled
    [    15.860] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    [    15.860] (II) AIGLX: enabled GLX_INTEL_swap_event
    [    15.860] (II) AIGLX: enabled GLX_ARB_create_context
    [    15.860] (II) AIGLX: enabled GLX_ARB_create_context_profile
    [    15.860] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
    [    15.860] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
    [    15.860] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    [    15.860] (II) AIGLX: Loaded and initialized i965
    [    15.860] (II) GLX: Initialized DRI2 GL provider for screen 0
    [    15.861] (II) intel(0): switch to mode 1366x768@60.0 on pipe 0 using eDP1, position (0, 0), rotation normal
    [    15.883] (II) intel(0): Setting screen physical size to 361 x 203
    [    16.194] (II) config/udev: Adding input device Power Button (/dev/input/event4)
    [    16.194] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [    16.194] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [    16.194] (**) Power Button: Applying InputClass "LocalKeyboard"
    [    16.194] (II) LoadModule: "evdev"
    [    16.195] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
    [    16.215] (II) Module evdev: vendor="X.Org Foundation"
    [    16.215]     compiled for 1.14.3, module version = 2.8.2
    [    16.215]     Module class: X.Org XInput Driver
    [    16.215]     ABI class: X.Org XInput driver, version 19.1
    [    16.215] (II) Using input driver 'evdev' for 'Power Button'
    [    16.215] (**) Power Button: always reports core events
    [    16.215] (**) evdev: Power Button: Device: "/dev/input/event4"
    [    16.215] (--) evdev: Power Button: Vendor 0 Product 0x1
    [    16.215] (--) evdev: Power Button: Found keys
    [    16.215] (II) evdev: Power Button: Configuring as keyboard
    [    16.215] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event4"
    [    16.215] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
    [    16.215] (**) Option "xkb_rules" "evdev"
    [    16.215] (**) Option "xkb_model" "pc104"
    [    16.215] (**) Option "xkb_layout" "us"
    [    16.237] (II) config/udev: Adding input device Video Bus (/dev/input/event6)
    [    16.237] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
    [    16.237] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
    [    16.237] (**) Video Bus: Applying InputClass "LocalKeyboard"
    [    16.237] (II) Using input driver 'evdev' for 'Video Bus'
    [    16.237] (**) Video Bus: always reports core events
    [    16.237] (**) evdev: Video Bus: Device: "/dev/input/event6"
    [    16.237] (--) evdev: Video Bus: Vendor 0 Product 0x6
    [    16.237] (--) evdev: Video Bus: Found keys
    [    16.237] (II) evdev: Video Bus: Configuring as keyboard
    [    16.237] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input6/event6"
    [    16.237] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
    [    16.237] (**) Option "xkb_rules" "evdev"
    [    16.237] (**) Option "xkb_model" "pc104"
    [    16.237] (**) Option "xkb_layout" "us"
    [    16.237] (II) config/udev: Adding input device Power Button (/dev/input/event3)
    [    16.237] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [    16.237] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [    16.237] (**) Power Button: Applying InputClass "LocalKeyboard"
    [    16.237] (II) Using input driver 'evdev' for 'Power Button'
    [    16.237] (**) Power Button: always reports core events
    [    16.237] (**) evdev: Power Button: Device: "/dev/input/event3"
    [    16.237] (--) evdev: Power Button: Vendor 0 Product 0x1
    [    16.237] (--) evdev: Power Button: Found keys
    [    16.237] (II) evdev: Power Button: Configuring as keyboard
    Cont...

  4. #4

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Cont...

    Code:
    [    16.237] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input3/event3"
    [    16.237] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
    [    16.237] (**) Option "xkb_rules" "evdev"
    [    16.237] (**) Option "xkb_model" "pc104"
    [    16.238] (**) Option "xkb_layout" "us"
    [    16.238] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
    [    16.238] (II) No input driver specified, ignoring this device.
    [    16.238] (II) This device may have been added with another device file.
    [    16.238] (II) config/udev: Adding drm device (/dev/dri/card0)
    [    16.238] (II) config/udev: Adding input device HDA Intel MID HDMI/DP,pcm=8 (/dev/input/event11)
    [    16.238] (II) No input driver specified, ignoring this device.
    [    16.238] (II) This device may have been added with another device file.
    [    16.238] (II) config/udev: Adding input device HDA Intel MID HDMI/DP,pcm=7 (/dev/input/event12)
    [    16.238] (II) No input driver specified, ignoring this device.
    [    16.238] (II) This device may have been added with another device file.
    [    16.238] (II) config/udev: Adding input device HDA Intel MID HDMI/DP,pcm=3 (/dev/input/event13)
    [    16.238] (II) No input driver specified, ignoring this device.
    [    16.238] (II) This device may have been added with another device file.
    [    16.238] (II) config/udev: Adding input device eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00 (/dev/input/event7)
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Applying InputClass "evdev touchscreen catchall"
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Applying InputClass "evdev touchscreen catchall"
    [    16.239] (II) Using input driver 'evdev' for 'eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00'
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: always reports core events
    [    16.239] (**) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Device: "/dev/input/event7"
    [    16.239] (II) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Using mtdev for this device
    [    16.239] (--) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Vendor 0xeef Product 0xa103
    [    16.239] (--) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Found absolute axes
    [    16.239] (--) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Found absolute multitouch axes
    [    16.239] (II) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: No buttons found, faking one.
    [    16.239] (--) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Found x and y absolute axes
    [    16.239] (--) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Found absolute touchscreen
    [    16.239] (II) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Configuring as touchscreen
    [    16.239] (**) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: YAxisMapping: buttons 4 and 5
    [    16.239] (**) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [    16.239] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-13/3-13:1.0/input/input7/event7"
    [    16.239] (II) XINPUT: Adding extended input device "eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00" (type: TOUCHSCREEN, id 9)
    [    16.239] (II) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: initialized for absolute axes.
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: (accel) keeping acceleration scheme 1
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: (accel) acceleration profile 0
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: (accel) acceleration factor: 2.000
    [    16.239] (**) eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: (accel) acceleration threshold: 4
    [    16.239] (II) config/udev: Adding input device eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00 (/dev/input/mouse2)
    [    16.239] (II) No input driver specified, ignoring this device.
    [    16.239] (II) This device may have been added with another device file.
    [    16.239] (II) config/udev: Adding input device Dynex 5-Button Wired Optical Mouse (/dev/input/event5)
    [    16.239] (**) Dynex 5-Button Wired Optical Mouse: Applying InputClass "evdev pointer catchall"
    [    16.239] (**) Dynex 5-Button Wired Optical Mouse: Applying InputClass "evdev pointer catchall"
    [    16.239] (II) Using input driver 'evdev' for 'Dynex 5-Button Wired Optical Mouse'
    [    16.239] (**) Dynex 5-Button Wired Optical Mouse: always reports core events
    [    16.239] (**) evdev: Dynex 5-Button Wired Optical Mouse: Device: "/dev/input/event5"
    [    16.239] (--) evdev: Dynex 5-Button Wired Optical Mouse: Vendor 0x461 Product 0x4d42
    [    16.239] (--) evdev: Dynex 5-Button Wired Optical Mouse: Found 9 mouse buttons
    [    16.239] (--) evdev: Dynex 5-Button Wired Optical Mouse: Found scroll wheel(s)
    [    16.239] (--) evdev: Dynex 5-Button Wired Optical Mouse: Found relative axes
    [    16.239] (--) evdev: Dynex 5-Button Wired Optical Mouse: Found x and y relative axes
    [    16.239] (II) evdev: Dynex 5-Button Wired Optical Mouse: Configuring as mouse
    [    16.239] (II) evdev: Dynex 5-Button Wired Optical Mouse: Adding scrollwheel support
    [    16.239] (**) evdev: Dynex 5-Button Wired Optical Mouse: YAxisMapping: buttons 4 and 5
    [    16.239] (**) evdev: Dynex 5-Button Wired Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [    16.239] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/input/input5/event5"
    [    16.239] (II) XINPUT: Adding extended input device "Dynex 5-Button Wired Optical Mouse" (type: MOUSE, id 10)
    [    16.239] (II) evdev: Dynex 5-Button Wired Optical Mouse: initialized for relative axes.
    [    16.239] (**) Dynex 5-Button Wired Optical Mouse: (accel) keeping acceleration scheme 1
    [    16.240] (**) Dynex 5-Button Wired Optical Mouse: (accel) acceleration profile 0
    [    16.240] (**) Dynex 5-Button Wired Optical Mouse: (accel) acceleration factor: 2.000
    [    16.240] (**) Dynex 5-Button Wired Optical Mouse: (accel) acceleration threshold: 4
    [    16.240] (II) config/udev: Adding input device Dynex 5-Button Wired Optical Mouse (/dev/input/mouse1)
    [    16.240] (II) No input driver specified, ignoring this device.
    [    16.240] (II) This device may have been added with another device file.
    [    16.240] (II) config/udev: Adding input device HP Truevision HD (/dev/input/event10)
    [    16.240] (**) HP Truevision HD: Applying InputClass "evdev keyboard catchall"
    [    16.240] (**) HP Truevision HD: Applying InputClass "evdev keyboard catchall"
    [    16.240] (**) HP Truevision HD: Applying InputClass "LocalKeyboard"
    [    16.240] (II) Using input driver 'evdev' for 'HP Truevision HD'
    [    16.240] (**) HP Truevision HD: always reports core events
    [    16.240] (**) evdev: HP Truevision HD: Device: "/dev/input/event10"
    [    16.240] (--) evdev: HP Truevision HD: Vendor 0xbda Product 0x571a
    [    16.240] (--) evdev: HP Truevision HD: Found keys
    [    16.240] (II) evdev: HP Truevision HD: Configuring as keyboard
    [    16.240] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-7/3-7:1.0/input/input10/event10"
    [    16.240] (II) XINPUT: Adding extended input device "HP Truevision HD" (type: KEYBOARD, id 11)
    [    16.240] (**) Option "xkb_rules" "evdev"
    [    16.240] (**) Option "xkb_model" "pc104"
    [    16.240] (**) Option "xkb_layout" "us"
    [    16.240] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event14)
    [    16.240] (II) No input driver specified, ignoring this device.
    [    16.240] (II) This device may have been added with another device file.
    [    16.240] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event15)
    [    16.240] (II) No input driver specified, ignoring this device.
    [    16.240] (II) This device may have been added with another device file.
    [    16.241] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event16)
    [    16.241] (II) No input driver specified, ignoring this device.
    [    16.241] (II) This device may have been added with another device file.
    [    16.241] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
    [    16.241] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    [    16.241] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    [    16.241] (**) AT Translated Set 2 keyboard: Applying InputClass "LocalKeyboard"
    [    16.241] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
    [    16.241] (**) AT Translated Set 2 keyboard: always reports core events
    [    16.241] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
    [    16.241] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
    [    16.241] (--) evdev: AT Translated Set 2 keyboard: Found keys
    [    16.241] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
    [    16.241] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
    [    16.241] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 12)
    [    16.241] (**) Option "xkb_rules" "evdev"
    [    16.241] (**) Option "xkb_model" "pc104"
    [    16.241] (**) Option "xkb_layout" "us"
    [    16.241] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event1)
    [    16.241] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
    [    16.241] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
    [    16.241] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
    [    16.241] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
    [    16.241] (II) LoadModule: "synaptics"
    [    16.241] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
    [    16.249] (II) Module synaptics: vendor="X.Org Foundation"
    [    16.249]     compiled for 1.14.3, module version = 1.7.1
    [    16.249]     Module class: X.Org XInput Driver
    [    16.249]     ABI class: X.Org XInput driver, version 19.1
    [    16.249] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
    [    16.249] (**) SynPS/2 Synaptics TouchPad: always reports core events
    [    16.249] (**) Option "Device" "/dev/input/event1"
    [    16.280] (II) synaptics: SynPS/2 Synaptics TouchPad: found clickpad property
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5660 (res 41)
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4702 (res 56)
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left double triple
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
    [    16.280] (**) Option "HorizScrollDelta" "0"
    [    16.280] (**) Option "TapButton1" "1"
    [    16.280] (**) Option "TapButton2" "3"
    [    16.280] (**) Option "TapButton3" "2"
    [    16.280] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    [    16.280] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
    [    16.280] (**) SynPS/2 Synaptics TouchPad: always reports core events
    [    16.298] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input1/event1"
    [    16.298] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 13)
    [    16.298] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
    [    16.298] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
    [    16.298] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.038
    [    16.298] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
    [    16.298] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
    [    16.298] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
    [    16.298] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
    [    16.299] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
    [    16.299] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
    [    16.299] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
    [    16.300] (II) config/udev: Adding input device PC Speaker (/dev/input/event8)
    [    16.300] (II) No input driver specified, ignoring this device.
    [    16.300] (II) This device may have been added with another device file.
    [    16.302] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event9)
    [    16.302] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
    [    16.302] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
    [    16.302] (**) HP WMI hotkeys: Applying InputClass "LocalKeyboard"
    [    16.302] (II) Using input driver 'evdev' for 'HP WMI hotkeys'
    [    16.302] (**) HP WMI hotkeys: always reports core events
    [    16.302] (**) evdev: HP WMI hotkeys: Device: "/dev/input/event9"
    [    16.302] (--) evdev: HP WMI hotkeys: Vendor 0 Product 0
    [    16.302] (--) evdev: HP WMI hotkeys: Found keys
    [    16.302] (II) evdev: HP WMI hotkeys: Configuring as keyboard
    [    16.302] (**) Option "config_info" "udev:/sys/devices/virtual/input/input9/event9"
    [    16.302] (II) XINPUT: Adding extended input device "HP WMI hotkeys" (type: KEYBOARD, id 14)
    [    16.302] (**) Option "xkb_rules" "evdev"
    [    16.302] (**) Option "xkb_model" "pc104"
    [    16.302] (**) Option "xkb_layout" "us"
    [   257.007] (II) evdev: HP WMI hotkeys: Close
    [   257.007] (II) UnloadModule: "evdev"
    [   257.007] (II) UnloadModule: "synaptics"
    [   257.007] (II) evdev: AT Translated Set 2 keyboard: Close
    [   257.007] (II) UnloadModule: "evdev"
    [   257.007] (II) evdev: HP Truevision HD: Close
    [   257.008] (II) UnloadModule: "evdev"
    [   257.008] (II) evdev: Dynex 5-Button Wired Optical Mouse: Close
    [   257.008] (II) UnloadModule: "evdev"
    [   257.008] (II) evdev: eGalax Inc. eGalaxTouch EXC7910-1023-04.00.00: Close
    [   257.008] (II) UnloadModule: "evdev"
    [   257.008] (II) evdev: Power Button: Close
    [   257.008] (II) UnloadModule: "evdev"
    [   257.008] (II) evdev: Video Bus: Close
    [   257.008] (II) UnloadModule: "evdev"
    [   257.008] (II) evdev: Power Button: Close
    [   257.008] (II) UnloadModule: "evdev"
    [   257.035] (EE) Server terminated successfully (0). Closing log file.
    Have any other ideas?

  5. #5

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Quote Originally Posted by nathan_k View Post
    Have any other ideas?
    Not really at the moment.
    I don't find any error in there.

    Maybe try to boot with "plymouth.enable=0" added to the boot options?

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    This bug report may be of interest

    https://bugzilla.redhat.com/show_bug.cgi?id=989084

    It might be worth reviewing kernel bugs too.

  7. #7

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Quote Originally Posted by deano_ferrari View Post
    This bug report may be of interest

    https://bugzilla.redhat.com/show_bug.cgi?id=989084
    That solved my problem, thank you! The issue, as described in the (unresolved/closed) bug, is that the backlight on my laptop screen is getting set to 0 early in the boot process. The problem is solved by using the "acpi_backlight=vendor" kernel setting in Grub.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Quote Originally Posted by nathan_k View Post
    That solved my problem, thank you! The issue, as described in the (unresolved/closed) bug, is that the backlight on my laptop screen is getting set to 0 early in the boot process. The problem is solved by using the "acpi_backlight=vendor" kernel setting in Grub.
    That's good to know. It may be of help to others with this hardware.

  9. #9
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,191

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Quote Originally Posted by deano_ferrari View Post
    That's good to know. It may be of help to others with this hardware.
    WOW!!! I'm glad I found this thread!!!

    Patricia

    Edit: is the "acpi_backlight=vendor" addition into the boot options line in GRUB2?

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,285

    Default Re: Fresh 13.1 KDE install boots to blank screen unless nomodeset on intel HD 4600

    Easiest made persistent in Yast -boot loader section

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •