Results 1 to 6 of 6

Thread: how to install 'libxslt-dev libxml2-dev' ?

  1. #1

    Unhappy how to install 'libxslt-dev libxml2-dev' ?

    i want to install nokogiri gem ( http://nokogiri.org/tutorials/installing_nokogiri.html ) on opensuse 13.1 but getting error

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,048

    Default Re: how to install 'libxslt-dev libxml2-dev' ?

    On Thu, 24 Apr 2014 06:06:01 +0000, akashkumarEngg wrote:

    > i want to install nokogiri gem (
    > http://nokogiri.org/tutorials/installing_nokogiri.html ) on opensuse
    > 13.1 but getting error


    And the command you're running is....?

    And the error you're getting is....?

    Details - we need details.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: how to install 'libxslt-dev libxml2-dev' ?

    gem install nokogiri -v '1.6.1'


    Building native extensions. This could take a while...
    ERROR: Error installing nokogiri:
    ERROR: Failed to build gem native extension.

    /home/akash/.rvm/rubies/ruby-2.1.1/bin/ruby extconf.rb
    Extracting libxml2-2.8.0.tar.gz into tmp/x86_64-suse-linux/ports/libxml2/2.8.0... OK
    Running 'configure' for libxml2 2.8.0... OK
    Running 'compile' for libxml2 2.8.0... OK
    Running 'install' for libxml2 2.8.0... OK
    Activating libxml2 2.8.0 (from /home/akash/.rvm/gems/ruby-2.1.1/gems/nokogiri-1.6.1/ports/x86_64-suse-linux/libxml2/2.8.0)...
    Extracting libxslt-1.1.26.tar.gz into tmp/x86_64-suse-linux/ports/libxslt/1.1.26... OK
    Running 'configure' for libxslt 1.1.26... OK
    Running 'compile' for libxslt 1.1.26... OK
    Running 'install' for libxslt 1.1.26... OK
    Activating libxslt 1.1.26 (from /home/akash/.rvm/gems/ruby-2.1.1/gems/nokogiri-1.6.1/ports/x86_64-suse-linux/libxslt/1.1.26)...
    checking for libxml/parser.h... yes
    checking for libxslt/xslt.h... yes
    checking for libexslt/exslt.h... yes
    checking for iconv_open() in iconv.h... yes
    checking for xmlParseDoc() in -lxml2... yes
    checking for xsltParseStylesheetDoc() in -lxslt... no
    -----
    libxslt is missing. please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.
    -----
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of necessary
    libraries and/or headers. Check the mkmf.log file for more details. You may
    need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/home/akash/.rvm/rubies/ruby-2.1.1/bin/ruby
    --with-zlib-dir
    --without-zlib-dir
    --with-zlib-include
    --without-zlib-include=${zlib-dir}/include
    --with-zlib-lib
    --without-zlib-lib=${zlib-dir}/lib
    --with-iconv-dir
    --without-iconv-dir
    --with-iconv-include
    --without-iconv-include=${iconv-dir}/include
    --with-iconv-lib
    --without-iconv-lib=${iconv-dir}/lib
    --with-xml2-dir
    --without-xml2-dir
    --with-xml2-include
    --without-xml2-include=${xml2-dir}/include
    --with-xml2-lib
    --without-xml2-lib=${xml2-dir}/lib
    --with-xslt-dir
    --without-xslt-dir
    --with-xslt-include
    --without-xslt-include=${xslt-dir}/include
    --with-xslt-lib
    --without-xslt-lib=${xslt-dir}/lib
    --with-libxslt-config
    --without-libxslt-config
    --with-pkg-config
    --without-pkg-config
    --with-libxml-2.0-config
    --without-libxml-2.0-config
    --with-libiconv-config
    --without-libiconv-config
    --with-xml2lib
    --without-xml2lib
    --with-xsltlib
    --without-xsltlib

    extconf failed, exit code 1

    Gem files will remain installed in /home/akash/.rvm/gems/ruby-2.1.1/gems/nokogiri-1.6.1 for inspection.
    Results logged to /home/akash/.rvm/gems/ruby-2.1.1/extensions/x86_64-linux/2.1.0/nokogiri-1.6.1/gem_make.out

  4. #4

    Default Re: how to install 'libxslt-dev libxml2-dev' ?

    The packages you want/need are called "libxml2-devel" and "libxslt-devel" on openSUSE. So install those with YaST->Software Management, or run:
    Code:
    sudo zypper in libxml2-devel libxslt-devel

  5. #5

    Default Re: how to install 'libxslt-dev libxml2-dev' ?

    thanks .. in my case
    sudo zypper install --oldpackage libxslt-devel-1.1.28-5.1.2.x86_64
    working..

  6. #6

    Default Re: how to install 'libxslt-dev libxml2-dev' ?

    Quote Originally Posted by akashkumarEngg View Post
    thanks .. in my case


    working..
    So you already had a higher version of libxslt-devel installed?
    From where?

    libxslt-devel-1.1.28-5.1.2 is the one that's included in openSUSE 13.1.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •