Results 1 to 3 of 3

Thread: Samba dependencies

  1. #1

    Default Samba dependencies

    I use OpenSuse on my raspberry pi, I have a minimal configuration that runs headless.
    I try to keep the installed packages to the bare minimum and I realized that, in order to install samba, the following packages are automatically added by zypper:

    Code:
    at-spi2-atk-common at-spi2-atk-gtk2 at-spi2-core bind-libs bind-utils bundle-lang-common-ar bundle-lang-gnome-en cantarell-fonts checkmedia cifs-utils cryptsetup cryptsetup-mkinitrd dmraid fuse gcr-data 
      gcr-prompter gcr-viewer glib2-tools glib-networking glib-networking-lang gnome-online-accounts gptfdisk gsettings-desktop-schemas gstreamer gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-plugins-base 
      gtk3-branding-upstream gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-tools gvfs gvfs-backend-afc gvfs-backends gvfs-fuse hunspell hunspell-tools 
      keyutils kpartx libarchive13 libaspell15 libatasmart4 libatk-bridge-2_0-0 libatspi0 libbluetooth3 libbluray1 libcairo-gobject2 libcanberra-gtk0 libcanberra-gtk2-module libcanberra-gtk3-0 libcanberra-gtk3-module 
      libcanberra-gtk-module-common libcdda_interface0 libcdda_paranoia0 libcdio14 libcdio_cdda1 libcdio_paranoia1 libcolord2 libdcerpc0 libdcerpc-binding0 libelf0 libenchant1 libgck-1-0 libgcr-3-1 libgensec0 
      libgeoclue0 libgnutls28 libgoa-1_0-0 libgoa-backend-1_0-1 libgphoto2-6 libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstinterfaces-0_10-0 libgstpbutils-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0 
      libgstriff-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 libgtk-3-0 libgudev-1_0-0 libgvfscommon0 libharfbuzz-icu0 libhogweed2 libicu51_2 libicu51_2-data libimobiledevice4 libjavascriptcoregtk-3_0-0 
      libjson-glib-1_0-0 liblcms2-2 libldapcpp1 libldb1 liblockdev1 libmtp9 libndr0 libndr-krb5pac0 libndr-nbt0 libndr-standard0 libnetapi0 libnettle4 libopenobex1 liborc-0_4-0 libpackagekit-glib2-16 libparted0 
      libpdb0 libplist1 libproxy1-pacrunner-webkit libregistry0 libreiserfs-0_3-0 librest0 libsamba-credentials0 libsamba-hostconfig0 libsamba-util0 libsamdb0 libsecret-1-0 libsmbclient0 libsmbclient-raw0 libsmbconf0 
      libsmbldap0 libsoup-2_4-1 libstorage4 libstorage-ruby libtalloc2 libtdb1 libtelepathy-glib0 libtevent0 libtevent-util0 libtheora0 libudisks2-0 libusbmuxd2 libvisual libwbclient0 libwebkitgtk-3_0-0 
      libwebkitgtk3-lang libwebp4 libXevie1 libxslt1 libXtst6 libXv1 libyaml-0-2 libyui5 libyui-gtk5 libyui-gtk-pkg5 libyui-ncurses5 lockdev lsscsi lvm2 mdadm multipath-tools obex-data-server PackageKit 
      PackageKit-backend-zypp PackageKit-branding-openSUSE PackageKit-gstreamer-plugin PackageKit-gtk3-module pam-config parted perl-Config-Crontab perl-Crypt-SmbHash perl-Digest-MD4 perl-Digest-SHA1 
      perl-Parse-RecDescent perl-X500-DN perl-XML-LibXML perl-XML-NamespaceSupport perl-XML-SAX perl-XML-SAX-Base perl-XML-SAX-Expat perl-XML-Simple perl-XML-XPath pytalloc ruby ruby20 rubygem-fast_gettext 
      rubygem-ruby-dbus samba samba-client samba-libs udisks2 unzip unzip-doc usbmuxd yast2 yast2-core yast2-country yast2-country-data yast2-hardware-detection yast2-kerberos-client yast2-ldap yast2-ldap-client 
      yast2-network yast2-packager yast2-pam yast2-perl-bindings yast2-pkg-bindings yast2-ruby-bindings yast2-samba-client yast2-samba-server yast2-security yast2-storage yast2-transfer yast2-trans-stats yast2-users 
      yast2-xml yast2-ycp-ui-bindings
    My question is: why on Earth do I have to install yast and PackageKit to have samba??
    I do all the configuration on the command line, why should I install 192.0 MiB of stuff just for Samba ???

    Thank you, please give me a reason .

  2. #2

    Default Re: Samba dependencies

    Quote Originally Posted by angelo-opensuse View Post
    My question is: why on Earth do I have to install yast and PackageKit to have samba??
    I do all the configuration on the command line, why should I install 192.0 MiB of stuff just for Samba ???

    Thank you, please give me a reason .
    I suppose most of those are no strict requirement, but just recommended packages.

    Try to use the "--no-recommends" switch when calling zypper.
    See also "zypper help in".

    Also have a look at the following option in /etc/zypp/zypp.conf:
    Code:
    ##
    ## Whether required packages are installed ONLY
    ## So recommended packages, language packages and packages which depend
    ## on hardware (modalias) will not be regarded.
    ##
    ## Valid values: boolean
    ## Default value: false
    ##
    # solver.onlyRequires = false
    You might want to set this to "true".
    Last edited by wolfi323; 22-Apr-2014 at 01:03.

  3. #3

    Default Re: Samba dependencies

    Quote Originally Posted by wolfi323 View Post
    Try to use the "--no-recommends" switch when calling zypper.
    Thanks a lot wolfi, it worked and now it wants to install about 18 Mb, that is reasonable.

    I learnt something new (actually plenty of things looking inside /etc/zypp/zypp.conf)!!

    Thanks again,

    Angelo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •