Results 1 to 10 of 10

Thread: Audio issue after updating Opensuse from 12.3 to 13.1

  1. #1

    Default Audio issue after updating Opensuse from 12.3 to 13.1

    Hello

    It seems that updating my Opensuse doesn't bring me any luck!

    I have updated my Opensuse, passing from 12.3 to 13.1. The process went smoothly and no error message was seen during the process. But when I rebooted I noticed that something wasn't right. The first unusual thing was the booting menu:

    Code:
    # Modified by YaST2. Last modification on Sun Apr 20 21:10:17 BST 2014
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader
    
    default 0
    timeout 8
    gfxmenu (hd1,1)/boot/message
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE - 3.11.10-7
        root (hd1,1)
        kernel /boot/vmlinuz-3.11.10-7-desktop root=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part2 resume=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part1 splash=silent quiet showopts vga=0x31A
        initrd /boot/initrd-3.11.10-7-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE - 3.11.10-7
        root (hd1,1)
        kernel /boot/vmlinuz-3.11.10-7-desktop root=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31A
        initrd /boot/initrd-3.11.10-7-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title GNU GRUB 2 -- openSUSE 12.3 - GNU GRUB 2
        kernel (hd1,1)/boot/grub2/i386-pc/core.img root=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part2 devfs=mount,dall resume=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part1 splash=silent quiet showopts nomodeset vga=0x31A
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 12.3 - 3.7.10-1.28
        root (hd1,1)
        kernel /boot/vmlinuz-3.7.10-1.28-desktop root=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part2 resume=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part1 splash=silent quiet showopts vga=0x31A
        initrd /boot/initrd-3.7.10-1.28-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 12.3 - 3.7.10-1.28
        root (hd1,1)
        kernel /boot/vmlinuz-3.7.10-1.28-desktop root=/dev/disk/by-id/ata-Hitachi_HTS543216L9A300_081002FB0240LCDSRK6B-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31A
        initrd /boot/initrd-3.7.10-1.28-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: windows 1###
    title windows 1
        rootnoverify (hd0,1)
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier: Original name: windows 2###
    title windows 2
        rootnoverify (hd0,2)
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
        rootnoverify (fd0)
        chainloader +1
    It never happened to me, because once the system updated everything related with the 12.3 version should be overwritten. On top of that I lost the audio. I checked different times and volume, PCM settings are the same as before. So in a terminal I computed the following command:

    amixer > amixer-output.txt

    And this is what I got :

    Code:
    Simple mixer control 'Master',0
      Capabilities: pvolume pvolume-joined pswitch pswitch-joined
      Playback channels: Mono
      Limits: Playback 0 - 127
      Mono: Playback 54 [43%] [-54.75dB] [on]
    Simple mixer control 'Headphone',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 127
      Mono:
      Front Left: Playback 64 [50%] [-47.25dB] [on]
      Front Right: Playback 64 [50%] [-47.25dB] [on]
    Simple mixer control 'Headphone',1
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 127
      Mono:
      Front Left: Playback 64 [50%] [-47.25dB] [off]
      Front Right: Playback 64 [50%] [-47.25dB] [off]
    Simple mixer control 'Speaker',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 127
      Mono:
      Front Left: Playback 64 [50%] [-47.25dB] [on]
      Front Right: Playback 64 [50%] [-47.25dB] [on]
    Simple mixer control 'PCM',0
      Capabilities: pvolume
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 255
      Mono:
      Front Left: Playback 255 [100%] [0.00dB]
      Front Right: Playback 255 [100%] [0.00dB]
    Simple mixer control 'Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [on]
      Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    Simple mixer control 'Beep',0
      Capabilities: pvolume pvolume-joined pswitch pswitch-joined
      Playback channels: Mono
      Limits: Playback 0 - 3
      Mono: Playback 1 [33%] [-12.00dB] [on]
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 15
      Front Left: Capture 0 [0%] [0.00dB] [on]
      Front Right: Capture 0 [0%] [0.00dB] [on]
    Simple mixer control 'Capture',1
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 15
      Front Left: Capture 0 [0%] [0.00dB] [off]
      Front Right: Capture 0 [0%] [0.00dB] [off]
    Simple mixer control 'Auto-Mute Mode',0
      Capabilities: enum
      Items: 'Disabled' 'Enabled'
      Item0: 'Disabled'
    Simple mixer control 'Digital',0
      Capabilities: cvolume
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 120
      Front Left: Capture 0 [0%] [-30.00dB]
      Front Right: Capture 0 [0%] [-30.00dB]
    Simple mixer control 'Input Source',0
      Capabilities: cenum
      Items: 'Mic' 'Internal Mic' 'Internal Mic 1'
      Item0: 'Mic'
    Simple mixer control 'Input Source',1
      Capabilities: cenum
      Items: 'Mic' 'Internal Mic' 'Internal Mic 1'
      Item0: 'Mic'
    Simple mixer control 'Internal Mic',1
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [on]
      Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'Internal Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    Simple mixer control 'Internal Mic Boost',1
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    Simple mixer control 'Loopback Mixing',0
      Capabilities: enum
      Items: 'Disabled' 'Enabled'
      Item0: 'Disabled'
    And as far as I see it sound good to me. Any idea ?


    Regards

    Fabrizio

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    On 2014-04-20 22:36, FabrizioS wrote:
    >
    > Hello
    >
    > It seems that updating my Opensuse doesn't bring me any luck!
    >
    > I have updated my Opensuse, passing from 12.3 to 13.1.


    How exactly?

    > The process went
    > smoothly and no error message was seen during the process. But when I
    > rebooted I noticed that something wasn't right. The first unusual thing
    > was the booting menu:


    ....


    > It never happened to me, because once the system updated everything
    > related with the 12.3 version should be overwritten.


    Not necessarily.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    Quote Originally Posted by FabrizioS View Post
    On top of that I lost the audio. I checked different times and volume, PCM settings are the same as before. So in a terminal I computed the following command:

    amixer > amixer-output.txt

    And this is what I got :
    ....
    And as far as I see it sound good to me. Any idea ?
    Some of the audio levels are low, at 47% and 50%. Did you try moving those up ? Note also in the KDE desktop for 13.1, that there is NO startup desktop audio by default. But there should be audio in applications.

    Do you get sound with the YaST audio test ?

    You could also start your file manager, flag it to show hidden files, then go to /home/user/FabrizioS/ and rename .pulse directory to .pulse-old. Then completely restart your PC and test your audio again.

    Good luck and thank you for participating in our forum.

  4. #4

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    Hello

    Thanks for the prompt reply

    I will answer to the first question: how I updated from version 12.3 to 13.1

    1) First I verified that the 12.3 was perfectly updated

    2) I replaced the old repositories with the new one and I got:

    Code:
    # | Alias                               | Name                                | Enabled | Refresh
    --+-------------------------------------+-------------------------------------+---------+--------
    1 | Opensuse-11.3-Non-Oss_1             | Opensuse-13.1-Non-Oss               | Yes     | Yes    
    2 | Packman                             | Packman                             | Yes     | Yes    
    3 | Updates_for_openSUSE_11.3_11.3-1.82 | Updates for openSUSE 13.1 11.4-1.82 | Yes     | Yes    
    4 | libdvdcss                           | libdvdcss                           | Yes     | Yes    
    5 | openSUSE-11.3-Oss                   | openSUSE-13.1-Oss                   | Yes     | Yes    
    6 | repo-update-non-oss                 | openSUSE-13.1-Update-Non-Oss        | Yes     | Yes
    I have lowered the priority of the Packman repository to the bottom.

    3) In a terminal console I ran the command : zypper ref, and everything was fine

    4) I ran the command zypper dup, I accepted the license and the update begun smoothly and clean

    5) I computed at the end the command shutdown -r now, so the system restarted but with no sound.

    Now for the other question things are a bit more complicated

    Do you get sound with the YaST audio test ?

    You could also start your file manager, flag it to show hidden files, then go to /home/user/FabrizioS/ and rename .pulse directory to .pulse-old. Then completely restart your PC and test your audio again.
    Well frankly, even if I setup the File Manager so as to visualize the hidden files, no .pulse directory seems to exist.

    Furthermore I was tinkering with the volume command and I discovered that there are three different volume setting: the Kmix volume, the Kmix PCM, and the volume command in Yast. Selecting the last one to the maximum I was able to hear some test music and Yast test sounds. But when I rebooted it seems that the previous settings were lost and I could not hear anything again.

    On top of that, when I plug a headphone I should not hear anything from my laptop speaker, but I am able to hear both (but I do not know if it is a Suse issue, even though before it was not happening).

    Please tell me if you need further info

    Regards

    Fabrizio

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    Quote Originally Posted by FabrizioS View Post
    Furthermore I was tinkering with the volume command and I discovered that there are three different volume setting: the Kmix volume, the Kmix PCM, and the volume command in Yast. Selecting the last one to the maximum I was able to hear some test music and Yast test sounds. But when I rebooted it seems that the previous settings were lost and I could not hear anything again.
    ok ... and when you move the volume settings to max ? Do you then hear sound again ?

    Given you can hear sound with YaST (which means root permissions are in use) have you tried adding your regular user to group audio via YaST, and then rebooting and checking your audio ? Post here asking for instructions of you do not know how to do that.

    Quote Originally Posted by FabrizioS View Post
    On top of that, when I plug a headphone I should not hear anything from my laptop speaker, but I am able to hear both (but I do not know if it is a Suse issue, even though before it was not happening).
    What type of headphone did you plug in ? A usb ? or a regular headphone ?

    According to your mixer settings you provided earlier, your headphone is switched OFF (muted):
    Code:
    Simple mixer control 'Headphone',1
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 127
      Mono:
      Front Left: Playback 64 [50%] [-47.25dB] [off]
      Front Right: Playback 64 [50%] [-47.25dB] [off]
    Hence that is puzzling. Have you tried unmuting that headphone setting ?

    Also, you could install pavucontrol and try to use that to tune your pulse audio settings in case the issue lies there. There is guidance here in these two blog entries on how to use pulse audio:


    Good luck and thank you for participating in our forum.

  6. #6

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    Hello

    I think I need to explain in more detail that hardware I have:

    I am using an old Dell Studio Laptop and from the KInfocentre I can see that there are two audio device installed:

    1) Advanced Micro Devices [AMD/ATI] RV 635 HDMI Audio [Radeon Series 3600]

    2) Intel Corporation 82801H HD Audio Controller

    It seems that after installing pavucontrol and enable pulseaudio (as https://forums.opensuse.org/entry.ph...-Configuration advised). I am only enable to use the first one, but this is not an issue because I able to hear music, audio test both from the speaker and from the two headphone output ( a normal 3.5mm jacks).

    The nuisance is that when I am plugging the headphone I am not supposed to hear the speaker ( that should be muted) but I can hear both. And this is an issue I want to listen music without bothering my flatmates.

    Now this is the real problem, and before it was not happening (I have Opensuse in dual boot with Vista and this problem is not happening under Windows)

    Now the settings are being kept from one session and the other.

    Please tell me if you need me to run further test.

    Regards

    Fabrizio

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    Quote Originally Posted by FabrizioS View Post
    The nuisance is that when I am plugging the headphone I am not supposed to hear the speaker ( that should be muted) but I can hear both. And this is an issue I want to listen music without bothering my flatmates.
    One thing you could try is create a new desktop user, and see if the new user has the same problem. My comment below is based on the assumption that a new user would have the same problem.

    Given this recent information, I see only two approaches :

    • see if you can use the mixer to manually mute the speakers while using the headphones, or
    • if you prefer speakers to be automatically muted when headphones plugged in (which is my preference) then write a bug report on openSUSE-13.1 and obtain support from the openSUSE sound packager, who is also an alsa sound driver developer. There is guidance here for such bug reports: http://en.opensuse.org/openSUSE:Submitting_bug_reports . You can use your openSUSE forum username and password when logging on to bugzilla.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    On 2014-04-21 23:26, FabrizioS wrote:
    >
    > Hello
    >
    > Thanks for the prompt reply
    >
    > I will answer to the first question: how I updated from version 12.3 to
    > 13.1
    >
    > 1) First I verified that the 12.3 was perfectly updated
    >
    > 2) I replaced the old repositories with the new one and I got:


    Thanks, but it is preferable to produce the list with "zypper lr
    --details", so that we can check the actual URLs.


    You see, the alias below says "11.3", whereas the name say "13.1", so
    there is reason to suspect.

    >
    >
    > Code:
    > --------------------
    > # | Alias | Name | Enabled | Refresh
    > --+-------------------------------------+-------------------------------------+---------+--------
    > 1 | Opensuse-11.3-Non-Oss_1 | Opensuse-13.1-Non-Oss | Yes | Yes
    > 2 | Packman | Packman | Yes | Yes
    > 3 | Updates_for_openSUSE_11.3_11.3-1.82 | Updates for openSUSE 13.1 11.4-1.82 | Yes | Yes
    > 4 | libdvdcss | libdvdcss | Yes | Yes
    > 5 | openSUSE-11.3-Oss | openSUSE-13.1-Oss | Yes | Yes
    > 6 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes
    >
    > --------------------
    >
    >
    > I have lowered the priority of the Packman repository to the bottom.
    >
    > 3) In a terminal console I ran the command : zypper ref, and everything
    > was fine
    >
    > 4) I ran the command zypper dup, I accepted the license and the update
    > begun smoothly and clean
    >
    > 5) I computed at the end the command shutdown -r now, so the system
    > restarted but with no sound.


    Well... the procedure seems correct.
    In the case of using the DVD upgrade method, there would have been extra
    things to do, and that's what I was aiming at. Not your case.

    Although...

    I would probably have left packman out initially, and afterwards enable
    it and to the "traditional" package switch to it.

    >
    > Now for the other question things are a bit more complicated
    >
    >> Do you get sound with the YaST audio test ?
    >>
    >> You could also start your file manager, flag it to show hidden files,
    >> then go to /home/user/FabrizioS/ and rename .pulse directory to
    >> .pulse-old. Then completely restart your PC and test your audio again.
    >>
    >>

    >
    > Well frankly, even if I setup the File Manager so as to visualize the
    > hidden files, no .pulse directory seems to exist.



    Create a new user in YaST, login as that user, delete and set sound with
    YaST again.

    Some machines seem to work best with pulse, some without. You could try
    both settings.

    >
    > Furthermore I was tinkering with the volume command and I discovered
    > that there are three different volume setting: the Kmix volume, the Kmix
    > PCM, and the volume command in Yast. Selecting the last one to the
    > maximum I was able to hear some test music and Yast test sounds. But
    > when I rebooted it seems that the previous settings were lost and I
    > could not hear anything again.


    pavucontrol is the one to use if you are using pulse.

    Yesterday I noticed a machine without sound. Yast produced sound. Pulse
    was enabled - but the pulse user directory was owned by root. I chowned
    it, loged out, killed all pulse tasks from any user, and that user
    tasks, loged in again, had sound.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  9. #9

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    Hello guys !!!!!!!!!

    Things here are really confusing !!!!!!

    As you can see from my booting menu I can boot my laptop using kernel version 3.7.10-1.28 (even if there is written opensuse 12.3 is 13.1 version, I verified) and version 3.11.10-7.

    I tried the first one, and with my incredible surprise I saw Opensuse 13.1 booting up !!!!! ( I think that on top of the audio problems, the updating process didn't go so smoothly). So I tried to tinker the audio setting and I discovered that some settings were disappeared (for example it was not possible to set any microphone). Furthermore if I tried to select the Built-in Audio Analog Stereo and after the RV 635 HDMI Audio [Radeon Series 3600], I could not even go back because in KMix there was not any setting to select (PCM, Volume and so on disappeared)

    So I gave up and rebooted using the 3.11.10-7 version, where with my surprise everything is working as it should be. If I plug my headphones now I can mute the built in speaker with no problem. Using pavucontrol I excluded the other ATI audio card because it was not working (no sound is heard using audio test and other music files)

    So it seems that the issue has been solved now. The only thing I do not like is having two different kernel versions and a messy booting menu. In the case I need to update again my Opensuse I do not want to get even more trouble, so I think is better to get rid of the old one.

    Could the command : rpm -e kernel-desktop-3.7.10-1.28 solve the issue ?

    I report below my present repositories situation:


    Code:
    # | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                         | Service
    --+-------------------------------------+-------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------+--------
    1 | Opensuse-11.3-Non-Oss_1             | Opensuse-13.1-Non-Oss               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss |        
    2 | Packman                             | Packman                             | Yes     | Yes     |  100     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/13.1         |        
    3 | Updates_for_openSUSE_11.3_11.3-1.82 | Updates for openSUSE 13.1 11.4-1.82 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                   |        
    4 | libdvdcss                           | libdvdcss                           | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                        |        
    5 | openSUSE-11.3-Oss                   | openSUSE-13.1-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/    |        
    6 | repo-update-non-oss                 | openSUSE-13.1-Update-Non-Oss        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/           |
    Last questions is the audio settings completely changed with 13.1 release ? Frankly I preferred before. It was cleaner and simple.

    Regards

    Fabrizio

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Audio issue after updating Opensuse from 12.3 to 13.1

    I'd remove it in Yast or you could use zypper

    Note there was a problem when people did an online upgrade that the grub menu was not updated correctly. A patch corrected the basic problem but I believe you still needed to edit the line in Yast. so try uname -a to be sure you which kernel is actually running. ie don't totally rely on grub to show the right kernel when doing a online update to 13.1

    Also it is now default to hold the last kernel for times when a kernel update may break something so you can always drop back

    So now when a kernel update happens the new kernel is installed (giving 3) and the oldest is only removed after a successful boot to the newest.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •