Hi again,

This time I'm having another problem. optirun works almost twice as fast when -b primus parameter is not supplied. But for some reason I can't run dota without that option(it starts and ends immediately).

Code:
➜  ~  optirun -b primus glxspheres32
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 620M/PCIe/SSE2
62.277263 frames/sec - 69.501425 Mpixels/sec
59.990912 frames/sec - 66.949857 Mpixels/sec
59.988017 frames/sec - 66.946627 Mpixels/sec
^C[ 4699.311769] [WARN]Received Interrupt signal.
➜  ~  optirun glxspheres32 
Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 620M/PCIe/SSE2
123.819703 frames/sec - 138.182788 Mpixels/sec
126.920213 frames/sec - 141.642958 Mpixels/sec
125.096932 frames/sec - 139.608176 Mpixels/sec
^C[ 4711.415627] [WARN]Received Interrupt signal.
Any ideas why can't I run dota 2 without -b primus parameter?