I tried searching for this but didn't find an answer. When there are two or more sessions running on my computer kwin uses 100% of one core on the CPU. I tried searching google for an answer but nothing seemed to be applicable or didn't work (namely turning off a few different desktop effects).

asks: 248 total, 2 running, 246 sleeping, 0 stopped, 0 zombie
%Cpu(s): 23.0 us, 12.0 sy, 0.0 ni, 64.9 id, 0.1 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem: 8189596 total, 7826348 used, 363248 free, 20 buffers
KiB Swap: 6289404 total, 43820 used, 6245584 free, 3489700 cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
27495 ehl-dot 20 0 3060508 115728 64040 R 100.0 1.413 74:15.56 kwin
27688 ehl-dot 20 0 1644128 244284 34744 S 12.62 2.983 540:55.54 plugin-co+
27580 ehl-dot 20 0 2760160 992.4m 56748 S 5.648 12.41 1664:29 firefox
1313 seth 20 0 1975216 570268 54720 S 5.316 6.963 1130:10 firefox
1044 root 20 0 201524 101508 41132 S 4.984 1.239 60:21.55 Xorg
3907 seth 20 0 575992 42052 21080 S 2.658 0.513 0:00.36 konsole
1243 seth 20 0 3324680 181164 42276 S 1.993 2.212 149:05.25 plasma-de+
1236 seth 20 0 3055164 132728 71184 S 1.329 1.621 6825:58 kwin
1463 seth 20 0 582140 97052 27672 S 1.329 1.185 0:42.48 plugin-co+
3930 seth 20 0 15360 1656 1076 R 0.332 0.020 0:00.02 top
27294 root 20 0 479140 359508 36908 S 0.332 4.390 76:34.89 Xorg
27731 root 20 0 0 0 0 S 0.332 0.000 0:30.19 kworker/1+
1 root 20 0 47720 3452 1912 S 0.000 0.042 0:04.80 systemd
2 root 20 0 0 0 0 S 0.000 0.000 0:00.60 kthreadd
3 root 20 0 0 0 0 S 0.000 0.000 0:03.39 ksoftirqd+
5 root 0 -20 0 0 0 S 0.000 0.000 0:00.00 kworker/0+
7 root rt 0 0 0 0 S 0.000 0.000 0:02.31 migration+
8 root -2 0 0 0 0 S 0.000 0.000 0:00.00 rcuc/0
9 root -2 0 0 0 0 S 0.000 0.000 0:00.00 rcub/0
10 root 20 0 0 0 0 S 0.000 0.000 4:34.19 rcu_preem+
11 root 20 0 0 0 0 S 0.000 0.000 0:54.77 rcuop/0
12 root 20 0 0 0 0 S 0.000 0.000 0:41.30 rcuop/1
13 root 20 0 0 0 0 S 0.000 0.000 0:47.22 rcuop/2
14 root 20 0 0 0 0 S 0.000 0.000 1:04.36 rcuop/3
15 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcuop/4
16 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcuop/5
17 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcu_bh
18 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcuob/0
19 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcuob/1
20 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcuob/2
21 root 20 0 0 0 0 S 0.000 0.000 0:00.00 rcuob/3

I am running openSUSE 13.1, kernel version 3.11.10-7-desktop, and using the official Nvidia driver version 331.49, and KDE 4.11.5