Results 1 to 5 of 5

Thread: Grub2 default boot

  1. #1

    Default Grub2 default boot

    SuSe 13.1
    I (rather my wife) would like grub to boot to my win7 partition by default after the 8 second countdown.

    My fdisk -l

    Disk /dev/sda: 500.1 GB, 500107862016 bytes, 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0x07f2837e

    Device Boot Start End Blocks Id System
    /dev/sda1 63 208844 104391 de Dell Utility
    /dev/sda2 212992 41172991 20480000 7 HPFS/NTFS/exFAT
    /dev/sda3 41172992 731011119 344919064 7 HPFS/NTFS/exFAT
    /dev/sda4 * 731015166 976771071 122877953 f W95 Ext'd (LBA)
    /dev/sda5 731015168 812931071 40957952 7 HPFS/NTFS/exFAT
    /dev/sda6 812933120 817145855 2106368 82 Linux swap / Solaris
    /dev/sda7 817147904 881358847 32105472 83 Linux
    /dev/sda8 881360896 976752639 47695872 83 Linux

    Also, when I boot SuSe 13.1, I'd prefer to see all that text scrolling by than a background JPEG.

    Thankin' You!

    Bill

  2. #2

    Default Re: Grub2 default boot

    OK' Bootloader in YAST fixed my default OS.

    I'd still like to see text flying by instead of the default SuSe JPEG.

    Last time I messed with those bits, well, it wasn't good.

    Thanks!
    Bill

  3. #3

    Default Re: Grub2 default boot

    You can press the escape key at boot time or shutdown. Now if you want to make it default you can adjust it using yast2 bootloader as well. You can call that module using your terminal.
    Code:
    yast2 bootloader
    Click this button.
    Code:
    BootLoaderOptions
    Edit the entry under this line.
    Code:
    Optional Kernel Command Line Parameter
    Then change from
    Code:
    splash=silent
    into this
    Code:
    splash=verbose
    Click the ok button and you should be good.
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Grub2 default boot

    Quote Originally Posted by washley View Post
    Also, when I boot SuSe 13.1, I'd prefer to see all that text scrolling by than a background JPEG.
    Uninstall "plymouth". And then, run
    Code:
    # mkinitrd
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: Grub2 default boot

    Quote Originally Posted by nrickert View Post
    Uninstall "plymouth". And then, run
    Code:
    # mkinitrd
    That is also an option and this is another.

    Replace silent with versbose in /etc/default/grub
    Code:
    ex -sc '%s/silent/verbose/ge|x' /etc/default/grub
    Make the change.
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •