Results 1 to 5 of 5

Thread: MyPaint doesn´t open

  1. #1

    Question MyPaint doesn´t open

    Hi I installed mypaint on OpenSuse 13,1 64bit with KDE. The installation(1 Click install) seemed to be successfull and the graphic repository was added to the list. But mypaint doesn´t start, what could be the problem??

  2. #2

    Default Re: MyPaint doesn´t open

    Quote Originally Posted by chapati View Post
    Hi I installed mypaint on OpenSuse 13,1 64bit with KDE. The installation(1 Click install) seemed to be successfull and the graphic repository was added to the list. But mypaint doesn´t start, what could be the problem??
    Please run it in a terminal window (konsole f.e.) and post the output.

  3. #3

    Default Re: MyPaint doesn´t open

    Code:
    RuntimeError: module compiled against API version 9 but this version of numpy is 7
    
    We are not correctly installed or compiled!
    script: "/usr/bin/mypaint"
    deduced prefix: "/usr"
    lib_shared: "/usr/share/mypaint/"
    lib_compiled: "/usr/lib64/mypaint/"
    
    Traceback (most recent call last):
      File "/usr/bin/mypaint", line 170, in <module>
        datapath, extradata, confpath, localepath, localepath_brushlib = get_paths()
      File "/usr/bin/mypaint", line 111, in get_paths
        from lib import mypaintlib
      File "/usr/share/mypaint/lib/mypaintlib.py", line 26, in <module>
        _mypaintlib = swig_import_helper()
      File "/usr/share/mypaint/lib/mypaintlib.py", line 18, in swig_import_helper
        import _mypaintlib
    ImportError: numpy.core.multiarray failed to import
    THANKS

  4. #4

    Default Re: MyPaint doesn´t open

    Quote Originally Posted by chapati View Post
    Code:
    RuntimeError: module compiled against API version 9 but this version of numpy is 7
    You have the wrong version of python-numpy installed.
    openSUSE 13.1 comes with 1.7.1, but that MyPaint you installed is apparently built against 1.8.1, which is available in the same repo as MyPaint (graphics).
    So search for python-numpy in YaST and update it to the version 1.8.1 from the graphics repo (click on "Versions" below the package list to do that), then MyPaint should work.

  5. #5

    Default Re: MyPaint doesn´t open

    Now it works! Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •