Results 1 to 6 of 6

Thread: openSUSE + Virtualbox + Chrome Weird Display Problem

  1. #1

    Default openSUSE + Virtualbox + Chrome Weird Display Problem

    I'm not sure if the cause is openSUSE, Chromium, or Virtualbox. I am running openSUSE 13.1 as a Virtualbox guest in Mac OS. I have installed Chromium.

    The problem with Chromium is that the web page area within the application window always takes focus, even when Chromium is not the application with focus. Anything that is on top of the Chromium window is hidden under the web page area. The same goes for drop down menus within Chromium. I click the 3 bar button at the right side, and it is hidden behind the web page area.

    Any ideas how to fix this?

    Here's two links to screenshots:

    https://drive.google.com/file/d/0B8-...it?usp=sharing
    https://drive.google.com/file/d/0B8-...it?usp=sharing

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,461
    Blog Entries
    2

    Default Re: openSUSE + Virtualbox + Chrome Weird Display Problem

    Not seeing it on my machines.

    Have you updated your system?
    Run the following to make sure your system has all updates installed
    Code:
    zypper update
    Do this in your Guest, and if you are running Virtualbox on your Host, on your Host as well.

    Then reboot both your Host and your Guest.

    TSU

  3. #3

    Default Re: openSUSE + Virtualbox + Chrome Weird Display Problem

    Thanks for the reply, but yeah, updates are the first thing I do on a fresh install. I have re-installed my openSUSE guest 3 times and every time Chrome has the same issue.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: openSUSE + Virtualbox + Chrome Weird Display Problem

    Maybe a setting to not use the video hardware direct might help

    Could be also and artifact of the VM running in a Mac???

  5. #5

    Default Re: openSUSE + Virtualbox + Chrome Weird Display Problem

    I disabled 3d acceleration and that fixed it! Someone should probably fix that, but who? Chromium, openSUSE, or Virtualbox?

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: openSUSE + Virtualbox + Chrome Weird Display Problem

    As I recall the is a setting in chrome to not use direct hardware rendering. You may need to set that. Though when you have a complex software stack the problem could be anywhere

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •