Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: k3b won't copy or rip cds

  1. #1
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default k3b won't copy or rip cds

    Hi, I'm using opensuse 13.1 and I was trying to copy a CD with k3b. But when the copying started, I got the error that k3b "cannot load libcdparanoia", and nothing was copied. I checked with software management in the control center, and it does not find "libcdparanoia".

    If I try to rip a CD, k3b shows all the tracks with their song titles and authors, but when I click on "start ripping", I get a message there may be a bug, and k3b closes.

    I've also tried audex, but it doesn't even seem to recognize the CD, whereas at least k3b recognized the CD with its tracks and titles.

  2. #2

    Default Re: k3b won't copy or rip cds

    Quote Originally Posted by MoeNeigh View Post
    Hi, I'm using opensuse 13.1 and I was trying to copy a CD with k3b. But when the copying started, I got the error that k3b "cannot load libcdparanoia", and nothing was copied. I checked with software management in the control center, and it does not find "libcdparanoia".
    There is no libcdparanoia on 13.1. You probably have some left-over packages from an earlier openSUSE version installed or something like that.

    Which packages do you actually have?
    Code:
    rpm -qi k3b k3b-codecs cdparanoia cdrdao cdrecord wodim
    (I'm not 100% sure what k3b uses to copy a CD)

    And please post your repo list:
    Code:
    zypper lr -d

  3. #3
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Re: k3b won't copy or rip cds

    Quote Originally Posted by wolfi323 View Post
    There is no libcdparanoia on 13.1. You probably have some left-over packages from an earlier openSUSE version installed or something like that.

    Which packages do you actually have?
    Code:
    rpm -qi k3b k3b-codecs cdparanoia cdrdao cdrecord wodim
    (I'm not 100% sure what k3b uses to copy a CD)

    And please post your repo list:
    Code:
    zypper lr -d
    HI wolfi, I have everything in the applications list you mentioned except cdrecord. I searched for it also in Yast, Yast says "no results".
    Cdparanoia is there, for sure. I was able to open it in a terminal, but I don't know how to use it yet from the command line.

    Here is my repo list:

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

    ---+---------------------------+------------------------------------------------------------------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------+--------

    1 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |

    2 | home_rbos_pipelight | Windows NPAPI Wrapper Plugin, giving access to Silverlight among other plugins (openSUSE_13.1) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |

    3 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1 |

    4 | nvidia | nvidia | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |

    5 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1 |

    6 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |

    7 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    8 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    9 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    10 | repo-oss | openSUSE-13.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    11 | repo-source | openSUSE-13.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    12 | repo-update | openSUSE-13.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    13 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/ |


    Thanks for any help in figuring out this mystery.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,463
    Blog Entries
    2

    Default Re: k3b won't copy or rip cds

    If you have a package "libcdparanoia" you can avoid guessing (hopefully) about its origins by posting the "zypper info" about the package, eg
    Code:
    zypper info libcdparanoia
    If that doesn't describe a package's origins but you firmly believed you installed libcdparanoia as part of a package and not compiled from source, you might return something useful with
    Code:
    zypper se --provides libcdparanoia
    HTH,
    TSU

  5. #5
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Re: k3b won't copy or rip cds

    Well, I found an answer to the copy problem -- at least a workaround. A German-speaking user (also using 13.1) was having the same problem I was having, that "libcdparanoia would not load", according to the message in k3b. The workaround answer was to change Copy Mode from "Normal" to "Clone". It takes a little longer than normal copying, I think, but it works. My German is not that good, so I pasted the link into Google Chrome and asked for a translation.

    Here is the link from the opensuse forum in German:

    http://www.opensuse-forum.de/gel%C3%...f17/t9686-f44/

    Apparently, I'm not the only one having this problem.

    Hopefully, we can solve the ripping problem soon. That one doesn't give a real error message, just an option to file a bug report.

  6. #6

    Default Re: k3b won't copy or rip cds

    Quote Originally Posted by MoeNeigh View Post
    HI wolfi, I have everything in the applications list you mentioned except cdrecord. I searched for it also in Yast, Yast says "no results".
    You don't need cdrecord, if you have wodim.
    wodim is a replacement for cdrecord, and is included in openSUSE instead of cdrecord for quite some time.

    But that line was intended to find out whether you have some packages from previous openSUSE versions installed (maybe even cdrecord).
    So please post the output.

    Regarding the ripping, there is a bug in k3b 2.0.80 that causes it to crash.
    Packman did contain that buggy version, but it was downgraded again to 2.0.2 in December because of that crash.
    Maybe you still have 2.0.80 installed? That rpm line should show this.
    If yes, right-click on the package in YaST and choose "Upgrade Unconditionally" to downgrade it to the 2.0.2 version in the Packman repo.
    Yast, zypper up or patch, and PackageKit (your update applet) do NOT downgrade packages automatically.

    Here is my repo list:
    That looks ok.

    Another question: When did you get that message about "libcdparanoia not found"? Immediately when starting the copy?
    And what are your exact settings in the burn/copy dialog?
    I tried a (normal) copy now and it seems to work fine here (with k3b 2.0.2 that is). But I aborted during the copy so I don't really know whether it would have finished successfully.

  7. #7

    Default Re: k3b won't copy or rip cds

    PS: In the meantime I successfully copied an AudioCD twice (once with creating image files, once without, i.e. a direct copy).
    No problems whatsoever with the normal copy mode (not clone).

    I suppose you are trying to copy an AudioCD, right? Otherwise cdparanoia shouldn't be used anyway.

  8. #8
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Re: k3b won't copy or rip cds

    Quote Originally Posted by wolfi323 View Post
    Regarding the ripping, there is a bug in k3b 2.0.80 that causes it to crash.
    Packman did contain that buggy version, but it was downgraded again to 2.0.2 in December because of that crash.
    Maybe you still have 2.0.80 installed? That rpm line should show this.
    If yes, right-click on the package in YaST and choose "Upgrade Unconditionally" to downgrade it to the 2.0.2 version in the Packman repo.
    Yast, zypper up or patch, and PackageKit (your update applet) do NOT downgrade packages automatically.
    That worked beautifully for copying an Audio CD. I noticed that in YaST, k3b 2.0.80 was the installed version, and 2.0.2 was marked as "devel". Seems it should have been the other way around. Anyway, I followed your instructions, I used normal copy, and the tracks and song titles both appeared. Thank you.

    I'm wondering whether Apper will keep trying to reinstall k3b 2.0.80 though?

    Quote Originally Posted by wolfi323 View Post
    Another question: When did you get that message about "libcdparanoia not found"? Immediately when starting the copy?
    And what are your exact settings in the burn/copy dialog?
    I tried a (normal) copy now and it seems to work fine here (with k3b 2.0.2 that is). But I aborted during the copy so I don't really know whether it would have finished successfully.
    Normal copy at first, then I tried clone copy, which worked, but did not pick up the song titles. Normal copy with 2.0.80 caused k3b to crash immediately after the message "libcdparanoia not found" occurred.

  9. #9

    Default Re: k3b won't copy or rip cds

    Quote Originally Posted by MoeNeigh View Post
    That worked beautifully for copying an Audio CD. I noticed that in YaST, k3b 2.0.80 was the installed version, and 2.0.2 was marked as "devel". Seems it should have been the other way around.
    Yes. 2.0.80 is the development version.

    But where does YaST mark 2.0.2 as "devel"?
    I don't follow you there.
    [edit]
    I think I understand now what you mean.
    There is a package called "k3b-devel", yes (which would be at version 2.0.2 of course).
    But that's something completely different. That doesn't imply anything whether this k3b version is a devel version or not.
    It is only needed to write/compile plugins for k3b.
    [/edit]

    Again, 2.0.80 was available in Packman for some time, that's why you have it installed.
    Then those crashes were reported and therefore it got downgraded again to 2.0.2 in Packman.

    Now there's only 2.0.2 available in Packman, so YaST should have marked the package in red, which means that there's only a lower version available than the one you have installed (or none at all).

    But neither Apper, nor "zypper up", "zypper patch" or YaST will automatically install the lower version. You have to force that.

    I'm wondering whether Apper will keep trying to reinstall k3b 2.0.80 though?
    There is no k3b 2.0.80 available any more. As I said, it got downgraded to 2.0.2 in Packman because of the crashes.

    There still is 2.0.80 in KDE:Extra, but you don't have that repo anyway, and Apper wouldn't change your installed package to a version from another repo.

    Normal copy at first, then I tried clone copy, which worked, but did not pick up the song titles. Normal copy with 2.0.80 caused k3b to crash immediately after the message "libcdparanoia not found" occurred.
    So this apparently is another bug in 2.0.80. I was only aware of the crash when trying to rip a CD. Maybe they are related though.
    Last edited by wolfi323; 18-Apr-2014 at 06:56.

  10. #10
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Re: k3b won't copy or rip cds

    Quote Originally Posted by wolfi323 View Post
    Yes. 2.0.80 is the development version.

    But where does YaST mark 2.0.2 as "devel"?
    I don't follow you there.
    Well, 2.0.80 is now gone from YaST. Yay! Only 2.0.2 files are showing for k3b. Except the last four, which are not installed. Three are marked "...debuginfo", and one is marked "k3b-devel".

    By the way, I've now tested the ripping, and it is also perfect. Thanks so much again.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •