Results 1 to 3 of 3

Thread: Energieverwaltung Linux 3.11.10-7-desktop openSUSE 13.1

  1. #1

    Default Energieverwaltung Linux 3.11.10-7-desktop openSUSE 13.1

    Meine Hardware:

    AMD A6-5200 APU mit Radeon (TM) HD-Grafik
    AMD Radeon HD 8400 Treiber
    AMD Catalyst Paketversion 13.20.11

    Also, Ich Habe hier massiv Probleme mit der Energieverwaltung, insbesondere mit der Helligkeitsregelung. Alles was ich in der Energieverwaltung einstelle funktioniert Nicht. Weder das runterfahren beim zuklappen des Deckels, noch der Energiesparmodus im Akkubetrieb (Helligkeit wird nicht angepasst). Das ist natürlich eine enorme Belastung des Akkus, den ich dann alle 2 Stunden aufladen muss.

    Hier mal meine xorg.conf

    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection


    Section "Module"
    EndSection


    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection


    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:0:1:0"
    EndSection


    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    In Grub habe ich in Sachen Helligkeit das schon alles durchprobiert

    acpi_osi=Linux acpi_backlight=vendor
    acpi_osi=Linux acpi_backlight=legacy
    acpi_osi="!Windows 2012" acpi_backlight=vendor
    acpi_backlight=legacy
    acpi_osi=Linux

    Die Helligkeit Lässt sich nur über dem Terminal mit der Befehlszeile

    echo 60 | sudo tee / sys/class/backlight/acpi_video0/brightness

    regeln, wobei nach einem Neustart alle Einstellung wieder auf 100 gestellt werde und auch so bleiben.
    Über die Tastatur geht auch nichts geschweige denn über den Regler in der Batterie Anzeige.

    Der Befehl dmesg | grep acpi bringt folgendes

    [ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    [ 0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
    [ 0.000000] ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] enabled)
    [ 0.000000] ACPI: LAPIC (acpi_id[0x03] lapic_id[0x03] enabled)
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
    [ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x03] high edge lint[0x1])
    [ 0.222190] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
    [ 2.982617] acpi PNP0A08:00: Requesting ACPI _OSC control (0x1d)
    [ 2.983073] acpi PNP0A08:00: ACPI _OSC control (0x1d) granted
    [ 2.983630] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
    [ 3.002813] Found 1 acpi root devices
    [ 4.808483] ACPI: acpi_idle registered with cpuidle
    [ 13.112759] acpi device:01: registered as cooling_device4
    [ 13.113758] acpi device:0b: registered as cooling_device5
    [ 13.618868] acpi-cpufreq: overriding BIOS provided _PSD data



    Das heißt ACPI Läuft.

    Ich habe auch den Catalyst-14.3 Beta probiert, der die Helligkeit beim Desktop-Start auf 50 runtersetzt und ich es manuell ändern muss.

    Was kann ich tun, um dieses Problem in den Griff zu bekommen. Ich Google schon seit einer Woche ohne Erfolg.

  2. #2

    Default Re: Energieverwaltung Linux 3.11.10-7-desktop openSUSE 13.1

    Keiner irgend eine Idee ???

  3. #3
    Join Date
    Mar 2013
    Location
    Regensburg
    Posts
    20

    Default Re: Energieverwaltung Linux 3.11.10-7-desktop openSUSE 13.1

    1)
    Ich kann Dir nur bei KDE weiterhelfen:
    Prinzipiell werden dort sämtliche Energieeinstellungen in openSUSE 13.1 (auch der Bildschirm) mit PowerDevil (Systemeinstellungen -> Energieverwaltung) kontrolliert. D.h. xorg.conf zieht den kürzeren...:-)

    Bei Gnome weiß ich nicht, wie das gehandhabt wird.


    2)
    Ich hatte auch Probleme mit meinem neuen Laptop mit Kernel 3.11, z.B schaltete er sich nicht ordentlich beim Shutdown ab und Ethernet funktionierte nicht. Diese Probleme waren mit Kernel 3.13 gelöst. Der Umstieg war etwas frickelig (wegen UEFI-Bios), sollte aber prinzipiell machbar sein (es gibt dafür einen Repository-Pfad).
    Ein Tip:
    Lade Dir zum Test mal eine Live-Version von Ubuntu 14.04 mit Kernel 3.13 herunter und teste, ob es da besser funktioniert. Wenn ja, dann solltest Du evtl. auch bei openSUSE 13.1 auf einen neueren Kernel umsteigen, oder auf die 13.2 warten.

    Siegmund

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •