Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

  1. #1

    Default 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Hi all !

    This is a fresh install of openSUSE 13.1 64bit, with KDE,
    on Fujitsu-Siemens Esprimo (Pentium Dual-Core E5200,
    intel onboard graphics).

    It worked perfect.
    And I'm using this PC to write this.

    Up to this point:
    I left the PC alone for 15-20 minutes.

    Afterwards I wasn't even able to shutdown anymore.

    Not even Ctrl-Alt-F1 and saying 'shutdown -h now' did work.



    The disk light flashed every few seconds - so something still was going on.

    Rebooting, after cutting power, gave a pretty long list of fixes for the file system at boot -
    yes I removed the options splash=silent (or the like) from my /boot/grub/menu.lst
    (I'm still using legacy GRUB).

    To me it seems that power saving functions didn't work correctly.

    Thanks in advance
    Mike

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Quote Originally Posted by ratzi View Post
    This is a fresh install of openSUSE 13.1 64bit, with KDE,
    on Fujitsu-Siemens Esprimo (Pentium Dual-Core E5200,
    intel onboard graphics).
    In KDE power settings, uncheck the box "Dim Screen".

    You can leave the "Screen Energy Savings" box checked. And keep the screen brightness at the max (should be the default).

    At least, that is my experience with Intel graphics. My laptop has perhaps a 50% chance of freezing when the brightness changes. By making sure that brighness never changes, I rarely have freezes. Maybe, about 1 time in 100, it freezes during KDE startup - just after showing the first icon in the startup screen.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Quote Originally Posted by nrickert View Post
    In KDE power settings, uncheck the box "Dim Screen".

    You can leave the "Screen Energy Savings" box checked. And keep the screen brightness at the max (should be the default).

    At least, that is my experience with Intel graphics. My laptop has perhaps a 50% chance of freezing when the brightness changes. By making sure that brighness never changes, I rarely have freezes. Maybe, about 1 time in 100, it freezes during KDE startup - just after showing the first icon in the startup screen.
    In the KDE settings I found 'Hardware/Power Management' and there 'Screen Energy Saving'.

    But I didn't find the other ones.

    Best wishes
    Mike

  4. #4

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Am I looking in the wrong place?

    It is
    (1) SUSE Menu (lower left corner of the screen)
    (2) Favorites
    (3) Configure Desktop
    (4) Hardware

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Quote Originally Posted by ratzi View Post
    Am I looking in the wrong place?

    It is
    (1) SUSE Menu (lower left corner of the screen)
    (2) Favorites
    (3) Configure Desktop
    (4) Hardware
    SUSE Menu --> Configure Desktop --> Power Management

    or

    Favorites --> Configure Desktop --> Power Management

    Yes, it's the hardware section of "Configure Desktop"



    Maybe there are different options for your system. I think the options offered might depend on the hardware. I'm seeing this on both laptop and desktop with Intel graphics. But your Intel graphics is a bit different from either of mine.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  6. #6

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Perhaps I should add that I'm usually not logged in as root.
    Would that change anything?

  7. #7

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Quote Originally Posted by nrickert View Post
    SUSE Menu --> Configure Desktop --> Power Management

    or

    Favorites --> Configure Desktop --> Power Management

    Yes, it's the hardware section of "Configure Desktop"



    Maybe there are different options for your system. I think the options offered might depend on the hardware. I'm seeing this on both laptop and desktop with Intel graphics. But your Intel graphics is a bit different from either of mine.
    Thank you very much!

    Yes, on my system it looks different.

    I e.g. miss the entry for 'Dim Screen'.

    Otherwise the window looks quite the same !

    Thanks again for taking your time !
    Mike

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Quote Originally Posted by ratzi View Post
    Perhaps I should add that I'm usually not logged in as root.
    Would that change anything?
    I'm not logged in as root, either. So, no, that should not be relevant.

    Maybe your screen does not have the dim possibility.

    A possible alternative: Look in $HOME/.kde4/share/config/powermanagementprofilesrc

    with a text editor.

    I do not have a section
    Code:
    [AC][DimDisplay]
    and I think that's because I have disable display dimming. If you have that section, try removing it. Similarly for Battery, if you are using on Battery.

    If you edit that file, it's a good idea to save a copy of the original, but keep it somewhere else. That way you can restore it if you don't like the change, and you will have a memory of what was originally there.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  9. #9

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Hi again!

    Quote Originally Posted by nrickert View Post
    I'm not logged in as root, either. So, no, that should not be relevant.

    Maybe your screen does not have the dim possibility.
    OK (I have a Fujitsu-Siemens P19-2 with 1280x1024).

    Quote Originally Posted by nrickert View Post
    A possible alternative: Look in $HOME/.kde4/share/config/powermanagementprofilesrc
    Here comes the good stuff .....

    Found that!

    Quote Originally Posted by nrickert View Post
    with a text editor.

    I do not have a section
    Code:
    [AC][DimDisplay]
    I do have that section.

    In my file it is
    Code:
    [AC][DimDisplay]
    idleTime=300000
    Quote Originally Posted by nrickert View Post
    and I think that's because I have disable display dimming. If you have that section, try removing it. Similarly for Battery, if you are using on Battery.
    I'm running a desktop PC.

    Quote Originally Posted by nrickert View Post
    If you edit that file, it's a good idea to save a copy of the original, but keep it somewhere else. That way you can restore it if you don't like the change, and you will have a memory of what was originally there.
    OK, yes, I made a backup copy, good practice.

    Otherwise I completely deleted the contents of this file, because my desktop PC doesn't have a battery.

    Let's see what that does.

    Rebooting now.

    Thanks again !
    Mike

  10. #10
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: 13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

    Quote Originally Posted by ratzi View Post
    I'm running a desktop PC.
    Are you running the desktop kernel? You should be.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •