Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: HELP! new install 13.1 zypper refresh fails IPv6

  1. #1
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    223

    Exclamation HELP! new install 13.1 zypper refresh fails IPv6

    Hi,

    I have a new install of KDE 13.1 (last weekend) and then zypper was working. Now zypper isn't. It's persistently looking for the download servers using IPv6, which is failing.

    Internet browsing, wget (from command line) work OK. curl (from command line) also fails.

    I've disabled IPv6 in KDE, and set IPv6 to reject in sysconfig & rebooted. No change.

    How can I fix this?

    Thanks

    p.s. I can't download curl or whatever to revert to an earlier version in zypper :-)

  2. #2

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    Quote Originally Posted by jetojedno View Post
    It's persistently looking for the download servers using IPv6, which is failing.
    No, it isn't.
    It tries IPv4 first, but it only reports the last thing it tried when it fails.
    That's a limitation of curl I think.

    Anyway, there seems to be a general problem with download.opensuse.org at the moment, I cannot reach the repos either.

    You don't have a configuration issue.

    Try again later and just be patient until this is fixed.

  3. #3

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    PS: It is working again now for me.

  4. #4
    Join Date
    Mar 2013
    Location
    Bari (Italy)
    Posts
    58

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    Quote Originally Posted by wolfi323 View Post
    Anyway, there seems to be a general problem with download.opensuse.org at the moment, I cannot reach the repos either.
    http://lists.opensuse.org/opensuse-a.../msg00000.html

  5. #5
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    223

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    Thanks. You're right - it's back now.

    I'll log the error message as a bug. I have no IPv6 on the local network and my ISP doesn't yet support IPv6 properly, so zypper shouldn't be saying IPv6 failed when it was an IPv4 issue.

    David

  6. #6

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    Quote Originally Posted by jetojedno View Post
    I'll log the error message as a bug.
    This has been reported already:
    https://bugzilla.novell.com/show_bug.cgi?id=863047

    And I'm pretty sure this was not even the first bug report about that.

  7. #7
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    223

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    with this morning's download.opensuse outage while the servers were changed, I'm sure a lot of other people have seen this error.

    The bug was listed as priority 5 (which means it gets no attention). I've changed it to 4 (Low). The opensuse zypper maintainers may like to raise its priority further. It depends on how they feel about wasting people's time. :-)

  8. #8

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    Quote Originally Posted by jetojedno View Post
    The bug was listed as priority 5 (which means it gets no attention).
    No, that's not true.
    Priority 5 (None) means, that no specific priority has been set, not that it will be ignored.
    It's even more likely ignored with a priority of 4 (low) I suppose.

    And you as bug reporter or commenter on a bug should not change the priority, that's intended for the maintainer only.
    From Bugzilla's help:
    Priority: The bug assignee uses this field to prioritize his or her bugs. It's a good idea not to change this on other people's bugs.
    You could change the Severity instead though.
    Severity: This indicates how severe the problem is - from blocker ("application unusable") to trivial ("minor cosmetic issue"). You can also use this field to indicate whether a bug is an enhancement request.
    Last edited by wolfi323; 15-Apr-2014 at 06:07.

  9. #9
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    223

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    Quote Originally Posted by wolfi323 View Post
    No, that's not true.
    Priority 5 (None) means, that no specific priority has been set, not that it will be ignored.
    It's even more likely ignored with a priority of 4 (low) I suppose.

    And you as bug reporter or commenter on a bug should not change the priority, that's intended for the maintainer only.
    From Bugzilla's help:


    You could change the Severity instead though.
    Thanks for the correction. I'll undo my mistake and do as you suggest.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: HELP! new install 13.1 zypper refresh fails IPv6

    On 2014-04-15 13:16, ezio84 wrote:
    >
    > wolfi323;2637065 Wrote:
    >>
    >> Anyway, there seems to be a general problem with download.opensuse.org
    >> at the moment, I cannot reach the repos either.

    > http://lists.opensuse.org/opensuse-a.../msg00000.html


    I posted it here, on the opensuse-news forum.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •