Results 1 to 6 of 6

Thread: Clarifying a Stupid KDE Tumbleweed Question

  1. #1
    Join Date
    Apr 2014
    Location
    Colorado Springs, CO
    Posts
    24

    Default Clarifying a Stupid KDE Tumbleweed Question

    Hi,

    By all means, please mock me incessantly if this is a stupid question or something I should have otherwise determined on my own, but I will ask anyway.

    I have configured Tumbleweed and see some odd upgrade paths now and then. No stability issues or anything. I will use KDE4 as an example. I did a zypper ref && zypper lu and this was the output:
    Code:
    hopper:~ # zypper lu
    Loading repository data...
    Reading installed packages...
    S | Repository              | Name                                 | Current Version | Available Version | Arch  
    --+-------------------------+--------------------------------------+-----------------+-------------------+-------
    v | openSUSE Stable Updates | apache2                              | 2.4.6-6.15.1    | 2.4.6-6.19.2      | x86_64
    v | openSUSE Stable Updates | apache2-prefork                      | 2.4.6-6.15.1    | 2.4.6-6.19.2      | x86_64
    v | openSUSE Stable Updates | apache2-utils                        | 2.4.6-6.15.1    | 2.4.6-6.19.2      | x86_64
    v | openSUSE Tumbleweed     | gtk2-engine-oxygen                   | 1.4.4-6.1       | 1.4.5-7.1         | x86_64
    v | openSUSE Tumbleweed     | gtk2-theme-oxygen                    | 1.4.4-6.1       | 1.4.5-7.1         | x86_64
    v | openSUSE Tumbleweed     | kde4-kgreeter-plugins                | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | kdebase4-openSUSE                    | 13.1-2.5        | 13.1-2.6          | x86_64
    v | openSUSE Tumbleweed     | kdebase4-runtime-branding-openSUSE   | 13.1-2.5        | 13.1-2.6          | x86_64
    v | openSUSE Tumbleweed     | kdebase4-workspace                   | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | kdebase4-workspace-branding-openSUSE | 13.1-2.5        | 13.1-2.6          | x86_64
    v | openSUSE Tumbleweed     | kdebase4-workspace-ksysguardd        | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | kdebase4-workspace-liboxygenstyle    | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | kdebase4-workspace-plasma-calendar   | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | kdm                                  | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | ktorrent                             | 4.3.1-3.30      | 4.3.1-3.31        | x86_64
    v | openSUSE Tumbleweed     | kwin                                 | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    v | openSUSE Tumbleweed     | plasma-addons                        | 4.12.4-2.7      | 4.12.4-2.8        | x86_64
    v | openSUSE Tumbleweed     | plasma-addons-akonadi                | 4.12.4-2.7      | 4.12.4-2.8        | x86_64
    v | openSUSE Tumbleweed     | plasma-addons-lancelot               | 4.12.4-2.7      | 4.12.4-2.8        | x86_64
    v | openSUSE Tumbleweed     | python-kdebase4                      | 4.11.8-2.6      | 4.11.8-3.1        | x86_64
    Some of the applications show the version number I would expect to see KDE using (4.12.4) and KDE itself reflects this. What is with some of the kdebase4 apps and some others showing 4.11.8 still? Is that something I have configured incorrectly by using Tumbleweed?

    Thank you and -- again -- feel free to mock if I mucked something up or missed the obvious.

    Thanks!
    MN

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Clarifying a Stupid KDE Tumbleweed Question

    You should know there is a thread all about using TW here
    https://forums.opensuse.org/content....-to-Tumbleweed

    FYI
    Some kde 4.11 packages remain in any 4.12 upgrade

    There have been stability issues in TW with KDE. Not sure if that remains the case
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Apr 2014
    Location
    Colorado Springs, CO
    Posts
    24

    Default Re: Clarifying a Stupid KDE Tumbleweed Question

    Quote Originally Posted by caf4926 View Post
    You should know there is a thread all about using TW here
    https://forums.opensuse.org/content....-to-Tumbleweed

    FYI
    Some kde 4.11 packages remain in any 4.12 upgrade

    There have been stability issues in TW with KDE. Not sure if that remains the case
    Thanks for the info. Looking at the thread, it is good to know I have the repos configured properly and that seeing 4.11.x packages are okay. Like I said, incessant mockery is approved.

    Thanks!
    MN

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,832

    Default Re: Clarifying a Stupid KDE Tumbleweed Question

    Tumbleweed questions should go in the Tumbleweed forums, because that is where the Tumbleweed experts will look if they feel an urge to help other Tumbleweed users.

    This will be moved and is CLOSED for the moment.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,832

    Default Re: Clarifying a Stupid KDE Tumbleweed Question

    Quote Originally Posted by hcvv View Post

    This will be moved and is CLOSED for the moment.
    Moved from Applications and open again.
    Henk van Velden

  6. #6

    Default Re: Clarifying a Stupid KDE Tumbleweed Question

    Quote Originally Posted by Mountainerd View Post
    I did a zypper ref && zypper lu and this was the output:
    You should not use "zypper lu" on Tumbleweed.
    The only supported way to update is "zypper dup". Use the -D (dry-run) option if you only want to see whether updates are available, or say "n" at the prompt.

    Some of the applications show the version number I would expect to see KDE using (4.12.4) and KDE itself reflects this. What is with some of the kdebase4 apps and some others showing 4.11.8 still? Is that something I have configured incorrectly by using Tumbleweed?
    kdebase4-workspace and all its sub-packages (like kdm, and kwin, f.e.) are at version 4.11.8 at the moment. That's not Tumbleweed specific.

    A kdebase4-workspace 4.12 DOES NOT EXIST, upstream KDE decided to freeze kde-workspace at 4.11.
    See here f.e.: http://alien.slackbook.org/blog/kde-4-12-is-available/
    KDE Software Compilation 4.12.0 will be mainly about improving and polishing KDE Applications. The Plasma Workspace has been feature-frozen at the end of the 4.11 cycle. There is no new source tarball labeled “4.12″ for kde-workspace anymore, the KDE folk have stuck to the 4.11 tarball for inexplicable reasons…

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •