Results 1 to 5 of 5

Thread: Having some issues with KDE4.12.4 - sound familiar to anyone?

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Having some issues with KDE4.12.4 - sound familiar to anyone?

    I am running 13.1 with KDE 4.12.4 from the recently updated KDE repos.

    I have had a nagging desktop crash issue ( desktop reverts to Greeter-Login screen) recently, very infrequent and random as to what apps and windows I had open at the time but frequently associated with selecting the "Show Desktop" widget from the panel to get clean access to my desktop folder.

    I use the term "recently" rather loosely, as the infrequency and randomness make it unclear when this started, but I am now focused on my upgrade from 4.11.x to 4.12.y as the probable trigger.

    In addition to desktop crashes, I found some wierdness when running my CAD program QCADCAM, which is a QT application that uses the KDE file chooser interface.
    My dialog with the QCAD developer is here in the QCAD Forum.
    I found that certain file chooser operations were causing QCAD to seg fault.

    After search both openSUSE and internet forums with some of the messaging I was getting from CLI sessions, and experiments with a new test-user login (and environment), I decided to create a new ~/.kde4 profile for my normal user login.

    So far, no desktop crashes experienced.
    I also find that QCAD no longer segfaults when using the kde file chooser interface to open a file, but neither does the file open.
    I know the file.dxf is good, and can open it by specifying it on the command line.
    So an interface issue still exists between the application (built using QT 4.8.4) and the KDE 4.12.4 file chooser interface.

    Anyone else chasing weirdness in this area?
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,199
    Blog Entries
    1

    Default Re: Having some issues with KDE4.12.4 - sound familiar to anyone?

    I have KDE 4.12.4 installed with none of the issues you describe. (I don't use QCAD, so can't comment on that.) You should probably start by showing us your current configured repos:

    Code:
    zypper lr -d

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,654

    Default Re: Having some issues with KDE4.12.4 - sound familiar to anyone?

    Sounds like you had some corrupt or old KDE configure files. As to the problem opening a file in QCADCAM There was a problem that sounds like this one with LibraOffice It had to do with the oxygen theme.

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Having some issues with KDE4.12.4 - sound familiar to anyone?

    Here are my active repos
    ((I edited out a buch of Enabled = no stuff I keep around for ease of turning on/off))
    Code:
                                                                                                                                                                      
    #  | Alias                   | Name                         | Enabled | Refresh | Priority | Type     | URI                       |
    ---+-------------------------+------------------------------+---------+---------+----------+----------+---------------------------+
     1 | Carl_Downloads          | Carl Downloads               | Yes     | Yes     |  100     | plaindir | dir:///home/carl/Downloads        
     5 | Java:packages           | Java:packages                | Yes     | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/Java:/packages/openSUSE_13.1/
     6 | KDE:KDE3                | KDE:KDE3                     | Yes     | Yes     |   90     | rpm-md   | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_13.1/
     7 | KDE_4.12_Core           | KDE Current Core             | Yes     | Yes     |   30     | rpm-md   | http://download.opensuse.org/repositories/KDE:/Current/openSUSE_13.1/
     8 | KDE_4.12_Extras         | KDE Current Extras           | Yes     | Yes     |   31     | rpm-md   | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Current_openSUSE_13.1/
     9 | Kernel_upstream_Repo    | Kernel upstream Repo         | Yes     | Yes     |   38     | rpm-md   | http://download.opensuse.org/repositories/Kernel:/openSUSE-13.1/standard/
    11 | Oracle_Virtual_Box_Repo | Oracle Virtual Box Repo      | Yes     | Yes     |   35     | rpm-md   | http://download.virtualbox.org/virtualbox/rpm/opensuse/12.3
    13 | PlexRepo                | PlexRepo                     | Yes     | No      |   99     | rpm-md   | http://plex.r.worldssl.net/PlexMediaServer/fedora-repo/release/x86_64/
    16 | graphics                | graphics                     | Yes     | Yes     |   90     | rpm-md   | http://download.opensuse.org/repositories/graphics/openSUSE_13.1/
    21 | packman.inode.at-suse   | Packman Repository           | Yes     | Yes     |   20     | rpm-md   | http://packman.inode.at/suse/13.1/
    22 | repo-non-oss            | openSUSE-13.1-Non-Oss        | Yes     | Yes     |   50     | yast2    | http://download.opensuse.org/distribution/13.1/repo/non-oss/
    23 | repo-oss                | openSUSE-13.1-Oss            | Yes     | Yes     |   50     | yast2    | http://download.opensuse.org/distribution/13.1/repo/oss/
    24 | repo-update             | openSUSE-13.1-Update         | Yes     | Yes     |   40     | rpm-md   | http://download.opensuse.org/update/13.1/
    25 | repo-update-non-oss     | openSUSE-13.1-Update-Non-Oss | Yes     | Yes     |   40     | rpm-md   | http://download.opensuse.org/update/13.1-non-oss/
    I have not experienced this issue with any other apps myself.
    And, can now report more runtime with my system after rebuilding ~/.kde4 without a crash, so I am more optimistic in that aspect.

    So I probably should be asking: "Anyone else running third party applications with KDE 4.12.4 having similar issues?"

    The QCAD developer has provided me with instructions on how to go back to the native QT file chooser menu (what I believe gimp, inkscape and other apps) use.
    And I'll probably put up a quick 13.1 VM just to verify performance with KDE 4.11.y
    I'd prefer not to back my current environment to 4.11.y.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  5. #5
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Having some issues with KDE4.12.4 - sound familiar to anyone? *** SOLVED***

    gogalthorp
    Sounds like you had some corrupt or old KDE configure files.
    I would agree, desktop has been very stable since my rebuild of ~/.kde4.
    As to the problem opening a file in QCADCAM There was a problem that sounds like this one with LibraOffice It had to do with the oxygen theme.
    I apparently borked a file-open script in QCAD in trying to diagnose the desktop crashes that, at the time, seemed QCAD related.
    I had inserted some diagnostic code found on a 'net post.
    Removing that code did not fix the issue, but a clean reinstall of the application did work OK.

    Since I could not possibly make such a mistake, I'll attribute this to my 2yo Grandson
    who frequently provides keyboard help because "..I like to push the buttons..."
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •