I have a strange one that I've been working with Google on.

It seems that sometime in the past couple of months we could no longer print landscape documents from Chrome. I first thought it was related to the Google Drive documents we were printing. Docs created in landscape would only print portrait with the right cut off. That is except for Sheet files; they print fine because the Print dialog box has extra options to select Landscape or Portrait. I remember that they all used to have that option, but now only Sheet files have that for printing and they print landscape just fine.

Then I noticed that I can print anything from Chrome in landscape. This is true using Chrome's dialog or using the alternate Shift+Ctrl+P and passing to my oS 13.1 print dialog. So, it started to look like a Chrome browser problem. BTW, my wife's Chromebook uses the shared printer on this desktop too and also won't print landscape when it's suppose to. The way we have it setup is through Google Cloud Print to my local HP 7510. To let you know this all used to work just fine with oS 12.3 and 13.1 for a very long time.

I then tried Firefox and found it worked exactly the same - it won't print anything in landscape, even if it is landscape. So, it's telling me that it's not specific to Drive files or Chrome. The weird thing is that if I print any local file from a Linux app to the local printer in landscape. Libreoffice, Okular, GIMP, everything prints just exactly in the orientation I tell it. No problems locally at all.

So, printing locally prints landscape just as it's suppose to. Printing anything landscape from Chrome or Firefox will force it into portrait, except for Google Drive Sheet files where the extra option will tell something to do it right. Logically, it seems like it's a communication problem between the browsers and oS's printing system. Somehow, Sheet files are sending a message to the oS printing system that tells to print correctly while anything else doesn't get that landscape flag triggered.

The people I've been working with at Google support seem to have lost interest in helping as soon as I found out that it worked the same in Firefox. Any ideas? Anything I can do?

Thanks,
Clyde


PS - I have my oS 13.1 very stock. I only add stuff with YaST and accept every update that it wants to do.