Results 1 to 4 of 4

Thread: wireless only works after resuming from sleep

  1. #1

    Default wireless only works after resuming from sleep

    I have seen many threads where going to sleep and then waking will cause the wifi to stop working, but I have the opposite problem. When booting up, the wifi will not work, and when trying to enable it using the system tray icon, it will just turn right back off. Then when I put the machine to sleep and wake it up, it starts working just fine. Has anyone else encountered this problem?

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: wireless only works after resuming from sleep

    On 04/11/2014 03:26 PM, illumilore wrote:
    >
    > I have seen many threads where going to sleep and then waking will cause
    > the wifi to stop working, but I have the opposite problem. When booting
    > up, the wifi will not work, and when trying to enable it using the
    > system tray icon, it will just turn right back off. Then when I put the
    > machine to sleep and wake it up, it starts working just fine. Has anyone
    > else encountered this problem?


    Do you want help resolving a "problem", or are you just taking a survey? If the
    former, please supply basic information such as openSUSE version, desktop,
    wireless driver, method of wifi control (presumably NM), and such configuration
    questions.

    If you want to fix the problem, also post any differences between the following
    commands run before and after putting it to sleep:

    Code:
    sudo /usr/sbin/iwlist scan
    /usr/sbin/rfkill list
    If the rfkill command is not found, then 'sudo zypper install rfkill'.



  3. #3

    Default Re: wireless only works after resuming from sleep

    Quote Originally Posted by lwfinger View Post
    On 04/11/2014 03:26 PM, illumilore wrote:

    If you want to fix the problem, also post any differences between the following
    commands run before and after putting it to sleep:

    Code:
    sudo /usr/sbin/iwlist scan
    /usr/sbin/rfkill list
    If the rfkill command is not found, then 'sudo zypper install rfkill'.
    When the laptop first boots up, rfkill lists the phy0 as hard locked. If I press the wireless hotkey button that should toggle the bios control lock of the wireless on/off, rfkill then says it is only softlocked, but as soon as I click enable wireless in the kde system tray network manager, the toggle switch there briefly enables, then grays out, while rfkill then says it is now hard blocked again.

    $ sudo iwlist scan
    root's password:
    eth0 Interface doesn't support scanning.

    lo Interface doesn't support scanning.

    wlan0 Interface doesn't support scanning : Network is down

    $ rfkill list
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

  4. #4

    Default Re: wireless only works after resuming from sleep

    Quote Originally Posted by lwfinger View Post
    On 04/11/2014 03:26 PM, illumilore wrote:
    >
    > I have seen many threads where going to sleep and then waking will cause
    > the wifi to stop working, but I have the opposite problem. When booting
    > up, the wifi will not work, and when trying to enable it using the
    > system tray icon, it will just turn right back off. Then when I put the
    > machine to sleep and wake it up, it starts working just fine. Has anyone
    > else encountered this problem?


    Do you want help resolving a "problem", or are you just taking a survey? If the
    former, please supply basic information such as openSUSE version, desktop,
    wireless driver, method of wifi control (presumably NM), and such configuration
    questions.

    If you want to fix the problem, also post any differences between the following
    commands run before and after putting it to sleep:

    Code:
    sudo /usr/sbin/iwlist scan
    /usr/sbin/rfkill list
    If the rfkill command is not found, then 'sudo zypper install rfkill'.
    Is there a way to fix this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •