Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Problem updating gstreamer in 13.1

  1. #1

    Default Problem updating gstreamer in 13.1

    Good afternoon people!

    I am having a problem with updates, I suppose it goes in Multimedia but if it doesn't please move it to wherever it belongs.

    Thing is I have a package called gstreamer-0_10-plugins-bad-0.10.23-24.43.x86_64 that doesn't update since it needs libpng15.so.15()(64bit), but this last one can't be found on my repositories. A search on the internet says that it must be on the OSS repository, which I have listed in YaST, but anyway the problem still pops up.

    Apart from that my laptop runs like a charm, my concern is just that I want everything to be flawlessly updated, blame it on my mild OCD.

    Thanks for your attention, and have a nice day!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,740

    Default Re: Problem updating gstreamer in 13.1

    I have 13.1 here and I have installed Multimedia support from Packman as most do.

    gstreamer-0_10-plugins-bad is from Packman and on version 0.10.23-24.36 and I see that Packman now has 0.10.23-24.40 (I will update in due course).
    So I wonder where you have that ........24.42.X86_64 from.

    Did you do the "standard" Multimedia support installation as described in the first (sticky) thread of the Multimedia Forum?

    Do you have other repos that have this package. Thus please post
    Code:
    zypper lr -d
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem updating gstreamer in 13.1

    Quote Originally Posted by Karmovorotin View Post
    Good afternoon people!

    I am having a problem with updates, I suppose it goes in Multimedia but if it doesn't please move it to wherever it belongs.

    Thing is I have a package called gstreamer-0_10-plugins-bad-0.10.23-24.43.x86_64 that doesn't update since it needs libpng15.so.15()(64bit), but this last one can't be found on my repositories. A search on the internet says that it must be on the OSS repository, which I have listed in YaST, but anyway the problem still pops up.

    Apart from that my laptop runs like a charm, my concern is just that I want everything to be flawlessly updated, blame it on my mild OCD.

    Thanks for your attention, and have a nice day!
    I have
    gstreamer-0_10-plugins-bad-0.10.23-24.40.x86_64

    as suggested
    Lets see your repos
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Problem updating gstreamer in 13.1

    Here you are:

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+------------------------------------+-------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
    1 | FGLRX | FGLRX | Yes | Yes | 98 | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/ |
    2 | Packman | Packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_12.3 |
    3 | SuSE | SuSE | Yes | Yes | 99 | rpm-md | http://download.videolan.org/SuSE/13.1/ |
    4 | WINE | WINE | Yes | Yes | 98 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    5 | download.opensuse.org-13.1-non-oss | Update Repository (Non-Oss) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/ |
    6 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    7 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    8 | download.opensuse.org-filesystems | openSUSE BuildService - filesystems | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    9 | download.opensuse.org-games | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    10 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Yes | Yes | 98 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    11 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    12 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    13 | download.opensuse.org-update | Main Update Repository | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    14 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.1/ |
    15 | google-talkplugin | google-talkplugin | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64 |
    16 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/12.3 |
    17 | libdvdcss repository | libdvdcss repository | Yes | Yes | 98 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
    18 | opensuse-guide.org-repo | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
    19 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |
    20 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    21 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    22 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    23 | repo-oss | openSUSE-13.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    24 | repo-source | openSUSE-13.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    25 | repo-update | openSUSE-13.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    26 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | NONE | http://download.opensuse.org/update/13.1-non-oss/

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,740

    Default Re: Problem updating gstreamer in 13.1

    To begin with, this is rather unreadable. You used QUOTE tags, but you need CODE tags. It is the # button in the tool bar.

    Then I see at first glance that there are doubles there. Very many of them. Please first remove those doubles that have the same URL. And repost the new list, then we will get e a better view.
    Henk van Velden

  6. #6

    Default Re: Problem updating gstreamer in 13.1

    Sorry for the inconvenience. I am quite new to this, so first of all I thank you heartily for your help:

    Code:
    #  | Alias                              | Name                                | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
    ---+------------------------------------+-------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
     1 | FGLRX                              | FGLRX                               | Yes     | Yes     |   98     | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/                        |        
     2 | Packman                            | Packman                             | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_12.3                                   |        
     3 | SuSE                               | SuSE                                | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/13.1/                                      |        
     4 | WINE                               | WINE                                | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_13.1/     |        
     5 | download.opensuse.org-13.1-non-oss | Update Repository (Non-Oss)         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                            |        
     6 | download.opensuse.org-Extra        | openSUSE BuildService - KDE:Extra   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/          |        
     7 | download.opensuse.org-Stable       | openSUSE BuildService - LibreOffice | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_13.1/ |        
     8 | download.opensuse.org-filesystems  | openSUSE BuildService - filesystems | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_13.1/         |        
     9 | download.opensuse.org-games        | openSUSE BuildService - Games       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_13.1/               |        
    10 | download.opensuse.org-mozilla      | openSUSE BuildService - Mozilla     | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.1/             |        
    11 | download.opensuse.org-oss          | Main Repository (OSS)               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                     |        
    12 | download.opensuse.org-update       | Main Update Repository              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                    |                                                                                    
    13 | ftp.gwdg.de-suse                   | Packman Repository                  | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                     |                                                                                    
    14 | google-talkplugin                  | google-talkplugin                   | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                      |        
    15 | libdvdcss repository               | libdvdcss repository                | Yes     | Yes     |   98     | rpm-md | http://opensuse-guide.org/repo/13.1/                                         |        
    16 | repo-debug                         | openSUSE-13.1-Debug                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/               |        
    17 | repo-debug-update                  | openSUSE-13.1-Update-Debug          | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                              |        
    18 | repo-debug-update-non-oss          | openSUSE-13.1-Update-Debug-Non-Oss  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                      |        
    19 | repo-non-oss                       | openSUSE-13.1-Non-Oss               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                 |        
    20 | repo-source                        | openSUSE-13.1-Source                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,740

    Default Re: Problem updating gstreamer in 13.1

    2 and 13 are the same. You need only one Packman.

    And remove the Videolan one. It can not coexist with Packman.

    Then do the switch to Packman again (like desccribed in https://forums.opensuse.org/showthre...de#post2180319
    Part of this is already done. E.g. you have th libdvdcss and the Packman repos already. But to be sure you have all the right versions from Packman (and not from videolan), you should particulary do: http://www.imagebam.com/image/6b67e954459645/
    That is: YaST > Software > Software Manager. Then the View button to choose the Repositories View. Then click Packman at the left. Then click where the arrow points to: Switch system packages ....
    Henk van Velden

  8. #8

    Default Re: Problem updating gstreamer in 13.1

    Quote Originally Posted by hcvv View Post
    2 and 13 are the same. You need only one Packman.

    And remove the Videolan one. It can not coexist with Packman.

    Then do the switch to Packman again (like desccribed in https://forums.opensuse.org/showthre...de#post2180319
    Part of this is already done. E.g. you have th libdvdcss and the Packman repos already. But to be sure you have all the right versions from Packman (and not from videolan), you should particulary do: http://www.imagebam.com/image/6b67e954459645/
    That is: YaST > Software > Software Manager. Then the View button to choose the Repositories View. Then click Packman at the left. Then click where the arrow points to: Switch system packages ....
    Thank you! But now I lack some codecs, and besides I have had to uninstall vlc media player. And when trying to reinstall I have the very same problem, nothing provides the libpng15.so.15()(64bit). Any suggestions?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem updating gstreamer in 13.1

    Quote Originally Posted by Karmovorotin View Post
    Thank you! But now I lack some codecs, and besides I have had to uninstall vlc media player. And when trying to reinstall I have the very same problem, nothing provides the libpng15.so.15()(64bit). Any suggestions?
    Your problem has be exasperated by the use of the repo Videolan

    When you try switching on packman, and if you get a dependancy error, please use the expert button to the error to file. Then copy the file content here in the code tags again please
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Problem updating gstreamer in 13.1

    Quote Originally Posted by caf4926 View Post
    Your problem has be exasperated by the use of the repo Videolan

    When you try switching on packman, and if you get a dependancy error, please use the expert button to the error to file. Then copy the file content here in the code tags again please
    All right, here's what I got:

    Code:
    #### YaST2 conflicts list - generated 2014-04-13 10:20:32 ####
    
    nothing provides libpng15.so.15()(64bit) needed by vlc-noX-2.1.4-199.14.x86_64
    
        [ ] break vlc-noX-2.1.4-199.14.x86_64 by ignoring some of its dependencies
    
        [ ] do not install vlc-2.1.4-199.14.x86_64
    
    
    
    nothing provides libpng15.so.15 needed by gstreamer-0_10-plugins-bad-0.10.23-24.44.i586
    
        [ ] keep obsolete gstreamer-0_10-plugins-bad-0.10.23-13.1.4.i586
    
        [ ] keep obsolete gstreamer-0_10-plugins-bad-0.10.23-13.1.4.i586
    
        [ ] break gstreamer-0_10-plugins-bad-0.10.23-24.44.i586 by ignoring some of its dependencies
    
        [ ] deinstallation of gstreamer-0_10-plugins-bad-0.10.23-13.1.4.i586
    
    
    
    nothing provides libpng15.so.15 needed by libquicktime0-1.2.4-65.4.i586
    
        [ ] Following actions will be done:
    install libquicktime0-1.2.4-7.1.2.x86_64 from excluded repository
    deinstallation of libquicktime0-32bit-1.2.4-7.1.2.x86_64
        [ ] Following actions will be done:
    deinstallation of libmjpegutils-2_0-0-2.0.0-57.2.i586
    deinstallation of libquicktime0-32bit-1.2.4-7.1.2.x86_64
        [ ] keep obsolete libquicktime0-32bit-1.2.4-7.1.2.x86_64
    
        [ ] break libquicktime0-1.2.4-65.4.i586 by ignoring some of its dependencies
    
    
    
    nothing provides libMagickWand.so.5 needed by libxine2-32bit-1.2.5-90.1.x86_64
    
        [ ] Following actions will be done:
    deinstallation of libxine2-32bit-1.2.3-3.1.3.x86_64
    install libxine2-1.2.3-3.1.3.i586 from excluded repository
        [ ] keep obsolete libxine2-32bit-1.2.3-3.1.3.x86_64
    
        [ ] break libxine2-32bit-1.2.5-90.1.x86_64 by ignoring some of its dependencies
    
    
    
    
    #### YaST2 conflicts list END ###

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •