Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Apper updater problem

  1. #1

    Default Apper updater problem

    I configured Apper to not alert me of new updates (both settings are set to Never) , I also disabled Apper in Service Manager.
    That all worked fine for let's say 48 hours, then it started again to check for updates.
    I checked the settings and they are still on Never , in Service Manager it's also uncheked.
    Tried to enable it again and then turn it off, it didn't help.
    What am I missing ? How can I disable it ?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,288

    Default Re: Apper updater problem

    Deinstall it. I also deinstalled PackageManger (in fact I did not install them at system installation).
    Henk van Velden

  3. #3

    Default Re: Apper updater problem

    Quote Originally Posted by hcvv View Post
    Deinstall it. I also deinstalled PackageManger (in fact I did not install them at system installation).
    Or at least disable the "Software Updates" applet in the System Tray Settings (right-click on the small up-arrow just left of the clock to reach them, f.e.)
    AFAIK, this will still check for updates on login, even when checking is disabled.

  4. #4

    Default Re: Apper updater problem

    Quote Originally Posted by hcvv View Post
    Deinstall it. I also deinstalled PackageManger (in fact I did not install them at system installation).
    You mean packagekit ?

  5. #5

    Default Re: Apper updater problem

    Quote Originally Posted by gzenum View Post
    You mean packagekit ?
    No, apper should suffice.

    On KDE you should be able to uninstall PackageKit, but if you have GNOME installed as well you can't. Some packages necessary for GNOME depend on it.
    Code:
    sudo zypper rm PackageKit
    ...
    The following 23 packages are going to be REMOVED:
      apper apper-lang gdm gdm-branding-openSUSE gdm-lang gnome-color-manager 
      gnome-color-manager-lang gnome-control-center gnome-control-center-lang 
      gnome-session gnome-session-default-session gnome-session-lang gnome-shell 
      gnome-shell-browser-plugin gnome-shell-lang 
      gnome-shell-search-provider-contacts gnome-shell-search-provider-nautilus 
      gnome-tweak-tool gnome-tweak-tool-lang PackageKit PackageKit-backend-zypp 
      PackageKit-branding-openSUSE PackageKit-lang

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,288

    Default Re: Apper updater problem

    Quote Originally Posted by gzenum View Post
    You mean packagekit ?
    Sorry confusing you. Yes, that is what I mean. But when you like packagekit, you can keep it, it is Apper that annoys you, thus removing apper will be sufficient. That is when you also think like me that software that is not installed can not annoy you.
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,288

    Default Re: Apper updater problem

    Quote Originally Posted by wolfi323 View Post

    On KDE you should be able to uninstall PackageKit, but if you have GNOME installed as well
    Yes, people refuse to tell what they have. We do not even know what version of openSUSE he has. If it is openSUSE and not SLES/SLED (again a few today ).
    Henk van Velden

  8. #8

    Default Re: Apper updater problem

    Removing Apper did it, thanks

    It wasn't confusing but there wasn't packagemanger or packagemanager, the only thing I could think of was packagekit , I left it , for now

    I'm on OpenSuse 13.1 x86-x64 , KDE

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,801
    Blog Entries
    3

    Default Re: Apper updater problem

    Quote Originally Posted by gzenum View Post
    What am I missing ? How can I disable it ?
    If you are using KDE (and I think you are), then what you are seeing is probably the software updater in the tray.

    Right click on the tray, select "tray settings". Then uncheck the box for software updater.

    And for those who like the applet -- in my opinion, it is best to turn off Apper in "Startup & Shutdown", and rely on the try software updater.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10

    Default Re: Apper updater problem

    Quote Originally Posted by nrickert View Post
    If you are using KDE (and I think you are), then what you are seeing is probably the software updater in the tray.

    Right click on the tray, select "tray settings". Then uncheck the box for software updater.

    And for those who like the applet -- in my opinion, it is best to turn off Apper in "Startup & Shutdown", and rely on the try software updater.
    Yeah I said it later, I'm using KDE , btw is Apper shipped with Gnome or other DE's too ? I thought it was KDE exclusive.
    Like I said, "Startup & Shutdown" doesn't work.

    Anyhow, I removed packagekit as well, no problems

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •