Results 1 to 7 of 7

Thread: cannot update software

  1. #1
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Exclamation cannot update software

    Hi,

    When trying to update a message is displayed:

    package dependency could not be found.
    More information is available in the detailed report.

    I press the detail button and a message appears:

    There is no update candidate for libavformat55-2.1.1-2.1.x86_64

    Any clue ?

    Regards

    Agunet
    agunet74

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,374
    Blog Entries
    3

    Default Re: cannot update software

    Quote Originally Posted by agunet74 View Post
    There is no update candidate for libavformat55-2.1.1-2.1.x86_64
    You are more likely to get help if you indicate your opensuse version, and say what it is that you were trying to do.

    Checking here (using opensuse 13.1), I see that libavformat55 version 2.1.1-3.3-8x6_64 is installed, but the packman repo has version 2.1.1-3-8x6_64. I am not seeing any problems over this.

    Presumably, you are not running 13.1, since your version number is a bit different.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: cannot update software

    Uninstall libavfilter3 (you should have that option in zypper's conflict resolution dialog).
    ffmpeg has been upgraded to 2.2.0, and this version comes with libavfilter4. But this conflicts with libavfilter3 which is no longer needed nor available.

  4. #4
    Join Date
    Dec 2008
    Location
    Montevideo, Uruguay
    Posts
    451

    Exclamation Re: cannot update software

    I'm usiing opensuse 3.1 and actually I'm having problems updating 3 packages via apper:

    libacodec55 don't find the package libavcodec55-2.1.1-2.1.x86_64
    libaformat55 don't find the package libavformat55-2.1.1-2.1.x86_64
    libpostproc52 don't find the package libpostproc52-2.1.1-2.1.x86_64


    I really don't know what to do with these packages.

    Any help ?

    Regards

    agunet74
    agunet74

  5. #5
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: cannot update software

    Quote Originally Posted by agunet74 View Post
    I'm usiing opensuse 3.1 and actually I'm having problems updating 3 packages via apper:
    Any help ?
    Use YaST. Apper is a second best. It might be useful for those poor KDE users that do not have the benefit of SUSE/openSUSE.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,374
    Blog Entries
    3

    Default Re: cannot update software

    Quote Originally Posted by agunet74 View Post
    I'm usiing opensuse 3.1 and actually I'm having problems updating 3 packages via apper:

    libacodec55 don't find the package libavcodec55-2.1.1-2.1.x86_64
    libaformat55 don't find the package libavformat55-2.1.1-2.1.x86_64
    libpostproc52 don't find the package libpostproc52-2.1.1-2.1.x86_64
    Apper is useless when it finds problems. It just refused to update.

    In that case, use Yast online update. It give several choices for possible actions. It is usually easy to see which choice to make. But you can ask here if unsure.

    Or, use "zypper up" from a root command line. It, too, will present choices, though in a command-line interface manner.

    If I there are many updates, I usually take the choice "do not install xxx". That allows most of the updates to install. Then I restart Yast online update, with only the problem updates remaining. And then I look more closely at the problems and solution choices.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7

    Default Re: cannot update software

    Quote Originally Posted by nrickert View Post
    In that case, use Yast online update.
    No. YaST->Online updates won't update packages from Packman.

    Either use "zypper up" or YaST->Software Management.

    Or uninstall libavfilter3 via YaST or zypper as I suggested already, and Apper should be able to update all packages.
    Apper is not able to resolve conflicts, but by uninstalling libavfilter3, you remove the conflict.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •