Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Grub prompt when installing OpenSuse from USB

  1. #1

    Default Grub prompt when installing OpenSuse from USB

    Hello guys,

    I am a new user of Linux and I hope you will forgive my limited knowledge of linux. I have been using Ubuntu for sometime and now want to switch to Suse. I tried to install Opensuse 13.1 from a USB which had the 4.7GB Suse image downloaded from here: http://software.opensuse.org/131/en

    I followed the instructions on the download page and used 'dd' to copy the image into the newly formatted USB("https://en.opensuse.org/SDB:Live_USB_stick#Using_commandline_tools").

    After plugging USB into laptop, I restarted and went into BIOS. I could see UEFI is enabled and my USB was listed under EFI boot device. But when I boot into the device I am taken to the grub 2.0 command screen. I typed boot there and it said: "Error, no kernal loaded".

    I don't know how to proceed further from here. Is there a command to install Suse from there or is there something wrong with my iso or USB device.

    My laptop is Lenovo G580, Intel i5 third generation with Ubuntu 13.04 installed.

    Thank you for your help.
    Arun.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,665
    Blog Entries
    3

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by karnnan View Post
    My laptop is Lenovo G580, Intel i5 third generation with Ubuntu 13.04 installed.
    You may need to disable secure-boot in your BIOS.

    It is normal to see a grub2 boot menu. Actually, its a grub2-efi boot menu. That at least indicates that UEFI was recognized.

    I have a Lenovo desktop (ThinkServer TS140), and it does not like the way that secure-boot is handled by opensuse. I don't need secure-boot on that box, so I have it turned off. It is possible to get secure-boot to work, but not with the install media.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by nrickert View Post
    You may need to disable secure-boot in your BIOS.

    It is normal to see a grub2 boot menu. Actually, its a grub2-efi boot menu. That at least indicates that UEFI was recognized.

    I have a Lenovo desktop (ThinkServer TS140), and it does not like the way that secure-boot is handled by opensuse. I don't need secure-boot on that box, so I have it turned off. It is possible to get secure-boot to work, but not with the install media.

    Thank you for the reply. In the grub prompt just before I exit I got the message 'Secure boot not enabled'. I could not make sense of this message then.

    My laptop model does not have a secure boot option accessible from the BIOS settings. It is strange but I find that a few other also have the same problem. I am trying to find a way to somehow change it, but so far there is no success. I wonder if there is a way around this.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,665
    Blog Entries
    3

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by karnnan View Post
    Thank you for the reply. In the grub prompt just before I exit I got the message 'Secure boot not enabled'. I could not make sense of this message then.
    That means that I did not correctly diagnose the problem.

    On rereading your initial post, I may have misunderstood that, too. You should have seen a grub2-efi menu, with "Installation" as one of the options. You should not have got to a grub2 command prompt.

    Some things to check:

    Check the md5sum of the download.

    Make sure you downloaded the 64bit image (I think you must have, because the 32bit image would behave differently from what you described).

    Plug your USB into a USB2 connector, rather than a USB3 connector. I'm not sure if that matters. I used a USB3 connector, but a USB2 device. Still, it's worth trying with a USB2 port.

    If you plug in your USB device while running ubuntu, and then use "fdisk -l" on the device, it should show two partition.

    On the computer where I am typing this (not a Lenovo), it shows up as device "/dev/sdd". My output is
    Code:
    # fdisk -l /dev/sdd
    
    Disk /dev/sdd: 8004 MB, 8004304896 bytes, 15633408 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0x7e142954
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1            3764       11955        4096   ef  EFI (FAT-12/16/32)
    /dev/sdd2   *       11956     8931327     4459686   17  Hidden HPFS/NTFS
    Your output will be different, but the partitioning should be similar.

    I'm not sure what else could be wrong. Usually, if there are problems, they arise later in the boot. The first few steps of boot, up through loading a kernel, are managed through your computer's firmware.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by nrickert View Post
    That means that I did not correctly diagnose the problem.

    On rereading your initial post, I may have misunderstood that, too. You should have seen a grub2-efi menu, with "Installation" as one of the options. You should not have got to a grub2 command prompt.

    Some things to check:

    Check the md5sum of the download.

    Make sure you downloaded the 64bit image (I think you must have, because the 32bit image would behave differently from what you described).

    Plug your USB into a USB2 connector, rather than a USB3 connector. I'm not sure if that matters. I used a USB3 connector, but a USB2 device. Still, it's worth trying with a USB2 port.

    If you plug in your USB device while running ubuntu, and then use "fdisk -l" on the device, it should show two partition.

    On the computer where I am typing this (not a Lenovo), it shows up as device "/dev/sdd". My output is
    Code:
    # fdisk -l /dev/sdd
    
    Disk /dev/sdd: 8004 MB, 8004304896 bytes, 15633408 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0x7e142954
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1            3764       11955        4096   ef  EFI (FAT-12/16/32)
    /dev/sdd2   *       11956     8931327     4459686   17  Hidden HPFS/NTFS
    Your output will be different, but the partitioning should be similar.

    I'm not sure what else could be wrong. Usually, if there are problems, they arise later in the boot. The first few steps of boot, up through loading a kernel, are managed through your computer's firmware.
    Hi nrickert,
    I hadn't checked checksum before, although it turned out to be OK. However in the second step I get something different than yours:
    Code:
    # fdisk -l /dev/sdc
    
    Disk /dev/sdc: 8004 MB, 8004304896 bytes
    35 heads, 21 sectors/track, 21269 cylinders, total 15633408 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00043b28
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1              32    15633407     7816688    b  W95 FAT32
    I apparently only have one partition instead of two as you say. Does this mean the iso did not get loaded correctly?
    Thank you for the help!

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,665
    Blog Entries
    3

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by karnnan View Post
    I apparently only have one partition instead of two as you say. Does this mean the iso did not get loaded correctly?
    Yes, it looks that way.

    I'm assuming that you did use "fdisk" on the correct device.

    The web page that you say you followed, says to use:
    [code]
    dd if=/path/to/downloaded.iso of=/dev/sdX bs=4M
    [code]

    So, assuming the device is "/dev/sdc", that would become
    Code:
    dd if=/path/to/downloaded.iso of=/dev/sdc bs=4M
    It looks to me as if, instead, you used
    Code:
    dd if=/path/to/downloaded.iso of=/dev/sdc1 bs=4M
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by nrickert View Post
    Yes, it looks that way.

    I'm assuming that you did use "fdisk" on the correct device.

    The web page that you say you followed, says to use:
    [code]
    dd if=/path/to/downloaded.iso of=/dev/sdX bs=4M
    [code]

    So, assuming the device is "/dev/sdc", that would become
    Code:
    dd if=/path/to/downloaded.iso of=/dev/sdc bs=4M
    It looks to me as if, instead, you used
    Code:
    dd if=/path/to/downloaded.iso of=/dev/sdc1 bs=4M
    Yes, that is exactly what I did! So, that is the reason for the error! Thank you. I will redo it and check again. Is it that this is causing the USB to be treated as a normal USB and not an EFI device? I don't know this difference.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,665
    Blog Entries
    3

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by karnnan View Post
    Is it that this is causing the USB to be treated as a normal USB and not an EFI device? I don't know this difference.
    Yes, it is not seen as an EFI device.

    Let us know how it works out once you get the USB straightened out.

    By the way -- there's no need to reformat the USB before the "dd". You can just use it as it is, do the "dd" and try installing.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,285

    Default Re: Grub prompt when installing OpenSuse from USB

    In this case you want to write the image to the device not to a partition. The image is the partition(s)

  10. #10

    Default Re: Grub prompt when installing OpenSuse from USB

    Quote Originally Posted by nrickert View Post
    Yes, it looks that way.

    I'm assuming that you did use "fdisk" on the correct device.

    The web page that you say you followed, says to use:
    [code]
    dd if=/path/to/downloaded.iso of=/dev/sdX bs=4M
    [code]

    So, assuming the device is "/dev/sdc", that would become
    Code:
    dd if=/path/to/downloaded.iso of=/dev/sdc bs=4M
    It looks to me as if, instead, you used
    Code:
    dd if=/path/to/downloaded.iso of=/dev/sdc1 bs=4M
    I was running into the same issue, and this is exactly what I was doing (using of=/dev/sdf1 instead of just sdf). Using dd correctly to the device (not partition) resolved the issue and I was able to boot off of the USB getting the normal menu. Currently going through the installation now. Thanks for the help!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •