Results 1 to 6 of 6

Thread: libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

  1. #1

    Default libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

    I seem to keep getting this error quite a bit, here is an example:

    glxinfo
    name of display: :0
    libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (/usr/lib64/dri/updates/radeonsi_dri.so: cannot open shared object file: No such file or directory)

  2. #2

    Default Re: libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

    Quote Originally Posted by ryanbach View Post
    I seem to keep getting this error quite a bit, here is an example:

    glxinfo
    name of display: :0
    libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (/usr/lib64/dri/updates/radeonsi_dri.so: cannot open shared object file: No such file or directory)
    Are you using the radeon or the fglrx driver?

    The Mesa package includes /usr/lib64/dri/radeonsi_dri.so, so it should not matter that /usr/lib64/dri/updates/radeonsi_dri.so is not there (actually it shouldn't even be there).
    Which version do you have installed?
    Oh, and specifying which openSUSE version and graphics card you are using would be a good idea as well.
    Last edited by wolfi323; 08-Apr-2014 at 00:58.

  3. #3

    Default Re: libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

    Quote Originally Posted by wolfi323 View Post
    Are you using the radeon or the fglrx driver?

    The Mesa package includes /usr/lib64/dri/radeonsi_dri.so, so it should not matter that /usr/lib64/dri/updates/radeonsi_dri.so is not there (actually it shouldn't even be there).
    Which version do you have installed?
    Oh, and specifying which openSUSE version and graphics card you are using would be a good idea as well.
    Opensuse Factory, AMD Radeon 270x

    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.1.0
    OpenGL core profile shading language version string: 1.40

    I believe the issue I am having is the libgl error:

    glxgears
    libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (/usr/lib64/dri/updates/radeonsi_dri.so: cannot open shared object file: No such file or directory)

  4. #4

    Default Re: libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

    Quote Originally Posted by ryanbach View Post
    Opensuse Factory, AMD Radeon 270x
    So it is Factory, not 13.2 Milestone0, right?

    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN
    OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.1.0
    OpenGL core profile shading language version string: 1.40
    OK, so that's the radeon driver.

    I believe the issue I am having is the libgl error:

    glxgears
    libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (/usr/lib64/dri/updates/radeonsi_dri.so: cannot open shared object file: No such file or directory)
    As I said, Mesa does contain radeonsi_dri.so, in /usr/lib64/dri/. Do you have that?
    That it isn't found in /usr/lib64/dri/updates/ should not matter, that directory is just for overriding stuff in /usr/lib64/dri/.
    /usr/lib64/dri/updates/ is completely empty (except for a README file) even on my 13.1 system.

    That message is just debug output, it is not the cause of your issue.

    What exactly is your issue, btw?
    If it's just this message, ignore it.

    I just tried the latest Factory KDE LiveCD (timestamped April 1st, it contains Mesa-10.1.0), glxinfo (and OpenGL) works fine on my Radeon 9600 (RV350).
    I do get the same message as you (about /usr/lib64/dri/updates/r300_dri.so of course), but otherwise there are no problems AFAICT.
    Last edited by wolfi323; 09-Apr-2014 at 01:22.

  5. #5

    Default Re: libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

    Quote Originally Posted by wolfi323 View Post
    So it is Factory, not 13.2 Milestone0, right?


    OK, so that's the radeon driver.


    As I said, Mesa does contain radeonsi_dri.so, in /usr/lib64/dri/. Do you have that?
    That it isn't found in /usr/lib64/dri/updates/ should not matter, that directory is just for overriding stuff in /usr/lib64/dri/.
    /usr/lib64/dri/updates/ is completely empty (except for a README file) even on my 13.1 system.

    That message is just debug output, it is not the cause of your issue.

    What exactly is your issue, btw?
    If it's just this message, ignore it.

    I just tried the latest Factory KDE LiveCD (timestamped April 1st, it contains Mesa-10.1.0), glxinfo (and OpenGL) works fine on my Radeon 9600 (RV350).
    I do get the same message as you (about /usr/lib64/dri/updates/r300_dri.so of course), but otherwise there are no problems AFAICT.
    Just this error nothing else causing an issue.

  6. #6

    Default Re: libGL error: dlopen /usr/lib64/dri/updates/radeonsi_dri.so failed (mesa bug?)

    Quote Originally Posted by ryanbach View Post
    Just this error nothing else causing an issue.
    OK, then ignore it as I said.
    It is not really an error.

    As Factory is the development and testing branch for the next openSUSE version (I hope you know that ), it's not really surprising that it would have additional debug output enabled.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •