Results 1 to 7 of 7

Thread: Slight distortion with mic and playback audio

  1. #1

    Default Slight distortion with mic and playback audio

    Hey everybody, I've just installed a fresh copy of openSUSE 13.1 and things have been going great but I've noticed a small issue. I like to use Google Hangouts to talk to my friends and everytime I join a call for about 3-5 seconds, I get this strange distortion on the playback stream. Also, my friend has said that there is a little bit of distortion on my mic in comparison to before when I was using Windows. I did an lsmod | grep realtek and noticed that the modules for the realtek sound drivers were loaded (I haven't installed anything myself, just using the default audio) but should I install something else? Like a seperate build of drivers that would improve the quality of the audio?

    Thanks,
    Simon

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Slight distortion with mic and playback audio

    I don't really know the answer.
    But, you should explain

    1. Are you using KDE or Gnome
    2. Have you experienced any issue with audio playback such as with Music?
    3. Have you installed the multimedia stuff?
    4. What web browser are you using? (Could you try Chrome?)
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Slight distortion with mic and playback audio

    Quote Originally Posted by caf4926 View Post
    I don't really know the answer.
    But, you should explain

    1. Are you using KDE or Gnome
    2. Have you experienced any issue with audio playback such as with Music?
    3. Have you installed the multimedia stuff?
    4. What web browser are you using? (Could you try Chrome?)
    I'm using KDE, Youtube videos and Music have no playback issues what so ever, not sure quite what you mean by multimedia stuff and I'm currently using Chrome.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Slight distortion with mic and playback audio

    Do you obtain that same distortion if you record audio with a different application that uses pulse audio , and with a different application that does not use pulse audio ? Or do you get it in both cases ?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Slight distortion with mic and playback audio

    Multimedia stuff = https://forums.opensuse.org/entry.ph...allation-Guide

    Have you tried other browsers?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Slight distortion with mic and playback audio

    Quote Originally Posted by oldcpu View Post
    Do you obtain that same distortion if you record audio with a different application that uses pulse audio , and with a different application that does not use pulse audio ? Or do you get it in both cases ?
    Yes, the quality of the recording is superior to the quality of the call in Hangouts. There are very minute clicks/pops but they are almost indistinguishable.

    Quote Originally Posted by caf4926 View Post
    Multimedia stuff = https://forums.opensuse.org/entry.ph...allation-Guide

    Have you tried other browsers?
    I've installed the Multimedia stuff via Packman.
    I've tried Firefox and Iceweasel with the same result.

    Now, I've noticed something very strange. When I initiate a call or another party initiates a call with me and I pick up or they pick up, there is distortion on the playback stream for about 5 seconds. Then, it disappears completely and the sound is fine. However, if I use Skype this issue does not occur and if I leave Skype running in the the background while I call or the other party calls me with Hangouts, the issue does not occur.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Slight distortion with mic and playback audio

    These issues are usually tricky to pin down.

    KDE in particular can be a little more so than Gnome.

    I'm reluctant to encourage too much delving as it's always possible it could get worse.

    But I'll say this:
    In KDE system settings in the Multimedia section and Audio is where I might start looking
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •