Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

  1. #1

    Default Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Liebe Leute!

    Wenn ich meinen Rechner per "Verlassen - Herunterfahren" abschalten will, schafft es openSUSE 13.1 leider nur, die Festplatte zu stoppen - der Bildschirm und das Motherboard (samt Rest) laufen aber weiter. Ich muss dann immer manuell auf den An/Aus-Schalter drücken, damit er richtig herunterfährt. Hat jemand eine Idee, wie ich das ändern kann?

    Beim Ruhezustand ebenso: Er packt es nicht, brav den Bildschirm, Festplatten, Board und Lüfer in einen ordentlichen Ruhezustand zu versetzen. Sind das vllt. Treiberprobleme?

    Besten Gruß

  2. #2

    Default AW: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by Susesuser View Post
    Beim Ruhezustand ebenso: Er packt es nicht, brav den Bildschirm, Festplatten, Board und Lüfer in einen ordentlichen Ruhezustand zu versetzen. Sind das vllt. Treiberprobleme?
    Möglich.

    Welche Grafikkarte hast du denn? Und welchen Treiber?
    Das ist eigentlich meistens die Ursache bei sowas, denke ich.

    Bezüglich Runterfahren: Gehts, wenn du das aufrufst?
    Code:
    systemctl poweroff
    Code:
    systemctl suspend
    könntest du auch mal probieren, um zu sehen ob das ein tieferliegendes Problem ist, oder doch was in KDE.

  3. #3

    Default Re: AW: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by wolfi323 View Post
    Möglich.

    Welche Grafikkarte hast du denn? Und welchen Treiber?
    Das ist eigentlich meistens die Ursache bei sowas, denke ich.
    Ich habe eine Radeon HD 4850 verbaut. Ich hatte neulich den Versuch unternommen, den Originaltreiber von AMD zu installieren, musste dann aber feststellen, dass der für openSUSE 13.1 nicht angeboten wird:

    http://www.sebastian-siebert.de/2013...-installieren/

    Bezüglich Runterfahren: Gehts, wenn du das aufrufst?
    Code:
    systemctl poweroff
    Code:
    systemctl suspend
    könntest du auch mal probieren, um zu sehen ob das ein tieferliegendes Problem ist, oder doch was in KDE.
    Also beim "poweroff" läuft die Sache ab, wie über das Startmenü. Er bringt mich zum leeren grauen Systembildschirm (mit dem Chamäleon und dem grünen Baum) und schaltet meine Festplatte hörbar ab - dann passiert nichts mehr.

    Bei "suspend" macht er leider gar nichts. Wenn ich Ruhezustand über das Startmenü aufrufe, schafft er es immerhin mich abzumelden.

    Besten Gruß

  4. #4

    Default Re: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by Susesuser View Post
    Ich habe eine Radeon HD 4850 verbaut. Ich hatte neulich den Versuch unternommen, den Originaltreiber von AMD zu installieren, musste dann aber feststellen, dass der für openSUSE 13.1 nicht angeboten wird:
    Ja. Diese Karte wird vom fglrx Treiber schon seit längerem nicht mehr unterstützt.
    Und der Legacy Treiber, der sie unterstützen würde, funktioniert seit openSUSE 12.3 nicht mehr. (zu neuer Kernel, zu neues Xorg)

    Also beim "poweroff" läuft die Sache ab, wie über das Startmenü. Er bringt mich zum leeren grauen Systembildschirm (mit dem Chamäleon und dem grünen Baum) und schaltet meine Festplatte hörbar ab - dann passiert nichts mehr.

    Bei "suspend" macht er leider gar nichts. Wenn ich Ruhezustand über das Startmenü aufrufe, schafft er es immerhin mich abzumelden.
    OK, dann ists also kein KDE Problem.

    Hm, du könntest vielleicht mal den aktuellsten Kernel probieren:
    http://software.opensuse.org/downloa...kernel-desktop

    Der alte Kernel bleibt trotzdem installiert, du solltest ihn im Bootmenü unter "Erweiterte Optionen" finden, falls es Probleme beim Booten mit dem neuen Kernel geben sollte.

  5. #5

    Default Re: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by wolfi323 View Post
    Hm, du könntest vielleicht mal den aktuellsten Kernel probieren:
    http://software.opensuse.org/downloa...kernel-desktop
    Das hat leider nicht geholfen. Nichtsdestotrotz vielen Dank für den Vorschlag.

  6. #6

    Default Re: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by Susesuser View Post
    Das hat leider nicht geholfen. Nichtsdestotrotz vielen Dank für den Vorschlag.
    Schade.
    Funktioniert das Herunterfahren eigentlich, wenn du den Recovery Mode/Wiederherstellungsmodus unter "Advanced Options"/"Erweiterte Optionen" bootest?

  7. #7
    Join Date
    Aug 2010
    Location
    Hessens Herz
    Posts
    35

    Cool AW: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Hallo Susesuser

    Quote Originally Posted by Susesuser View Post
    Hat jemand eine Idee, wie ich das ändern kann?
    Sind das vllt. Treiberprobleme?
    Ist denn die CPU dazu fähig?
    Und ist der Dämon dafür gestartet?

    Zeig doch mal was hierbei ausgegeben wird:
    Code:
    grep acpi /proc/cpuinfo
    rpm -qa|grep acpi
    Bei Linux haben wir Module, Treiber ist was für Windows.

    Lieben Gruß aus Hessen

  8. #8

    Default Re: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by Herz-von-Hessen View Post
    Ist denn die CPU dazu fähig?
    Und ist der Dämon dafür gestartet?
    Welcher Dämon?
    Falls du acpid meinst, der wird _nicht_ benötigt, und seit 13.1 standardmäßig nicht mal mehr installiert.


    Zeig doch mal was hierbei ausgegeben wird:
    Code:
    grep acpi /proc/cpuinfo
    Äh, das ergibt bei mir _keine_ Ausgabe, mein System schaltet sich aber trotzdem einwandfrei ab. Und auch Suspend/Hibernate und Resume funktionieren ohne Probleme.

    Bei Linux haben wir Module, Treiber ist was für Windows.
    Ach so?
    Seit wann gibts bei Linux _keine_ Treiber?

    Wie würdest du dann z.B. die Sachen bezeichnen die in den "xorg-x11-driver-*" Paketen enthalten sind?
    Und nur weil etwas als Kernel-Modul implementiert ist, heißt das nicht dass es kein "Treiber" sein kann.

  9. #9
    Join Date
    Aug 2010
    Location
    Hessens Herz
    Posts
    35

    Cool AW: Re: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Hallo wolfi323,

    Quote Originally Posted by wolfi323 View Post
    Welcher Dämon?
    Falls du acpid meinst, der wird _nicht_ benötigt, und seit 13.1 standardmäßig nicht mal mehr installiert.
    Hmm wieso sieht das bei mir dann so aus?:

    Code:
    rpm -qa | grep acpi
    acpid-2.0.19-4.4.1.x86_64
    acpica-20130823-6.2.x86_64
    acpi-1.5-15.1.2.x86_64
    Quote Originally Posted by wolfi323 View Post
    Äh, das ergibt bei mir _keine_ Ausgabe, mein System schaltet sich aber trotzdem einwandfrei ab. Und auch Suspend/Hibernate und Resume funktionieren ohne Probleme.
    Merkwürdig ist das dann erst Recht.

    Quote Originally Posted by wolfi323 View Post
    Seit wann gibts bei Linux _keine_ Treiber?
    Ich wehre mich gegen die Bezeichnung, weil die Funktion auf einem GNU/Linux-System ganz anders umgesetzt wird als dies bei Windows der Fall ist.
    Wir können im laufenden Betrieb das Treibermodul laden und entladen, bei Windows geht das nicht ohne einen Neustart des Systems.

    Lieben Gruß aus Hessen

  10. #10

    Default Re: Herunterfahren und Ruhezustand funktionieren nicht wie gewünscht.

    Quote Originally Posted by Herz-von-Hessen View Post
    Hmm wieso sieht das bei mir dann so aus?:

    Code:
    rpm -qa | grep acpi
    acpid-2.0.19-4.4.1.x86_64
    acpica-20130823-6.2.x86_64
    acpi-1.5-15.1.2.x86_64
    acpid war in früheren openSUSE-Versionen standardmäßig installiert.
    Bei einem Upgrade bleibt das Paket natürlich installiert.

    Bei einer Neu-Installation von 13.1 (und auch schon 12.3) wird es jedoch _nicht_ installiert, weil die Funktionalität inzwischen von systemd übernommen wurde.

    acpi sind irgendwelche Kommandozeilen-Tools, hab ich auf meinem System auch nicht installiert.

    acpica hab ich hier, aber das sollte fürs Herunterfahren/Suspend auch nicht notwendig sein.
    Paketbeschreibung:
    This is a set of tools to display and debug your BIOS ACPI tables
    Merkwürdig ist das dann erst Recht.
    Wieso?
    Das Ausschalten des Rechners und ACPI hat _nichts_ mit der CPU zu tun, das ist mehr eine Funktion des Mainboards/Netzteils/BIOS, würd ich sagen.

    Also, vermutlich ist das ein Problem des BIOS.
    Evtl. gibts da ein Update, das hilft.

    Oder vielleicht bringen gewisse Kernel-Optionen Besserung, z.B. "acpi_osi=Linux" oder "acpi_osi=Windows".

    Ich wehre mich gegen die Bezeichnung, weil die Funktion auf einem GNU/Linux-System ganz anders umgesetzt wird als dies bei Windows der Fall ist.
    Wir können im laufenden Betrieb das Treibermodul laden und entladen, bei Windows geht das nicht ohne einen Neustart des Systems.
    Das stimmt natürlich.

    Aber der Begriff "Treiber" sagt ja nicht wirklich was über die Umsetzung aus. Ein "Treiber" ist halt notwendig um ein bestimmtes Gerät zu "betreiben".
    Last edited by wolfi323; 24-Apr-2014 at 01:02.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •