Results 1 to 7 of 7

Thread: Runtime branding vs runtime upstream

  1. #1

    Default Runtime branding vs runtime upstream

    Hello all.

    It has been a while since I have had any issues, with Tumbleweed, but here goes...

    Is it safe to replace the upstream kdelibs4-workspace/runtime-branding-openSUSE with the upstream packages from Tumbleweed? I am getting some issues when trying to upgrade.

    Output of zypper lr -u

    Code:
    #  | Alias                    | Name                                                | Enabled | Refresh | URI                                                                               ---+--------------------------+-----------------------------------------------------+---------+---------+-----------------------------------------------------------------------------------
     1 | KDE:Extra                | KDE:Extra                                           | Yes     | Yes     | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/         
     2 | LibreOffice_Stable       | Stable Version of LibreOffice (openSUSE_Tumbleweed) | Yes     | Yes     | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/
     3 | Tumbleweed               | Tumbleweed                                          | Yes     | Yes     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/          
     4 | google-chrome            | google-chrome                                       | Yes     | Yes     | http://dl.google.com/linux/chrome/rpm/stable/x86_64                               
     5 | google-musicmanager      | google-musicmanager                                 | Yes     | Yes     | http://dl.google.com/linux/musicmanager/rpm/stable/x86_64                         
     6 | google-talkplugin        | google-talkplugin                                   | Yes     | Yes     | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                           
     7 | openSUSE Current OSS     | openSUSE Current OSS                                | Yes     | Yes     | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/              
     8 | openSUSE Current non-OSS | openSUSE Current non-OSS                            | Yes     | Yes     | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/          
     9 | openSUSE Current updates | openSUSE Current updates                            | Yes     | Yes     | http://download.opensuse.org/update/openSUSE-current/                             
    10 | openSUSE_non-oss-current | openSUSE Current non-OSS updates                    | Yes     | Yes     | http://download.opensuse.org/update/openSUSE-non-oss-current/                     
    11 | packman-essentials       | packman-essentials                                  | Yes     | Yes     | http://packman.inode.at/suse/openSUSE_Tumbleweed/Essentials                       
    12 | security                 | security                                            | Yes     | Yes     | http://download.opensuse.org/repositories/security/openSUSE_13.1/

  2. #2

    Default Re: Runtime branding vs runtime upstream

    So, I pulled the trigger. What happens is that all of the openSUSE interface customizations disappear.


    I was able to re-create most of them manually. Which raises a question--is there a reason wallpaper/splash screen/login screen etc have to be haed dependencies? It seems to me we would just need an RPM to dump the various files where they belong, correct?

    Quote Originally Posted by Thiudans View Post
    Hello all.

    It has been a while since I have had any issues, with Tumbleweed, but here goes...

    Is it safe to replace the upstream kdelibs4-workspace/runtime-branding-openSUSE with the upstream packages from Tumbleweed? I am getting some issues when trying to upgrade.

    Output of zypper lr -u

    Code:
    #  | Alias                    | Name                                                | Enabled | Refresh | URI                                                                               ---+--------------------------+-----------------------------------------------------+---------+---------+-----------------------------------------------------------------------------------
     1 | KDE:Extra                | KDE:Extra                                           | Yes     | Yes     | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/         
     2 | LibreOffice_Stable       | Stable Version of LibreOffice (openSUSE_Tumbleweed) | Yes     | Yes     | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/
     3 | Tumbleweed               | Tumbleweed                                          | Yes     | Yes     | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/          
     4 | google-chrome            | google-chrome                                       | Yes     | Yes     | http://dl.google.com/linux/chrome/rpm/stable/x86_64                               
     5 | google-musicmanager      | google-musicmanager                                 | Yes     | Yes     | http://dl.google.com/linux/musicmanager/rpm/stable/x86_64                         
     6 | google-talkplugin        | google-talkplugin                                   | Yes     | Yes     | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                           
     7 | openSUSE Current OSS     | openSUSE Current OSS                                | Yes     | Yes     | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/              
     8 | openSUSE Current non-OSS | openSUSE Current non-OSS                            | Yes     | Yes     | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/          
     9 | openSUSE Current updates | openSUSE Current updates                            | Yes     | Yes     | http://download.opensuse.org/update/openSUSE-current/                             
    10 | openSUSE_non-oss-current | openSUSE Current non-OSS updates                    | Yes     | Yes     | http://download.opensuse.org/update/openSUSE-non-oss-current/                     
    11 | packman-essentials       | packman-essentials                                  | Yes     | Yes     | http://packman.inode.at/suse/openSUSE_Tumbleweed/Essentials                       
    12 | security                 | security                                            | Yes     | Yes     | http://download.opensuse.org/repositories/security/openSUSE_13.1/

  3. #3

    Default Re: Runtime branding vs runtime upstream

    Quote Originally Posted by Thiudans View Post
    I was able to re-create most of them manually. Which raises a question--is there a reason wallpaper/splash screen/login screen etc have to be haed dependencies? It seems to me we would just need an RPM to dump the various files where they belong, correct?
    Yes, and those RPMs are the xxx-branding-openSUSE and xxx-branding-upstream RPMs, *-openSUSE for openSUSE's configuration defaults (f.e. kdebase4-workspace-branding-openSUSE) and *-upstream for upstream's (KDE in this case) default configuration.

    To your original problem: the KDE *-branding-openSUSE packages are missing in Tumbleweed at the moment (since the KDE repo switch to KDE:Current) because of failing builds.
    Be patient, they should reappear soon, hopefully.

    See also the following mailinglist threads:
    http://lists.opensuse.org/opensuse-f.../msg00196.html
    http://lists.opensuse.org/opensuse-k.../msg00045.html

  4. #4

    Default Re: Runtime branding vs runtime upstream

    OK. But do these packages need to be dependencies for pretty much all of KDE?

    Quote Originally Posted by wolfi323 View Post
    Yes, and those RPMs are the xxx-branding-openSUSE and xxx-branding-upstream RPMs, *-openSUSE for openSUSE's configuration defaults (f.e. kdebase4-workspace-branding-openSUSE) and *-upstream for upstream's (KDE in this case) default configuration.To your original problem: the KDE *-branding-openSUSE packages are missing in Tumbleweed at the moment (since the KDE repo switch to KDE:Current) because of failing builds.Be patient, they should reappear soon, hopefully.See also the following mailinglist threads:http://lists.opensuse.org/opensuse-f.../msg00196.htmlhttp://lists.opensuse.org/opensuse-k.../msg00045.html

  5. #5

    Default AW: Re: Runtime branding vs runtime upstream

    Quote Originally Posted by Thiudans View Post
    OK. But do these packages need to be dependencies for pretty much all of KDE?
    They aren't.

    But kdebase4-workspace-branding is a requirement of kdebase4-workspace f.e. and if you follow the whole dependency chain, most of KDE gets downgraded when you downgrade the branding packages.

    Anyway, the problem here is that the Tumbleweed maintainer added the 13.2 branding packages to Tumbleweed, but desktop-data-openSUSE is NOT in Tumbleweed and the 13.1 package requires wallpaper-branding-13.1.
    That caused this conflict.
    The cause is known, and it will hopefully be fixed tomorrow.

  6. #6

    Default Re: Runtime branding vs runtime upstream

    According to http://lists.opensuse.org/opensuse-f.../msg00207.html the issue has been resolved.
    The KDE packages in Tumbleweed should now require the 13.1 branding as it's supposed to be.

    So you should be able to install the *-branding-openSUSE again (from openSUSE-Current-Updates).

  7. #7

    Default Re: Runtime branding vs runtime upstream

    Thanks.

    I re-installed the openSUSE branding packages, which downgraded me to KDE 4.11.5. After a reboot ran a dup and I am back at 4.12.4. After reboot everything looks OK.



    Quote Originally Posted by wolfi323 View Post
    According to http://lists.opensuse.org/opensuse-f.../msg00207.html the issue has been resolved.
    The KDE packages in Tumbleweed should now require the 13.1 branding as it's supposed to be.

    So you should be able to install the *-branding-openSUSE again (from openSUSE-Current-Updates).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •